RPCS3 Forums

Full Version: Demon's Souls [BLES00932]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
Playable:


Settings:
PPU LLVM Recompiler
SPU ASMJIT Recompiler
SPU loop detection: On
Preferred SPU Threads: 4 (probably but you have to test to see what's better for your CPU)
SPU delay penalty: 0 (config.yml only setting for now)
OpenGL or Vulkan (faster) + Write Color Buffers + Invalidate cache every frame

Known issues:
Very very rarely loading screens may look like they have locked up, but the game will recover after ~30 seconds.

Historical blog post from when the game first stared working: https://rpcs3.net/blog/2017/03/11/des/
Moving to ingame

Bathory

(01-23-2017, 07:59 PM)ssshadow Wrote: [ -> ]Works well but a little slow. See this post: https://rpcs3.net/blog/2017/03/11/des/

I'm unable to run the game. It loads (can be booted) but nothing is seem on the screen (black screen with 30 fps. I'm using the most recent build, but I'm getting these errors (no need for the entire log I guess, as this is the only kind of error I get):
[redacted console spam]
Using PPU and SPU as Interpreter (Fast) + OpenGL

Vergil

Tried running the game with the version provided at the end of the article.

lib problem at the beginning and some kind of a mem problem after booting the game. The debugger keeps spamming "sys_fs: sys_fs_open" and "cellFsOpen" until stopping the game while running a black screen at 30 fps.

Were the changes / fixes mentioned in the article compiled into the the build or I'm supposed to do that myself?

This is my first try at launching a game with RPCS3, so maybe I'm just missing something pretty basic.

PS: I checked multiple dev_flash packs and PS3 update files and none of them have a lib called "cellLibprof".

[redacted console spam]
Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Bathory

(03-12-2017, 05:55 PM)ssshadow Wrote: [ -> ]Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked
(03-12-2017, 06:11 PM)Bathory Wrote: [ -> ]
(03-12-2017, 05:55 PM)ssshadow Wrote: [ -> ]Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked

Check if the file PS3_DISC.sfb exists next to the folder PS3_GAME and not somewhere else. If it is somewhere else move it to the correct location.

Vergil

(03-12-2017, 05:55 PM)ssshadow Wrote: [ -> ]Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Works now. Borrowed the US version instead of the EU.

Interpreter fast on (PPU)
ASMJIT (SPU)
Load auto
Vulkan
1280x720

~20 fps on a 16 core 2.8 GHz Xeon

Bathory

(03-12-2017, 06:57 PM)ssshadow Wrote: [ -> ]
(03-12-2017, 06:11 PM)Bathory Wrote: [ -> ]
(03-12-2017, 05:55 PM)ssshadow Wrote: [ -> ]Both of you, read this: http://www.emunewz.net/forum/showthread.php?tid=171465
And this: https://rpcs3.net/quickstart

Attach the full log file rpcs3.log by putting it in a .zip. Console output is useless.

Here's the log.

RPCS3 config:
PPU = Interpreter (Fast)
SPU = Interpreter (Fast)
Load required libraries = checked

Check if the file PS3_DISC.sfb exists next to the folder PS3_GAME and not somewhere else. If it is somewhere else move it to the correct location.
I've found the solution, based on your answer. The file was in the correct folder, but the extension was sfb.txt, I just had to remove the .txt and the game loaded. Thx for your help

Vergil

Only worked first time.

Menu and everything works, but no ingame graphics are displayed. Looks like this.


[Image: souls6.jpg]
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31