Hello There, Guest! Register

Diablo 3 [BLES01921]
#1
RPCS3 v0.0.3-9-0f407a2 Alpha
White screen only.
Reply
#2
Tested on recent master commit 77f58326. Use "Load liblv2.sprx only" to run it (thanks to ZEROx for hint! Tongue) Requires minor hack in cellSysutilAvc2.cpp to get ingame.

Replace
Code:
fmt::throw_exception("Unimplemented" HERE);
to
Code:
UNIMPLEMENTED_FUNC(cellSysutilAvc2); return CELL_OK;


Reply
#3
(08-01-2017, 01:31 AM)BlackDaemon Wrote: Tested on recent master commit 77f58326. Use "Load liblv2.sprx only" to run it (thanks to ZEROx for hint! Tongue) Requires minor hack in cellSysutilAvc2.cpp to get ingame.

Replace
Code:
fmt::throw_exception("Unimplemented" HERE);
to
Code:
UNIMPLEMENTED_FUNC(cellSysutilAvc2); return CELL_OK;


please send for me hacked rpcs3
[email protected]
Reply
#4
At 20-08-2017 build:
1. It reaches to "Press START" only in sandboxie (after it crashes with reference to opengl 4 - i have VERY bad videocard, so I trying boot to menus atleast). I don't know why, emulator places in C:\PS3\EmuCR-rpcs3-v0.0.3-2017-08-20_win64. In usual launch - it freezes(FPS stuck) on avtosave indicator.
2. After EVERY try you need to:
a. Delete shader cache from gamedata and game - without it game stuck on autosave indicator.
b. Delete gamedata - without it game don't boot at all (white screen)
Also:
for some reason it not always create cache in hdd1\cache - sometimes (usually in sandboxie) it contains files, summary size from 300MB to 1,5GB. Sometimes - several files sized 0 kb etc.
30-09-2017 results:
I got this game to Ingame. Settings: CPU SPU Loop Detect is unchecked, GPU OGL all checkboxes unchecked. Very slow (becuase of laptop CPU and GPU).
Reply
#5
It's working for me, when i uncheck "Enable SPU Loop Detection". The textures are really bad and it's lagging like hell, but it's working Big Grin
Reply
#6
RPCS3 v0.0.4-6355-c8965564e Alpha | HEAD

IN-GAME

Low FPS + Colors are messed up...

   

LOG:

.rar   DIABLO 3 - INGAME LOG RPCS3.rar (Size: 1.14 MB / Downloads: 6)
Reply
#7
Emulator Version: RPCS3 v0.0.5-6545-d13584f85 Alpha
Game Status: Ingame

PPU/SPU Decoder: Recompiler
GPU: Vulkan.
XAudio: Downmix to Stereo: false
I/O: XInput
System: Language: Italian, Enable /host_root/: true

Everything else as Default configuration. FW used 4.81

Notes:
1. Shaders cache often gets corrupted resulting in either a freeze or a shader compile loop (end lines of the log).
2. Way better FPS than before. When the issue above and the colors will get fixed this will probably be playable.


Attached Files Thumbnail(s)
   

.gz   RPCS3.log.gz (Size: 2.98 MB / Downloads: 5)
Intel Core i7-3770 (OC: ~4.2GHz) | 8GB DDR3 1333MHz | Zotac Mini GTX 1060 6GB
Reply
#8
RPCS3 v0.0.5-7586-c50d459b Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 31.93 GiB RAM | AVX+ | TSX

Still plagued with MEM Access violation errors and random freezes. Not just this version, all versions of Diablo 3 and RoS xpac are riddled with MEM: Access violation errors. I hope they fix that soon. Very hard to test this game when it does this regularly.

F {SPU[0x2000004] Thread (CellSpursKernel4) [0x05ce8]} MEM: Access violation writing location 0xffdead00
F {SPU[0x2000003] Thread (CellSpursKernel3) [0x05c4c]} MEM: Access violation writing location 0x0
F {SPU[0x2000001] Thread (CellSpursKernel1) [0x05ce8]} MEM: Access violation writing location 0xffdead00
F {SPU[0x2000005] Thread (CellSpursKernel5) [0x05ce8]} MEM: Access violation writing location 0xffdead00
F {SPU[0x2000002] Thread (CellSpursKernel2) [0x05ce8]} MEM: Access violation writing location 0xffdead00

or this:

F {SPU[0x2000003] Thread (CellSpursKernel3) [0x05ce8]} MEM: Access violation writing location 0xffdead00
E {SPU[0x2000004] Thread (CellSpursKernel4) [0x04da0]} SPU: Trampoline simplified at 0x4da0 (level=2)
F {SPU[0x2000001] Thread (CellSpursKernel1) [0x04da4]} class std::runtime_error thrown: Unknown STOP code: 0x7 (Out_MBox is empty)
(in file c:\projects\rpcs3\rpcs3\emu\cell\sputhread.cpp:2388)


Log attached, which hopefully assists the devs.
Reply
#9
If you ever get this error:
F {SPU[0x2000001] Thread (CellSpursKernel1) [0x04da4]} class std::runtime_error thrown: Unknown STOP code: 0x7 (Out_MBox is empty)
(in file c:\projects\rpcs3\rpcs3\emu\cell\sputhread.cpp:2388)

you can just hit resume button in rpcs3 (with the play icon) and the game will start running again. Generally it will crash soon after, but you never know.
Reply
#10
RPCS3 v0.0.5-7732-5ed71811 Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 31.93 GiB RAM | AVX+ | TSX

Still MEM Violation access crash at random. Lucky to get 10 minutes out of it before it freezes.

I wish this could be fixed - it plagues ALL versions of Diablo 3 and Red Alert 3.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)