Demon's Souls [BLUS30443]
Started by Renusek




55 posts in this topic
Renusek
Member


0
41 posts 19 threads Joined: Aug 2017
01-27-2017, 03:44 AM -
#1
Works well but a little slow. See this post: https://rpcs3.net/blog/2017/03/11/des/

Settings:
PPU LLVM Recompiler
SPU ASMJIT Recompiler
SPU loop detection: On
Preferred SPU Threads: 4 (probably but you have to test to see what's better for your CPU)
SPU delay penalty: 0 (config.yml only setting for now)
OpenGL or Vulkan (faster) + Write Color Buffers + Invalidate cache every frame
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
03-11-2017, 07:42 PM -
#2
Moving to ingame
fifazalata
Member


0
60 posts 6 threads Joined: Aug 2017
07-26-2017, 12:36 AM -
#3
I have the US version but it hadn't been moved to playable section yet
so I figured I'll make a log for it to move it to playable
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
07-26-2017, 12:38 AM -
#4
Moving to playable, thanks for reporting.
Drinkie
Guest


 
07-29-2017, 06:23 PM -
#5
Posted this message before (In the EU version of this game by accident) but it didn't post for whatever reason anyway i'm having a display issue with the game where if i have the GPU setting set to OpenGL everything is black including the menu's but if i have it set to Vulkan then the stages are completely black i can't even see my character at all the game did work until i got to the second part of the tutorial but now it's just not playable.
Ani
Administrator
*******


8
3,105 posts 75 threads Joined: Aug 2017
07-29-2017, 06:36 PM -
#6
(07-29-2017, 06:23 PM)Drinkie Wrote: Posted this message before (In the EU version of this game by accident) but it didn't post for whatever reason anyway i'm having a display issue with the game where if i have the GPU setting set to OpenGL everything is black including the menu's but if i have it set to Vulkan then the stages are completely black i can't even see my character at all the game did work until i got to the second part of the tutorial but now it's just not playable.
From your log:
Video:
Write Color Buffers: false

From OP:
(01-27-2017, 03:44 AM)Renusek Wrote: Settings:
PPU LLVM Recompiler
SPU ASMJIT Recompiler
SPU loop detection: On
4 prefered SPU threads (probably, but you have to test)
OpenGL or Vulkan (faster) + Write Color Buffers + Invalidate cache every frame
godless3
Guest


 
07-30-2017, 12:32 PM -
#7
I have a pretty weird problem. The Tutorial works perfectly but as soon as I get to the Nexus my player audio goes away and never comes back (footsteps mainly). All other sounds work normally.
godless3
Guest


 
07-30-2017, 02:17 PM -
#8
I can confirm the game is working flawlessly for me at 30 FPS solid, no frame drops, no audio issues. I fixed my own problem with audio (no footsteps) - You MUST defeat Phalanx and return to the Nexus. All sounds are normal after this.

CPU: Intel Core i7 7700K GPU: Nvidia GTX 1080Ti RAM: 64GB G.skill Trident

Settings:
Vulkan
PPU LLVM Recompiler
SPU ASMJIT Recompiler
SPU Threads: 6
Write Color Buffers + Invalidate Frames ON

EDIT: Footsteps not present is an in-game "feature", not an issue.
Ani
Administrator
*******


8
3,105 posts 75 threads Joined: Aug 2017
07-30-2017, 02:49 PM -
#9
SPU Preferred Threads doesn't equal SPU Threads. Less is usually better.
godless3
Guest


 
07-30-2017, 03:18 PM -
#10
(07-30-2017, 02:49 PM)Annie Wrote: SPU Preferred Threads doesn't equal SPU Threads. Less is usually better.

Oops, I'll decrease it to 4 then but I'd have had less problems on 6 for some reason. I had a few freezes when it was set to Auto.


Forum Jump:


Users browsing this thread: 2 Guest(s)