Hello There, Guest! Register

Demon's Souls [BLUS30443]
#41
What's the best place to check to see if this game is still broken on newer builds as they come out?
Reply
#42
The issue was already fixed a few weeks ago just use the latest builds.
And use SPU LLVM for more performance, Demon's Souls is one of few games SPU LLVM works well with currently.
Reply
#43
Oh, that's great... thanks for the reply. I will check it out.

So, I tried Demon's Souls in the newest version today and it is a good bit faster/smoother... I get some instances of the player momentarily disappearing, but I'm guessing this is just a trade-off with the LLVM compiler?
Reply
#44
Demon Souls... using current RPCS3 build 7376, the game crashes while loading at the start.... I deleted all shaders for the game and reloaded them. Same issue. Color buggers IS enabled. It used to work...

Anyone else having this problem or am I just unlucky? Any known fix
Reply
#45
Using build 7377 and I'm getting the same issue. Messing with my setting to see if I can get something to work, but no luck so far.
Reply
#46
Build 0.0.5-7431 - same issue. The game crashes the emulator at the first loading screen before the appearance of the first dialog window. Increasing the value of the Resolution Scale Threshold slider helps to get further - I managed to see ~10s of the intro cutscene video before crashing at it being set to 1024. Happens on both Vulkan and OpenGL.

Using a laptop with Intel Core i3-3120M, GeForce GT645M, 6 Gb RAM.

Also, after deleting all caches and launching the game again, the render window opens with white screen. Closing it also crashes the emulator...
Reply
#47
(07-20-2018, 05:43 AM)Asinine Wrote: The issue was already fixed a few weeks ago just use the latest builds.
And use SPU LLVM for more performance, Demon's Souls is one of few games SPU LLVM works well with currently.

It was never fixed for me. I've had the issue ever since it first appeared, and it still happens.
Reply
#48
Idea Can confirm that 6697 (probably best) & 6718 work, new 7xxx versions are unstable (I get a crash at tutorial Compiling Shaders), with or without LLVM SPU.
Reply
#49
(11-11-2018, 07:16 PM)2mg Wrote: Idea Can confirm that 6697 (probably best) & 6718 work, new 7xxx versions are unstable (I get a crash at tutorial Compiling Shaders), with or without LLVM SPU.

An Update for anyone wondering if this game works on recent versions

It 's working on RPCS3 0.0.5-7586 with an i7 3770K at stock speed and an AMD 570 4GB.  Runs very well 30fps and looks fantastic.
Really amazed at this emulator. Just be sure to go to Config->GPU and check the box next to Write Color Buffers.
There are slow downs when entering an area I haven't before.  Other than that, its very playable after shaders cache.
Can even stream it fine on this 6 year old rig.
Reply
#50
For some reason this game is not responding to my controller. When you get that startup windows that says "The game is compatible with the data auto-save feature etc." no matter what I press it doesn't respond.

Any idea what could be wrong? My controller works fine with other games on rpcs3.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)