God of War: Ascension [BCUS98232]
Started by wffl

25 posts in this topic

7 posts 2 threads Joined: Apr 2018
08-12-2019, 04:27 PM -
Tried with v 0.0.6-8457. Black screen after Santa Monica's logo, sometimes it appears the loading icon but nothing else.

117 posts 0 threads Joined: Mar 2020
03-19-2020, 09:41 AM -
Finally beaten the game from start to finished with minor crashes/hanging/freezing.

# Gameplay FPS = (26~60)
# Cutscenes (55~60)
# RPCS3 v0.0.9-9947-7139c4fb Alpha
# default setting (resolution scale= 150% 1080p).
# Whatcookie patch used
# Intel i9-9900K @ 3.70GHz | 32GB GB RAM | 2070S 8GB Nvidia |NVMe storage (3500MB/2500MB Read/Write).

Random Crashes/Hanging/Freezing issues :-

@ Compiling Shader:-
RPCS3 = HDD & Backup = HDD  ==>  Very Slow (Loading blackscreen)
RPCS3 = SSD/NVMe & Backup = HDD  ==>  Normal speed (sometime Loading blackscreen + Hanging/Freezing)
RPCS3 = SSD/NVMe & Backup = SHDD  ==>  Fast speed (after multiple run)
RPCS3 = SSD/NVMe & Backup = SSD/NVMe  ==>  Very Fast!!

@ Video out of MEM problems: -
default setting & Res. scale= 100% (windowed 720p) 
==> Very horrible graphic look
==> GPU VRAM = Below 2GB
==> Hanging/Freezing = after 2h gameplay
default setting & Res. scale= 100% (Fullscreen on 4K TV) 
==> Very horrible graphic look
==> GPU VRAM = Below 5GB
==> Hanging/Freezing = after 30min gameplay

default setting & Res. scale= 150% (windowed 1080p)  Wink
==> Fine graphic look
==> GPU VRAM = Below 5GB
==> Hanging/Freezing = after 1.5h gameplay Smile
default setting & Res. scale= 150% (Fullscreen on 4K TV) 
==> Fine graphic look
==> GPU VRAM = Above 8GB
==> Hanging/Freezing = after 15min gameplay

default setting & Res. scale= 300% (4K Fullscreen
==> Great graphic look
==> GPU VRAM = above 8GB
==> Hanging/Freezing = after 10min gameplay

Tried suggested solution but NOT Helping:-
# Enable Vulkan Memory Allocator (Debug)
# Enable Strict Rendering Mode (GPU)

Attached Files Thumbnail(s)

.rar   RPCS3.rar (Size: 559.7 KB / Downloads: 175)

33 posts 0 threads Joined: Jul 2020
07-12-2020, 10:42 PM -
Finally able to get in game with example config found on YouTube. What ended up working for me is

Disable SPU MLAA: https://wiki.rpcs3.net/index.php?title=H...e_SPU_MLAA
Enable "Accurate RSX Reservation Access" on debug tab: https://wiki.rpcs3.net/index.php?title=H..._Debug_tab

I had previously been stuck at black screen after the Santa Monica Studio logo.

0.0.11-10648, Vulkan, frame limit 60, everything else is mostly default
Tried this on 2 of my PCs

PC1: i9-10900K stock, 1080Ti, 32G Ram, Samsung 970 Evo Plus SSD, Windows 10 Home.
Framerate is anywhere from 20 to 60, with 40~60% CPU usage and 25% GPU usage. kind of playable, but definitely not as smooth as on the PS3. Resolution scaling doesn't seem working, similar to GOW3, setting 200~300% scaling still gets the same low res graphics, and actually much more jaggy look worse than 100%, and framerate is much lower, and anything higher than 100% scaling would also likely cause "out of video memory" error after playing a while.

Side note, I somehow able to get in game once without disabling SPU MLAA, with 200% scaling, played for a short while until it crashes. Then I was never able to reproduce it. Disable SPU MLAA + Accurate RSX Reservation Access is the only reliable combination for me to get in game.

PC2: i5-3570K, 1660 super, 16G Ram, 6 years old Intel Sata SSD in Raid 0, Windows 10 Professional
Somehow I didn't need to disable SPU MLAA on this computer to get in game, CPU was 100% maxed out, getting 10~13fps on opening cut scene, which was unskipable for the first time, took me like 15 minutes to sit through it, and another 10 minutes of cut scene until I get to the first playable section. Single digit FPS, but images looks much better with MLAA on.

Overall, this game on RPCS3 is still not stable and performant. For now, without something like an overclocked 9900K, and without proper resolution scaling, it's not any better experience than natively on PS3, and not worth the hassle to tackle with.

10 posts 0 threads Joined: Aug 2017
07-31-2020, 10:09 PM -
After about a week of various configurations I can honestly report that it has been one hell of a nightmare trying to get this to run on a 2060 super strix not overclocked completely stock. The only thing that is overclocked is my processor which is a 9600 k at 5.1 gigahertz stable and cool 1.4 on the voltage the ram is 32GB of ddr4 3000 megahertz and it is not overclocked just stock at 1.35 volts.

Currently I am playing through the first part of God of war Ascension it is a bit stuttery but this is the stablest I've gotten it so far upon further rpcs3 and improvements made by the development teams. I watched a video on YouTube it was kind of old but it said rpcs3 settings fix for God of war Ascension and even though it was for a ryzen 5 I said why the hell not and I tried it and it actually worked now like I said it is very stuttery I did have to create my own custom configuration for the game and I added the power to the driver wake up delay up to 600. I'm going to keep testing this because I've got currently oh crap it just froze PPU trapped is the warning...

I'm definitely going to keep doing more research on this and I will report back with any new discoveries.

33 posts 0 threads Joined: Jul 2020
Video  09-01-2020, 08:45 AM -
Update to my previous post, got the hint from a recent youtube video, to make resolution scaling works, I need to update the game to version 1.04 then apply the patch at https://wiki.rpcs3.net/index.php?title=H..._Ascension , along with previously mentioned disable SPU MLAA

I still have "Accurate RSX Reservation Access" enabled on debug tab: https://wiki.rpcs3.net/index.php?title=H..._Questions , not sure if I still need it. Will test later and update/reply here.

0.0.11-10911, Vulkan, frame limit 60, anti-aliasing disabled, anisotropic filtering 16x, Write Color Buffer on, Multithread RSX on, Vsync on, 300% scaling(4k)
The game now looks gorgeous at 4K, while frame rate fluctuate from 16 to 60 FPS depending on the size of the scene and whether shader is being compiled, it is quite playable for the most part, stayed between high 20 to mid 40 for majority of the time, occasionally drop below 20 on large scene, audio is still quite stuttery at movie cut scenes(which is now blurry compared to 4K in game rendering anyways), but I can live with that while enjoying beautiful detailed 4K.

This is on my rather high end PC, i9-10900K stock, 1080Ti, 32G Ram, Samsung 970 Evo Plus SSD, Windows 10 Home. Compared to my previous post, CPU usage now increased to 50~63%, while GPU usage is above 40%, definitely huge improvement. But it's still largely bottlenecked at CPU that I can see a few cores maxing out while many others stayed quite idle.

I'd say this is quite close to playable on high end PCs, while gaming experience isn't yet superior than native PS3, and it did froze and crashed twice for me, it is definitely a worthy alternative to enjoy this game in 4K, and I'm considering actually play through it again even though it's still not perfect.

[Update]: Turns out with the 2 patches enabled, I don't need "Accurate RSX Reservation Access" anymore, disabling it increases performance quite a bit, and previous stuttery in cut scenes are now solved, this game now runs mostly above 30fps with only occasional drop to low 20s, it is now quite smooth and playable, comparable to native PS3 experience, very happy about it.
See gameplay video at 

Part 1 showing the configs, and YouTube/Geforce Experience screwed up the streaming that it didn't show gameplay.

Part 2 replaying the first stage
This post was last modified: 09-03-2020, 03:44 AM by ldczzyy. Edit Reason: Updated test results

33 posts 0 threads Joined: Jul 2020
09-07-2020, 02:09 AM -
Getting close to 60fps with "Write Color Buffer" off, with minor graphic issues, but overall better and smoother experience, almost don't need Sony to make a HD remaster on PS5 at this point Cool
And yes, it still crashes from time to time, but nothing game breaking.

Follow up video testing CPU utilization, this game starts at 22:49

Another test on low end PC, not playable at all. Related section starts at 11:00
This post was last modified: 09-17-2020, 05:55 AM by ldczzyy.

11 posts 0 threads Joined: Oct 2020
11-16-2020, 04:43 PM -
can someone point me to where I can find the patches for this game? I have run the update PKGs to bring this title to 1.12, but I am guessing these patches are referring to something else.

1 posts 0 threads Joined: Jan 2021
02-06-2021, 04:02 AM -
the sound went away
apparently it doesn't work anymore try with all settings
neither in safe nor in mega does the audio work

117 posts 0 threads Joined: Mar 2020
10-18-2021, 08:36 AM -
Almost Playable
Updating of post #12, much graphic & performance improvement are adaptively well-rendered using some new patches & config.  However, “Disable in-build MLAA patch” might introduce a little Mesh-Trimming on Kratos like in Chp2/14.   Multiple intel CPUs shows proportional performance in FPS
  • 4C8T [i7-4800MQ] – Ingame, Extremely Laggy/Stuttering Gameplay, 60FPS Cutscenes/Menu (SSD @ SATA 3.0)
  • 6C12T [i7-8750H] – Fine after multiple run with random crashes (NVMe @ PCIe 3)
  • 8C16T [i7-11800H] – Flawless (NVMe @ PCIe 3) – AVX-512
  • 8C16T [i9-10980HK] – Flawless (NVMe @ PCIe 3)
  • 8C16T [i9-9900K] – Flawless (NVMe @ PCIe 3)
# Gameplay Variable FPS = (28~46~60) – Unlocked FPS
# Cutscenes stable (59~60)
# RPCS3 v0.0.18-12902-683c061e Alpha
# Non-Default setting [Res. Scale= 300% Fullscreen 4K]
# RPCS3 Patch Manager used (thanks to RPCS3 teams & the contributors illusion001 & Zerox latest patches)
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia | NVMe storage (3500MB/2500MB Read/Write).

@ Graphic Config
# Enable list of patches depicted in attached picture (Patch Manager)     
# Enable Read Color Buffers (Advanced)      ==> Correct Color Environment

@ CPU Config @ 9900K
# Set Driver Wake-Up Delay = 350us (Advanced)
# Enable TSX Instruction (CPU)
# Enable libsail.sprx & libssl.sprx (Advanced)     ==> Long Time Run & Prevent Vulkan API call failed … (VK_ERROR_DEVICE_LOST)
@ CPU Preferable FPS++ Performance & Support
# Enable Accurate RSX reservation access (Advanced)     – AMD/non-TSX Intel
# Enable Full Width AVX-512 (CPU)                                                         – 11th  Intel CPU
# Set ZCULL Accuracy = Approximate (GPU)
# Set SPU Block Size = Mega (CPU)
This post was last modified: 10-18-2021, 08:50 AM by quick.sliver1.

Attached Files Thumbnail(s)

.7z   RPCS3+TTY [4C,6C,8C].7z (Size: 2.48 MB / Downloads: 96)

5 posts 0 threads Joined: Sep 2021
10-19-2021, 02:30 PM -
Does NVMe/SSD actually improve performance over HDD?

Forum Jump:

Users browsing this thread: 1 Guest(s)