RPCS3 Forums

Full Version: Trouble running Ni No Kuni (BLES-01555)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4


Hey everyone,

ssshadow recently posted a video on Reddit showing the demo version of Ni No Kuni running in RPCS3. I decided to give the full European disc version a try. Unfortunately, being the RPCS3 noob that I am, I couldn't really get it running. It reached the language selection menu, but gave me a black screen and sometimes an error after that. But more on that later.

First of all, my PC's specs, just in case it matters:

i7-4770K (currently not overclocked), GTX 1070, 16 GB RAM, Win10-64

As for my RPCS3 settings:

Emulator version: rpcs3-v0.0.1-2017-02-17-65104b59_win64
SPU/PPU: both Interpreter (fast)
LLE modules: libac3dec, libadec, libatxdec, libdmux, libdmuxpamf, libfont, libfontFT, libfreetype, libfreetypeTT, libl10n, libpamf, libresc, librtc, libsail, libspurs_jq, libsre
Graphics: Vulkan @ 1280x720; Frame limit set to Auto; VSync on
Audio: XAudio2
I/O: XInput

Here's a detailed list of my steps, so we can rule out any errors here:

1. Dumped the BD-ROM (BLES-01555) on my PC using IsoBuster. This gave me an .iso which matches the hashes of existing dumps, so I assume it's good.
2. Patched the image with the corresponding .ird file.
3. Decrypted the resulting .iso using 3k3y.
4. Extracted the decrypted .iso to E:\rpcs3-v0.0.1-2017-02-17-65104b59_win64\dev_hdd0\game\BLES01555 using 3k3y.
5. Decrypted all the .sdat files in USRDIR, as per http://www.emunewz.net/forum/showthread.php?tid=178888.
6. Moved all contents of ~\BLES01555\PS3_GAME to ~\BLES01555\, since RPCS3 kept looking for the files there.
7. Duplicated all contents of ~\BLES01555\USRDIR to ~\BLES01555\USRDIR\BD and ~\BLES01555\USRDIR\HDD_GAMEDATA, since RPCS3 seemed to expect files there, too.
8. Still got tons of missing files errors, so I decided to extract the .adat files that came with the game (which are just renamed .psarc files), which resolved quite a few missing files errors. Language selection menu started to work. It looked and sounded perfect; however, when selecting a language and pressing X, I got a black screen and nothing else happened.
9. Extracted some of the .zarc files that were extracted from the .adat files, since RPCS3 kept looking for the extracted versions. This got rid of many missing file errors, but ultimately, even after having extracted all the files RPCS3 complained about, I still got the black screen after the language selection menu, now sometimes (very inconsistently) accompanied by an error message ("The game data is corrupted. Press the PS button to close the game, and delete the game data.&quotWink

AnnieLeo asked me to upload my log files on that Reddit thread, so here we go.

As you can probably see, there are still a bunch of missing files errors, which I assume are the essence of my problem. For example:

·W {PPU[0x1000009] Thread (fios mediathread 5) [0x01787c08]} cellFs: cellFsStat(path=“/dev_hdd0/game/BLES01555/USRDIR/data/system/text_lang_setting.bin.zarc”, sb=*0xd008ac14) -> sys_fs_stat()
·W {PPU[0x1000009] Thread (fios mediathread 5) [0x01787c08]} sys_fs: sys_fs_stat(path=“/dev_hdd0/game/BLES01555/USRDIR/data/system/text_lang_setting.bin.zarc”, sb=*0xd008ac14)
·E {PPU[0x1000009] Thread (fios mediathread 5) [0x01787c08]} sys_fs: sys_fs_stat(“/dev_hdd0/game/BLES01555/USRDIR/data/system/text_lang_setting.bin.zarc”) failed: not found
·E {PPU[0x1000009] Thread (fios mediathread 5) [0x01787c08]} 'cellFsStat' failed with 0x80010006 : CELL_ENOENT

All these files do exist (they came within the .adat files I extracted earlier), but only in uncompressed form, not as .zarc.

So, does anybody have an idea how to get past the language selection menu? Sorry for this lengthy post, I just want to make sure that you're able to recreate my problem.
A few things to try:

Try the latest master branch version: https://ci.appveyor.com/project/rpcs3/rp.../artifacts

Use SPU recompiler (ASMJIT) (always use this for every game unless it explicitly crashes)

Try with OpenGL

- libac3dec.sprx
- libadec.sprx
- libatxdec.sprx
- libdmux.sprx
- libdmuxpamf.sprx
- libpamf.sprx
- libresc.sprx
- libsail.sprx
- libsjvtd.sprx
- libsmvd2.sprx
- libsmvd4.sprx
- libspurs_jq.sprx
- libsre.sprx

However I think the big mistake was when you started moving files. Just keep the original structure with everything insde PS3_GAME and don't put the game files inside /dev_hdd0/, just put the game on your desktop and use the menu boot -> boot game to select the PS3_GAME folder. After all on a real PS3 the game won't be on the internal HDD, and the game will be inside a PS3_GAME folder.


Thanks for the response, ssshadow. I had actually tried different combinations of interpreter/recompiler and all the graphics renderer options before. Didn't make a difference, as far as I could tell.

Anyway, for this new test I followed your instructions precisely. I used rpcs3-v0.0.1-2017-02-19-47fdaf69_win64 with PPU interpreter (fast) and SPU recompiler (ASMJIT), changed the graphics renderer to OpenGL and used the LLE modules you've suggested. I didn't move any files around this time; I extracted the decrypted .iso with 3k3y and tried to run the game right away via Boot -> Boot game.

This gave me exactly the results I had gotten before I had moved around the files in my previous test: The game did not get to the language selection screen as before; in fact, it did not boot at all or even show a renderer window. Just lots and lots of file not found errors in the log.

Could this have something to do with the game requiring a mandatory installation and RPCS3 not emulating this installation process yet?

I've attached an updated log file in case you'd like to take another look.


Been having the same problem. Tried ssshadow most recent suggestions step-by-step, and couldn't even boot. (Sending my log too in order to help).

The sad thing is that this is the game I wanted most to play xD
EDIT: Upon closer inspection it looks like the full version of the game tries to load this shit: http://www.psdevwiki.com/ps3/PlayView

Absolutely delete (with a backup) the file /PS3_GAME/USRDIR/libTGV_v1.45.07.sprx but it might cause problems further on...

Installation of disc games does work, and this is actually progress. There are multiple .sdat files that need to be decrypted such as for instance /PS3_GAME/USRDIR/data/vinfo.sdat.

Use the attached tool to decrypt the .sdat files.

For each .sdat file, for example vinfo.sdat run:
make_npdata.exe -v -d vinfo.sdat new_vinfo.sdat 0

Then make a backup copy of the original vinfo.sdat file, delete it, and rename new_vinfo.sdat to vinfo.sdat so the game will load the newly decrypted file. Do this for every .sdat.

In summary: Delete /PS3_GAME/USRDIR/libTGV_v1.45.07.sprx and decrypt every .sdat file, otherwise do not change anything.


Damn, I think deleting that libTGV_v1.45.07.sprx did the trick!

Game goes ingame now, although due to graphical glitches I couldn't play it for very long to see how far it'd go.

A few observations:

RPCS3 goes through the installation process without any issues. The menus look and feel flawless. The cutscenes run at full speed as well, although I had to skip them before they reached the end, otherwise I'd get a black screen after the cutscene finished. As I've said, there are lots of graphical glitches ingame. I can control my character, however there's flickering polygons and missing objects all over the place. Nevertheless, it's impressive to see this go ingame, to say the least!

OpenGL, DirectX 12 and Vulkan all work. The game flickers a lot more for me in OpenGL and Vulkan, though (//EDIT: Seems this was a fluke. I've played with DX12 a bit more and it flickers just as much as OGL and Vulkan now). Also, once I'm ingame, the game tends to freeze randomly after a couple seconds on all renderers.

I've attached another logfile with the game freezing at the end, just after a couple seconds of gameplay. Just in case anybody's interested Smile

Thanks for guiding me through the process, ssshadow Smile

And here's a couple of screenshots Smile
·F {rsx::thread} class std::runtime_error thrown: Invalid RSX method 0xd480 (arg=0xa8629)
(in file C:\rpcs3\rpcs3\Emu\RSX\rsx_methods.cpp:34)

Hmm... I would file a bug report with a renderdoc trace where a broken frame is captured and definitely also mention that the game dies with this error.

Google and download the program renderdoc. Set rpcs3 to use OpenGL with legacy buffers. Then launch rpcs3 from renderdoc and press print screen to capture a frame that is clearly broken. File -> Save the capture and attach it to a new bug report: https://github.com/RPCS3/rpcs3/issues . Also mention any other useful information, the above error, and of course attach the log file.

For the black screen videos maybe LLE libvdec.

And yes it's very impressive that rpcs3 is now able to run "real games" like this. The Patreon certainly helped speed things up...


Thanks again, ssshadow Big Grin

I gave libvdec a try. It does help with the cutscene transitions indeed. I can now watch multiple cutscenes in a row from start to finish and RPCS3 always properly continues with the next cutscene. No more black screen when the next cutscene is supposed to start. However, with libvdec enabled, the background video in the main menu is blackened out. Also, it's quite slow, so video and audio desync quickly. I think I'll continue not LLE'ing this module.

As for renderdoc, I'll look into that. One more thing I've noticed is that using DX12, the freezes are a lot less frequent than with OGL or Vulkan. I was able to play the game for several minutes with DX12 before getting the runtime error. Using DX12 I could get far enough into the game to be able to use the ingame save feature. I can confirm that the game properly saves and loads.
You should make a thread for the game with all findings so it can be added to compat DB: http://www.emunewz.net/forum/forumdisplay.php?fid=196


Hey, for me it did the trick too! Thanks a huge lot, ssshadow!

But, in my case I couldn't go beyond the "new game" -> "normal difficult". As soon as the first loading screen appears, the game freezes and keeps there forever.

Even with this setback, though, I'm super excited just to see this running smoothly through the menus! hahaha

P.S: To whoever it might interest, here goes my latest log in which I managed to get to the first loading screen.
Pages: 1 2 3 4