RPCS3 Forums

Full Version: Tales of Xillia [BLES01815]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16
The game is fine, there are still graphic defects, and the most important thing is the incomprehensible texts.
Emulator version 28/08/2017
tested on rpcs3-v0.0.3-2017-09-10-f0358f85_win64

Games seems to be almost playable ~30fps and no noticeable graphical bugs in first 10 minutes of gameplay
The biggest issue is broken text/font  most of it is completely garbled
I have the same problem with text and I need to play (Menu) the cpnversation it's no need necesary

Please fix Smile Smile Smile Smile Smile Smile Smile
(09-21-2017, 06:47 PM)solobie Wrote: [ -> ]I have the same problem with text and I need to play (Menu) the cpnversation it's no need necesary

Please fix Smile Smile Smile Smile Smile Smile Smile

the problems with the text in this game and tales of vesperia are probably due to ime-jp and/or libl10n not being fully implemented in the code base.  reverse engineering these are probably at the bottom of the list of things to do, i tried to reverse engineer ime-jp and it was just way too difficult for someone at my level.  so i wouldn't expect the text in these games to get done anytime soon unless you can find either an expert in reading assembly or someone who knows the ps3 architecture well enough to make a workaround.  both are monumental tasks.
It's been 3 months and it was not fixed yet, actually was only the problem with the font to become playable...
maybe even though it sounds silly, the error is more complex than it seems?
And looks the gamma shows better if manually force enable the libsysutil.sprx
Liblv2.sprx Only:
[Image: ybrizh.png]

with Automatically + Manually Libsysutil.sprx enabled:
[Image: fppokh.png]
Please be aware that of at least the 198e9dce build (1/1/18), this is no longer in game. This is a regression, as it was in game previously.

Upon boot of BLES01815, the bandai and namco logos are displayed, then the game freezes: the fps counter locks and a white screen is displayed.
Just to update, currently the status is: in game with 3 problems:
  1. Text Not Readable (If someone will try fix this game is better fix this first)
  2. Background Music Stops after a time
  3. Gamma/brigthness don't shows correctly, in older builds this can be fixed enabling the libsysutil library

And I tried search, but don't exist hackeds build to fix the text problem :/ in my case I'm waiting only the text problem to be fixed and i will try beat the game, the sound and gamma problem isn't very bad.
Hacked build that fix the text issue on Xillia and vesperia:

Hack created by pauls-gh, check the issue "tales of vesperia rendering issues" in the github to more information.
[Image: 37183462-0b0cf60e-22eb-11e8-92c3-b968db45345f.png]
I'm using the latest build

and I'm having problems just opening the game. The error
F {PPU[0x1000000] Thread (main_thread) [0x006e637c]} MEM: Access violation reading location 0x0

always comes out. Now I know that this game had trouble with fonts and lighting but I can't even open the game even with the build that supposedly fixed the fonts

Okay cross that. I just found out that I was experiencing the problem because I tried to put in a DLC. The game is working now without it and using this build, the text is okay too

problem is the speed department. Is there some kind of speedup for this game? And also did anyone get the DLC working?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16