RPCS3 Forums

Full Version: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11
Yes, the random crashes, especially around the world map, is why this one is still in the ingame category and not playable.


The "invalid mem access location" error which seems to be persistent during first item synthesis can be avoided by going into Interpreter (fast) mode. Afterwards, save the game and then we can resume using recompiler as usual.
My only question is, since the game requires motion detection from SixAxis, is there any possibility of implementing motion input without plugging a dualshock 3 or 4? Or perhaps a single button hack for this game?
The FPS is already quite good (30 FPS) and the only downside is being this motion detection requirement.
Well the world map crash can definitely happen regardless of settings.


(07-15-2017, 10:20 AM)Thanatos Wrote: [ -> ]
(04-11-2017, 12:31 PM)ssshadow Wrote: [ -> ]
(04-11-2017, 09:01 AM)rauldj Wrote: [ -> ]So, what's the deal with controllers not working on Gust games with LLVM? How does that even make the slightest sense?

The control are working, obviously, look at any screenshot or discussion about the game here. What isn't working is the sixaxis bits or whatever you call it. Motion controls in other words. This game strictly requires it but it is not implemented in RPCS3.

Yes, it needs to actually register the shaking of the controller, so I got Dualshock4 cotroller, plugged it via USB, and that worked (thanks for implementing that, btw). Real problems began at the 2nd town, where it began crashing like mad, around every 2nd to 3th time you try to access world map, city map or item creation. It's still somewhat progressable, but requires saving a LOT.
Also, let me brag a little. It still makes some static noises, but that's one nice fps!

Wait you mean plugging in the DS4 made the sixaxis work, or just that the controller worked in general?
Sixaxis is implemented for DS4 only


(07-27-2017, 11:43 PM)Firion Wrote: [ -> ]Wait you mean plugging in the DS4 made the sixaxis work, or just that the controller worked in general?

Well, purging worked, meaning sixaxis is working. Couldn't do that with normal XInput controller.


Any updates on the random crashing? The game runs near perfectly otherwise.
(08-15-2017, 11:43 AM)NES Wrote: [ -> ]Any updates on the random crashing? The game runs near perfectly otherwise.

Still crashes fairly consistently on the world map at least. I suspect this may actually be a game bug at this point...
This thing is running pretty fast on the latests builds. There's a lot of stuttering but otherwise is almost PS3 level of performance (targeting 60 FPS). Videos still run and sound like utter trash though. There're even some shadows on the ground too.
I made an account just to talk about this game and get some support! Big AT1-2 fan so i was pumped to finally play AT3.

Quick System Stars (i7 4.0 ghz, 32gb Ram, Geforce GTX 1080)
RPC3 Settings: LLVM and SDMJIT, Enable SPU Loop Detection and Automatically load required libraries. GPU is running Vulkan, Invalidate Cache Every Frame and Use GPU Texture Scaling,

I have it running at a solid 30 fps, only experiencing a little bit of unreadable text and some visual glitches. The AMVs stuttered, especially the introduction one. But the game engine itself seems run smooth. After realizing I needed motion controls, I got a DS4 so I could get the purge mechanic running.

Experienced my first crash when I got to the World map (but i see you all have experienced that a lot). Thankfully it didn't glitch on the 2nd time and I got into Eternus Shaft.

Got to Eternus Shaft and went to do the first Synthesis and it consistently crashed after the item creation conversation, ending in the following error at the end of my log.

"F {PPU[0x1000000] Thread (main_thread) [0x0051a8b4]} MEM: Access violation reading location 0x0".

I ran it a few more times but encountered the same problem, even trying to skip the little animation of the group crafting the item. But the problem happens after the event from creating the item.

Anyone got an idea if there are any settings I may need to tweak to get past this break point?

I can post more detailed information or a full log if that helps,

Pages: 1 2 3 4 5 6 7 8 9 10 11