Hello There, Guest! Register

Ridge Racer 7 [BLUS30001]
#1
RPCS3 v0.0.6-7857-1875dc3f Alpha | HEAD
AMD Athlon™ X4 760K Quad Core Processor | 4 Threads | 11.96 GiB RAM | AVXx

These are the settings I'm using currently after much testing to get best FPS. (03/21/2019) These are not the settings I was using when I originally made this post.
--
Core:
  PPU Decoder: Recompiler (LLVM)
  PPU Threads: 2
  PPU Debug: false
  Save LLVM logs: false
  Use LLVM CPU: ""
  Max LLVM Compile Threads: 3
  Enable thread scheduler: false
  Set DAZ and FTZ: false
  SPU Decoder: Recompiler (LLVM)
  Lower SPU thread priority: true
  SPU Debug: false
  Preferred SPU Threads: 2
  SPU delay penalty: 3
  SPU loop detection: true
  SPU Block Size: Mega
  Accurate GETLLAR: false
  Accurate PUTLLUC: false
  SPU Verification: true
  SPU Cache: true
  Enable TSX: Enabled
  Accurate xfloat: false
  Approximate xfloat: true
  Debug Console Mode: false
  Lib Loader: Load liblv2.sprx only
  Hook static functions: false
  Load libraries:
    []
  HLE lwmutex: false
VFS:
  $(EmulatorDir): ""
  /dev_hdd0/: $(EmulatorDir)dev_hdd0/
  /dev_hdd1/: $(EmulatorDir)dev_hdd1/
  /dev_flash/: ""
  /dev_usb000/: $(EmulatorDir)dev_usb000/
  /dev_bdvd/: ""
  /app_home/: ""
  Enable /host_root/: false
  Initialize Directories: true
  Limit disk cache size: false
  Disk cache maximum size (MB): 5120
Video:
  Renderer: Vulkan
  Resolution: 1280x720
  Aspect ratio: 16:9
  Frame limit: Off
  Write Color Buffers: false
  Write Depth Buffer: false
  Read Color Buffers: false
  Read Depth Buffer: false
  Log shader programs: false
  VSync: false
  Debug output: false
  Debug overlay: false
  Use Legacy OpenGL Buffers: false
  Use GPU texture scaling: false
  Stretch To Display Area: false
  Force High Precision Z buffer: false
  Strict Rendering Mode: false
  Disable ZCull Occlusion Queries: false
  Disable Vertex Cache: false
  Disable FIFO Reordering: false
  Enable Frame Skip: false
  Force CPU Blit: false
  Disable On-Disk Shader Cache: false
  Disable Vulkan Memory Allocator: false
  Use full RGB output range: true
  Disable Asynchronous Shader Compiler: false
  Strict Texture Flushing: false
  Consecutive Frames To Draw: 1
  Consecutive Frames To Skip: 1
  Resolution Scale: 100
  Anisotropic Filter Override: 8
  Minimum Scalable Dimension: 16
  Driver Recovery Timeout: 1000000
  D3D12:
    Adapter: AMD Radeon R9 200 Series
  Vulkan:
    Adapter: AMD Radeon R9 200 Series
    Force FIFO present mode: false
    Force primitive restart flag: false
  Performance Overlay:
    Enabled: true
    Detail level: Medium
    Metrics update interval (ms): 350
    Font size (px): 10
    Position: Top Right
    Font: n023055ms.ttf
    Horizontal Margin (px): 50
    Vertical Margin (px): 50
    Center Horizontally: false
    Center Vertically: false
    Opacity (%): 70
    Body Color (hex): "#FFE138FF"
    Body Background (hex): "#002339FF"
    Title Color (hex): "#F26C24FF"
    Title Background (hex): "#00000000"
  Shader Compilation Hint:
    Position X (px): 20
    Position Y (px): 690
  Shader Loading Dialog:
    Allow custom background: true
    Darkening effect strength: 30
    Blur effect strength: 0
Audio:
  Renderer: XAudio2
  Dump to file: false
  Convert to 16 bit: false
  Downmix to Stereo: false
  Start Threshold: 1
  Master Volume: 50
  Enable Buffering: true
  Desired Audio Buffer Duration: 75
  Sampling Period Multiplier: 100
  Enable Time Stretching: false
  Time Stretching Threshold: 90
--


[Image: a39fc8112e86fc98d794c9fccf0458c1.png]

Also, I was able to get in game last night.

[Image: 67d38e37462bd127892b600e8be21231.jpg]

[Image: 8e3e8f3c11495028430d9dc70d13e83b.jpg]

(In the latest build I was able to complete a race, Midtown Parkway, with 150 shaders)

You can set/change this games status to 'Ingame' from 'Not listed in compatibility database'

Needs at least 119 shaders compiled to get this far.

Log file attached.


Attached Files
.gz   RPCS3.log.gz (Size: 660.69 KB / Downloads: 3)
Reply
#2
What's your video card? AMD? I think that's the only way to have properly rendered trees....
Reply
#3
AMD R9 270X 2GB

Also this, 27min of gameplay. 2 crashes. 20-30 FPS. 158 shaders.

https://www.youtube.com/watch?v=creEJmzZ4jQ
Reply
#4
(03-14-2019, 12:14 PM)Veritas0923 Wrote: AMD R9 270X 2GB

Also this, 27min of gameplay. 2 crashes. 20-30 FPS. 158 shaders.

https://www.youtube.com/watch?v=creEJmzZ4jQ

your cpu is very old

it's playable

here the test

https://forums.rpcs3.net/thread-173590-page-3.html
soon
Reply
#5
Cleaned up the sound a bit and almost double FPS in current build.

https://www.youtube.com/watch?v=avwy37i-hso
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)