MasterTurkeyMinecraft: Playstation 3 Edition [BLUS31426]
Started by MasterTurkey




5 posts in this topic
MasterTurkey
Member


0
125 posts 51 threads Joined: Feb 2018
04-23-2018, 11:04 PM -
#1
RPCS3 v0.0.5-6662-8f4fa8a5b Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.96 GiB RAM | AVX+ | TSX

Intro, menu, attempts to load a new world and crashes everytime including the tutorial. Never gets ingame.
This post was last modified: 04-23-2018, 11:09 PM by MasterTurkey.


Attached Files Thumbnail(s)
       

.7z   RPCS3_Minecraft.7z (Size: 284.57 KB / Downloads: 376)
.7z   RPCS3.7z (Size: 401.95 KB / Downloads: 152)
Maxetto
Member


0
30 posts 2 threads Joined: Aug 2017
04-25-2018, 08:32 PM -
#2
You can get further using "Automatically load required libraries" instead of just liblv2.

World generates just fine but then is a real pain to get inside the game. So far I got:
- Unimplemented syscall syscall_988 (This is with liblv2 only when generating the world)
- Random freezes after loading the world
- Unregistered PPU functions ({PPU[0x1000019] Thread ((4J) Post processing) [0x0138e984]} PPU: Unregistered function called (LR=0x138b2ec))
- Segfaults when trying to load a world (after being generated) with just liblv2.
- Random crashes due to being unable to create a lock for I/O operations on the save folder. (class std::runtime_error thrown: Locking failed (lwmutex=*0xc37950, owner=0x100000e))

I wonder if European version got regressed too.
This post was last modified: 04-25-2018, 08:40 PM by Maxetto.
Intel Core i7-3770 (OC: ~4.2GHz) | 8GB DDR3 1333MHz | Zotac Mini GTX 1060 6GB
Maxetto
Member


0
30 posts 2 threads Joined: Aug 2017
07-15-2018, 02:37 PM -
#3
Emulator Version: RPCS3 v0.0.5-7096-46abe0f31 Alpha
Game Status: Ingame

PPU/SPU Decoder: Recompiler
GPU: Vulkan.
XAudio: Downmix to Stereo: false
I/O: XInput
System: Language: Italian, Enable /host_root/: true

Everything else as Default configuration. FW used 4.81

Notes:
1. Requires a savegame otherwise will crash during generation.
2. Performance-wise it is Playable, but crashes everytime it hits syscall_988 (Around 5 to 20 seconds after loading into the world).


Attached Files Thumbnail(s)
   

.gz   RPCS3.log.gz (Size: 218.36 KB / Downloads: 30)
Intel Core i7-3770 (OC: ~4.2GHz) | 8GB DDR3 1333MHz | Zotac Mini GTX 1060 6GB
Veritas0923
Member


0
26 posts 3 threads Joined: Jan 2019
03-31-2019, 05:17 PM -
#4
30min of gameplay

RPCS3 v0.0.6-7929-182054b8 Alpha | HEAD
AMD Athlon™ X4 760K Quad Core Processor | 4 Threads | 11.96 GiB RAM | AVXx

https://www.youtube.com/watch?v=6GoV9ZfEaGI
silverchair
Member


0
13 posts 2 threads Joined: Aug 2019
11-15-2020, 05:21 PM -
#5
Just tried and it does not work. Version v0.0.13-11249 Alpha [2020-11-15] As @Durandal mentioned, it is stuck loading the first level (it draws the sky and a few clouds and that's it). Tried 1.0 version first, then installed update 1.84 - still the same thing. I also tried [NPUB31419] and same issue.
Unfortunately I cannot find Disable GPU texture scaling which @Durandal mentioned anywhere in settings, possibly removed since his post is from 2018. Please downgrade to unplayable or provide settings needed to work.

# Intel i7 4770S @ 3.90GHz | 8GB RAM | Quadro M1200 4GB

Thanks!
This post was last modified: 11-15-2020, 06:12 PM by silverchair.
Asinine
Moderator
*****


3
1,964 posts 79 threads Joined: Aug 2017
05-04-2021, 08:06 AM -
#6
GPU Texture scaling was hidden a few years ago, and its off by default because of issues it causes. Ignore it.
Async Texture Streaming (new setting) should be disabled in this game now on gpu tab. As it currently causes problems with some view distance.


Forum Jump:


Users browsing this thread: 1 Guest(s)