Hello There, Guest! Register

Ni No Kuni: Wrath of the White Witch [NPUB30932]
#31
Playable as of:

https://forums.rpcs3.net/thread-179175-p...#pid296939
Reply
#32
Has anybody been able to load their saves from the PS3?

Everytime I try I get these two lines:

E {rsx::thread} RSX: nv406e:Confusedemaphore_acquire has timed out. semaphore_address=0x40300490
E {rsx::thread} RSX: Dangling reports found, discarding...

Should I open an issue on github?
Reply
#33
Did you decrypt the saves with the bruteforce savedata tool?

"Should I open an issue on github?"
No
Reply
#34
(04-30-2018, 12:34 PM)Asinine Wrote: Did you decrypt the saves with the bruteforce savedata tool?

"Should I open an issue on github?"
No

Yes I did, following this guide: https://youtu.be/aOHNFJHX69g

The save also passes all hash checks, Tekken 6 saves work with this method
Reply
#35
no longe working in latest builds
(since 6722)
game won't even load.

error:
"F {PPU[0x1000000] Thread (main_thread)} class std::runtime_error thrown: Verification failed (e=0xb7) (0):
(in file Emu\Cell\SPUASMJITRecompiler.cpp:2753)"

OBS: SPU interpreter makes it work but barely. I got exactly half the framerate using it. not worth. better roll back emulator build for now.
SPU LLVM Recompiler loads cache, but then crashs. still better then ASMJIT RECOMPILER that won't even load..

Clearly the problem here is the new implementations in SPU ASMJIT RECOMPILER made since build 6722 (none of the subsequently builds fixed it yet)


I'll stick to build 6718, as it was the lastest build with Ni No Kuni working.


UPDATE: build 6737 by Nekotekina fixed some issues. Game now get's to menu. loads game, but hangs (freeze) in loading screen before going ingame.

so far the game regressed to INTRO.

PS: unnamed5 now works, ni no kuni unfortunately remains broken.
Reply
#36
(05-13-2018, 07:19 PM)Slyponto Wrote: no longe working in latest builds
(since 6722)
game won't even load.

error:
"F {PPU[0x1000000] Thread (main_thread)} class std::runtime_error thrown: Verification failed (e=0xb7) (0):
(in file Emu\Cell\SPUASMJITRecompiler.cpp:2753)"

OBS:    SPU interpreter makes it work but barely. I got exactly half the framerate using it. not worth. better roll back emulator build for now.
SPU LLVM Recompiler loads cache, but then crashs. still better then ASMJIT RECOMPILER that won't even load..

Clearly the problem here is the new implementations in SPU ASMJIT RECOMPILER made since build 6722 (none of the subsequently builds fixed it yet)


I'll stick to build 6718, as it was the lastest build with Ni No Kuni working.


UPDATE: build 6737 by Nekotekina fixed some issues. Game now get's to menu. loads game, but hangs (freeze) in loading screen before going ingame.

so far the game regressed to INTRO.

PS: unnamed5 now works, ni no kuni unfortunately remains broken.

The same thing happens to me, since compilation 6718 many games no longer load or block on the loading screen as the Ni no kuni, in resident evil 4 the same thing happens, when you start it freezes and in inferno with llvm in the Initial struggle with death freezes.etc

Many of the playable games should go back to ingame, it seems that for each game you need a different compilation or you have to wait for improvements.
Reply
#37
Yes the regressions with nekos changes are known just stick with 6718 for a few days then try the newer builds to see if they are fixed.
Reply
#38
please as soon as anyone, myself included, confirms the game back into ingame post here.

build 6778 still intro.
Reply
#39
Just track the issue on github it's more active than the forums. https://github.com/RPCS3/rpcs3/issues/4589
Reply
#40
(05-19-2018, 12:25 PM)Asinine Wrote: Just track the issue on github it's more active than the forums. https://github.com/RPCS3/rpcs3/issues/4589

Thanks Asinine, but seems like nobody cares about this game...  almost 2 weeks later no fixes.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)