Hello There, Guest! Register

Grand Theft Auto IV [NPEB00882]
#1
Reaches ingame with graphical glitches. Freezes after a time. Tested in e3e3191.

Core

PPU: Interpreter (fast)
SPU: Interpreter (precise)

LLE Modules
Automatic

Graphics

- Vulkan
- 1280x720
- Auto (Frame limit)
- VSync

Audio

- XAudio2
Desktop: Intel Core i7-6700K, Nvidia GeForce GTX 970 (OpenGL, DirectX12 & Vulkan), Windows 10
Laptop: Intel Core i7-7700HQ, Nvidia GeForce GTX 1060 (OpenGL, DirectX12 & Vulkan), Windows 10
Reply
#2
Tried it on latest build, and it seems to cause an infinite loop of U {PPU[0x1000000] Thread (main_thread) [0x00bd19c0]} sceNp TODO: sceNpManagerUnregisterCallback(), game blackscreens after the GTA IV logo, and RPCS3.log is 100MB so can't upload it. These messages still keep on happening even after I stop the emulation. Tried all PPU and SPU settings but all of them resulted in this same error.
Reply
#3
Obviously you're not going to upload an uncompressed text file, that doesn't make any sense. Read the Global Forum Rules for attachment information.
Reply
#4
Even when compressing into a 7z file, the log is 3MB, over the 2MB attachment limit.
I've uploaded the compressed log to Mediafire: https://www.mediafire.com/file/fd4ytkyg834c2cv/RPCS3.7z
Reply
#5
RPCS3 v0.0.5-6631-da9baac84 Alpha
Ingame

   
U need Precise SPU, otherwise u end up under the map.


.gz   RPCS3.log.gz (Size: 90.46 KB / Downloads: 6)
[Image: CwrhKKk.png]
[Image: wygtra-2.png]





Reply
#6
Worked perfectly in build 7311, now lighting is broken, water is invisible and the sky is black (tested on build 7390) 
Tested with 
AMD Radeon R9 380 2GB 
Intel i7-8700

LLVM Recompiler for both SPU and PPU, Strict Rendering Mode on, everything else on stock


vs
[Image: unknown.png]
Reply
#7
You should set Write Color Buffers to ON to fix the reflections (water or cars for example).
Desktop: Intel Core i7-6700K, Nvidia GeForce GTX 970 (OpenGL, DirectX12 & Vulkan), Windows 10
Laptop: Intel Core i7-7700HQ, Nvidia GeForce GTX 1060 (OpenGL, DirectX12 & Vulkan), Windows 10
Reply
#8
(09-26-2018, 04:36 PM)MarioSonic2987 Wrote: You should set Write Color Buffers to ON to fix the reflections (water or cars for example).

Reflections are working now, lighting and headlights are still broken
[Image: unknown.png]
Reply
#9
https://www.youtube.com/watch?v=n4hesoTXNuY

Maybe playable?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)