RPCS3 Forums

Full Version: Grand Theft Auto IV [NPEB00882]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Reaches ingame with graphical glitches. Freezes after a time. Tested in e3e3191.


PPU: Interpreter (fast)
SPU: Interpreter (precise)

LLE Modules


- Vulkan
- 1280x720
- Auto (Frame limit)
- VSync


- XAudio2
Tried it on latest build, and it seems to cause an infinite loop of U {PPU[0x1000000] Thread (main_thread) [0x00bd19c0]} sceNp TODO: sceNpManagerUnregisterCallback(), game blackscreens after the GTA IV logo, and RPCS3.log is 100MB so can't upload it. These messages still keep on happening even after I stop the emulation. Tried all PPU and SPU settings but all of them resulted in this same error.
Obviously you're not going to upload an uncompressed text file, that doesn't make any sense. Read the Global Forum Rules for attachment information.
Even when compressing into a 7z file, the log is 3MB, over the 2MB attachment limit.
I've uploaded the compressed log to Mediafire: https://www.mediafire.com/file/fd4ytkyg834c2cv/RPCS3.7z
RPCS3 v0.0.5-6631-da9baac84 Alpha

U need Precise SPU, otherwise u end up under the map.

Worked perfectly in build 7311, now lighting is broken, water is invisible and the sky is black (tested on build 7390) 
Tested with 
AMD Radeon R9 380 2GB 
Intel i7-8700

LLVM Recompiler for both SPU and PPU, Strict Rendering Mode on, everything else on stock

[Image: unknown.png]
You should set Write Color Buffers to ON to fix the reflections (water or cars for example).
(09-26-2018, 04:36 PM)MarioSonic2987 Wrote: [ -> ]You should set Write Color Buffers to ON to fix the reflections (water or cars for example).

Reflections are working now, lighting and headlights are still broken
[Image: unknown.png]