Hello There, Guest! Register

compilling source problem
#1
i have installed all required programs from guide and downloaded all submodules with command

when i try compile __BUILD_BEFORE
Code:
Error    MSB3073    The command "cmake -G "Visual Studio 14 2015 Win64" -DCMAKE_CONFIGURATION_TYPES="Debug;Release" ../glslang
msbuild.exe ALL_BUILD.vcxproj /t:build /p:Configuration=Release /m" exited with code 1.    glslang-build    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets    41    
Error    MSB3073    The command "cmake -G "Visual Studio 14 2015 Win64" -DCMAKE_CONFIGURATION_TYPES="Debug;Release" ../glslang
msbuild.exe ALL_BUILD.vcxproj /t:build /p:Configuration=Release /m" exited with code 1.    glslang-build    C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets    41    
Error    MSB1009    Project file does not exist.    glslang-build    D:\rpcs3src\rpcs3\Vulkan\glslang-build\MSBUILD    1

do i need add some PATHs in visual studio somewhere? (python and cmake?) or just install them
Reply
#2
Python in CMake should be in path yeah, when installing them there should be an option to add them to PATH.

Anyways, the error says that glslang project doesn't exist, therefore you're missing its submodule. Try running git submodule update --init again.

Are you compiling with Release/Release LLVM?
Reply
#3
EDIT: looks like the problem was with "Blend for visual studio 2015" used it instead of "visual studio 2015". problem with "vulkan-build' remain. llvm and glslang compiled fine

EDIT2: problem solved. installed python 64bit

close request
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)