Kingdom Hearts 1.5 HD Remix [BLUS31212]
Started by Darkriot




96 posts in this topic
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
03-01-2018, 09:43 PM -
#51
So, i think im going to try writing a larger detailed post for this game about common issues and how to fix them, as time passes, ill try to keep this post up to date. I know this isnt on the front page or anything, but hopefully it'll serve as a reference point for people who need help in the future. I apologize that this first edition of the post will be short, i havent played the game all the way through, but as i encounter problems, ill try to work out ways to fix them, and add them here. For those of you who care, please help me to find and replicate new issues, so we can discover solutions.


BASIC SETTINGS:
As mentioned above, im not all the way through this game, so my advice here could be wrong, but thus far, getting through the beginning of the game, i have some idea of what should be on and off to produce good results. As i continue to test the game more thoroughly, and as rpcs3 continues to be updated, i should have a relatively complete guide on what works best for each part of the game.

For now, i feel comfortable sharing these basic settings, but later, ill try to give a comprehensive rundown of each setting.

CPU:                                                                                                                GPU:
[Image: 408e4bcbe0.png]         [Image: f36a5660dd.png]

A Note about Vulkan vs openGL: Both of the rendering methods have strengths and weaknesses, such as transition times, stutter frequency texture glitches and others. So far, i have tended to like Vulkan better, but its really something you'll have to test for yourself.


COMMON PROBLEMS:

Q: When i try to select kingdom hearts or any of the other games from the selection menu, it loads up and black screen and does nothing else.
A: While this isnt a problem everyone will have, RPCS3 doesn't seem to have a good way of handling games booting other games. When trying to play kingdom hearts or any other titles, boot the game file directly from the .self file located at \KH 1.5\PS3_GAME\USRDIR.

Edit: Some users have complained that this fix didn't work for them. Since i can't reproduce the problem, im reliant on you all to help me find a solution to other things that cause this if one if found. Thanks.

Q: During the intro movie/cutscene, the bottom of the screen gets cut off!
A: Uncheck "use GPU texture scaling" in you GPU settings.

Q: My game crashes just after i select my weapons type preferences (staff, shield, or sword).
A: Uncheck "use GPU texture scaling" in you GPU settings.

Q: My game crashes when i attempt to save.
A: Enable "Write Color Buffers" in your GPU settings.

Q: My game is having trouble with Jafars fight
A: Set 'Preferred SPU threads'to 1 - credit to Doctour

Edit: this solution no longer seems to fix the /Atlantis/bubbles in Hollow Bastion problem. Ill be looking for a new solution.

Q: Someones clothing or a background texture has turned red or brown/ their face disappears!
A: This may be solved by unchecking the 'Strict Rendering mode' option. Let me know if this doesnt work.

unsolved bugs:

Major:

Minor:
-
The playing cards/gorillas in Wonderland/deep jungle have hundreds of repeating textures. This seems to be an issue that happens after cutscenes.

- Still images from earlier in the game get stuck on the screen during loading or transition effects.

Interesting Tidbits:

If you are like me, and need to run through the intro a lot, you can skip it by simply deleting the cinematic file from KH 1.5\PS3_GAME\USRDIR\KH1Movie\en
This post was last modified: 04-06-2018, 05:27 PM by lastdance.
Terra97
Member


0
2 posts 0 threads Joined: Mar 2018
03-17-2018, 05:00 PM -
#52
I've got black screen after the first video (the video after the selection of the difficulty mode).
Someone know how to fix that? I've already tried booting from the .self file and a lot of configurations. Thanks in advance.
_________________________________________________________________________________________________________________________
EDIT problem fixed: 
Q: My game crashes/immediately shows a black screen after the intro.
A: It isnt a perfect fix, but if you navigate to KH 1.5\PS3_GAME\USRDIR\KH1Movie\en, and rename or move OPN.pam to another folder, you should be able to get past the intro.
This post was last modified: 03-18-2018, 06:03 PM by Terra97. Edit Reason: Fixed
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
03-17-2018, 08:46 PM -
#53
(03-17-2018, 05:00 PM)Terra97 Wrote: I got black screen after the first video (the video after the selection of the difficulty mode).

Someone know how to fix that? I've already tried booting from the .self file and a lot of configurations. Thanks in advance.

I just helped someone else with this, try navigating to KH 1.5\PS3_GAME\USRDIR\KH1Movie\en, and renaming your OPN.pam. it'll remove the video from the game, but let you proceed.
Terra97
Member


0
2 posts 0 threads Joined: Mar 2018
03-18-2018, 05:58 PM -
#54
(03-17-2018, 08:46 PM)lastdance Wrote:
(03-17-2018, 05:00 PM)Terra97 Wrote: I got black screen after the first video (the video after the selection of the difficulty mode).
I just helped someone else with this, try navigating to KH 1.5\PS3_GAME\USRDIR\KH1Movie\en, and renaming your OPN.pam. it'll remove the video from the game, but let you proceed.
Thank you!!! That's worked!!
Now I have these two bugs: 
  1. After playing for a while the audio turns off, sometimes that happen also at the start, when I run the iso, randomly.
  2. The image overlay bug described there: 
    (08-14-2017, 01:08 AM)trolol Wrote: [..] normally the effect lasts for a short moment (and appears to simply overlay the last image from a recent framebuffer?). However, there are some areas where there is a full-screen effect that causes that framebuffer to be displayed permanently. For instance, in Atlantica there's a sort of underwater effect and so you just see the framebuffer image gently moving.
    I didn't grab a video, but here's a screenshot: http://i.imgur.com/ubw8sD5.png
    EDIT: I tried again with all GPU optional settings disabled, and I get the same effect but with a black background under the health meters and UI.
    This bug appear before of almost every single transitions and cutscene
This post was last modified: 03-18-2018, 09:54 PM by Terra97.
Joao3233
Member


0
19 posts 4 threads Joined: Sep 2017
03-18-2018, 07:26 PM -
#55
I also have audio problem !!!
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
03-19-2018, 07:47 AM -
#56
(03-18-2018, 05:58 PM)Terra97 Wrote:
(03-17-2018, 08:46 PM)lastdance Wrote:
(03-17-2018, 05:00 PM)Terra97 Wrote: I got black screen after the first video (the video after the selection of the difficulty mode).
I just helped someone else with this, try navigating to KH 1.5\PS3_GAME\USRDIR\KH1Movie\en, and renaming your OPN.pam. it'll remove the video from the game, but let you proceed.
Thank you!!! That's worked!!
Now I have these two bugs: 
  1. After playing for a while the audio turns off, sometimes that happen also at the start, when I run the iso, randomly.
  2. The image overlay bug described there: 
    (08-14-2017, 01:08 AM)trolol Wrote: [..] normally the effect lasts for a short moment (and appears to simply overlay the last image from a recent framebuffer?). However, there are some areas where there is a full-screen effect that causes that framebuffer to be displayed permanently. For instance, in Atlantica there's a sort of underwater effect and so you just see the framebuffer image gently moving.
    I didn't grab a video, but here's a screenshot: http://i.imgur.com/ubw8sD5.png
    EDIT: I tried again with all GPU optional settings disabled, and I get the same effect but with a black background under the health meters and UI.
    This bug appear before of almost every single transitions and cutscene

Im glad that i could help! Big Grin

For problem #1: this seems to be consistent with several other people. Since i havent been able to replicate the bug, i dont know how to fix it, can you and Joao give me a screenshot of your settings for cpu, gpu, and audio?

For problem #2: this is currently unsolved, and currently makes atlantica unbeatable. Ive submitted a ticket about this issue to the devs.
walluz
Member


0
2 posts 0 threads Joined: Mar 2018
03-20-2018, 05:57 AM -
#57
(03-19-2018, 07:47 AM)lastdance Wrote:
(03-18-2018, 05:58 PM)Terra97 Wrote:
(03-17-2018, 08:46 PM)lastdance Wrote:
(03-17-2018, 05:00 PM)Terra97 Wrote: I got black screen after the first video (the video after the selection of the difficulty mode).
I just helped someone else with this, try navigating to KH 1.5\PS3_GAME\USRDIR\KH1Movie\en, and renaming your OPN.pam. it'll remove the video from the game, but let you proceed.
Thank you!!! That's worked!!
Now I have these two bugs: 
  1. After playing for a while the audio turns off, sometimes that happen also at the start, when I run the iso, randomly.
  2. The image overlay bug described there: 
    trolol[..] normally the effect lasts for a short moment (and appears to simply overlay the last image from a recent framebuffer?). However, there are some areas where there is a full-screen effect that causes that framebuffer to be displayed permanently. For instance, in Atlantica there's a sort of underwater effect and so you just see the framebuffer image gently moving. I didn't grab a video, but here's a screenshot: http://i.imgur.com/ubw8sD5.pngEDIT: I tried again with all GPU optional settings disabled, and I get the same effect but with a black background under the health meters and UI.
  3. This bug appear before of almost every single transitions and cutscene

Im glad that i could help! Big Grin

For problem #1: this seems to be consistent with several other people. Since i havent been able to replicate the bug, i dont know how to fix it, can you and Joao give me a screenshot of your settings for cpu, gpu, and audio?

For problem #2: this is currently unsolved, and currently makes atlantica unbeatable. Ive submitted a ticket about this issue to the devs.

I also have the sound bug, here is my screenshot.
I tried change the Threads number and active dump to file but the problem keep occurs.
My problem begins 15~20 minutes after the game starts.

[Image: cDqh4VE.jpg]

[Image: UeXqo43.jpg]

[Image: NuQOnsf.jpg]
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
03-21-2018, 08:58 PM -
#58
(03-20-2018, 05:57 AM)walluz Wrote: I also have the sound bug, here is my screenshot.
I tried change the Threads number and active dump to file but the problem keep occurs.
My problem begins 15~20 minutes after the game starts.

[Image: cDqh4VE.jpg]

[Image: UeXqo43.jpg]

[Image: NuQOnsf.jpg]

Could you also provide information to me about how you dumped the files, and just out of curiosity, what kind of processor you have?
walluz
Member


0
2 posts 0 threads Joined: Mar 2018
03-23-2018, 10:18 AM -
#59
(03-21-2018, 08:58 PM)lastdance Wrote:
(03-20-2018, 05:57 AM)walluz Wrote: I also have the sound bug, here is my screenshot.
I tried change the Threads number and active dump to file but the problem keep occurs.
My problem begins 15~20 minutes after the game starts.

[Image: cDqh4VE.jpg]

[Image: UeXqo43.jpg]

[Image: NuQOnsf.jpg]

Could you also provide information to me about how you dumped the files, and just out of curiosity, what kind of processor you have?
I tried with the Boot Game method selecting the folder and also with the SELF / ELF Boot method.

My processor is i5 7400.
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
03-23-2018, 04:41 PM -
#60
(03-23-2018, 10:18 AM)walluz Wrote:
(03-21-2018, 08:58 PM)lastdance Wrote: Could you also provide information to me about how you dumped the files, and just out of curiosity, what kind of processor you have?
I tried with the Boot Game method selecting the folder and also with the SELF / ELF Boot method.

My processor is i5 7400.

that doesnt tell me much about how you dumped the game.
Someone has recently suggested that setting SPU threads to 2 may fix audio issues, though you may run into graphical problem later by changing this setting.


Forum Jump:


Users browsing this thread: 3 Guest(s)