Sonic The Hedgehog [BLES00028]
Started by shoopdahoop22




31 posts in this topic
basic.wizard
Guest


 
08-02-2017, 08:45 PM -
#21
I'm probably way off here, but it could be worth building this PR to see if it gets any further. I can't figure out how to compile RPCS3 properly so I'll leave it up to someone more knowledgeable about this.
knuckles500
Guest


 
08-06-2017, 06:50 PM -
#22
Testing the game yet again especially after all the changes as of late and it still seems to have the same issue (see attached for logs)

libaudio.sprx
libfs.sprx
libio.sprx
libresc.sprx
libspurs_jq.sprx
libsre.sprx

Seems to crash at:
F 0:00:09.052200 {PPU[0x1000000] Thread (main_thread) [0x00e2ab64]} MEM: Access violation reading location 0x0


Settings:
PPU Decoder: Interpreter (precise)
SPU Decoder: Interpreter (precise)
Manually load selected libraries
Enabled SPU Loop detection
Graphics Render: Vulkan
Audio Out: XAudio2

(08-02-2017, 08:45 PM)basic.wizard Wrote: I'm probably way off here, but it could be worth building this PR to see if it gets any further. I can't figure out how to compile RPCS3 properly so I'll leave it up to someone more knowledgeable about this.

I haven't tested this though. So maybe this fixes the issue? Can anyone test?
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
11-24-2017, 12:53 PM -
#23
I tested that game and it shows the start screen but stuck (see the pic)
http://up419.siz.co.il/up2/mguz0zyndnmm.png

Version: rpcs3-v0.0.4-2017-11-23-7d3a5288
Firmware version: 4.82
---------------------------------------------------------
Libraries :
----------------
libaudio.sprx
libfs.sprx
libio.sprx
libresc.sprx
libspurs_jq.sprx
libsre.sprx
----------------------------------------------------------

Settings:
----------------
PPU Decoder: Interpreter (precise)
SPU Decoder: Interpreter (precise)
Manually load selected libraries
Enabled SPU Loop detection
Graphics Render: Vulkan / OpenGL (I gave two logs)
Audio Out: XAudio2

Logs:
https://mega.nz/#!qlhm1TRT!_eum6iCKlDtkz...sKXKCaTa0E
This post was last modified: 11-25-2017, 04:34 PM by ori0032.
Ani
Administrator
*******


11
3,532 posts 94 threads Joined: Aug 2017
11-24-2017, 08:08 PM -
#24
> Firmware version: 1.82
1.82 or 4.82?
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
11-25-2017, 04:35 PM -
#25
(11-24-2017, 08:08 PM)Ani Wrote: >  Firmware version: 1.82
1.82 or 4.82?

lol 
yeah it's 4.82 and i fixed it on my post

Another things.
I wanted to ask:
1. There's option to track the progress related to this game or maybe i need to check every update and report if there is a change (and to give a log of course)?

2. and do i need to quote you when i'm posting a new log?
This post was last modified: 11-25-2017, 06:40 PM by ori0032.
irixion
Member


0
1 posts 0 threads Joined: Nov 2017
Exclamation  12-12-2017, 06:01 PM -
#26
Edit: Apparently this was already a thread but I didn't see it using Search :|

RPCS3 v0.0.4-ca00ec4a Alpha

[Image: CSfJHsC.png]

Gets to the intro loading screen, and then hangs with

"F {PPU[0x1000000] Thread (main_thread) [0x00e2ab64]} MEM: Access violation reading location 0x0"

Settings:

PPU Interpreter (precise)
SPU Interpreter (precise)

Auto/Manual Selection.
Libraries used: libaudio.sprx, libfs.sprx, libio.sprx, libresc.sprx, libspurs_jq.sprx, libsre.sqrs.

Different PPU and SPU combinations tried, as well as many different builds (including the mem access violation fixes) but no dice on any of them.
This post was last modified: 12-14-2017, 08:10 PM by irixion.


Attached Files
.gz   RPCS3.log.gz (Size: 163.08 KB / Downloads: 0)
MsDarkLow
Member


0
38 posts 8 threads Joined: Aug 2017
01-28-2018, 04:03 PM -
#27
Build rpcs3-v0.0.4-2018-01-27-a27e2db4_win64

Goes ingame on OpenGL and Vulkan but sometimes it crashes when loading a save file, especially on Vulkan?
The graphics flicker A LOT

Seemed to go at full speed in the starting area.

https://youtu.be/IN4TrTw8cX0
This post was last modified: 01-28-2018, 04:56 PM by MsDarkLow. Edit Reason: Video


Attached Files Thumbnail(s)
           

.gz   RPCS3.log.gz (Size: 743.64 KB / Downloads: 3)
Just chilling around here I suppose.
I'm literally from Portugal. What else do you want to know.
Also love to test stuff.

Discord: MsLow#2316
ehw
Member


0
1 posts 0 threads Joined: Jun 2018
06-23-2018, 05:24 PM -
#28
Just an update. The game is still having issues with the flickering and random hangs with random MEM: Access violation reading location 0x0 errors. It doesn't matter what video backend or cpu/gpu setting you use, and the behavior hasn't really changed since the last time. Sad
Metasynic
Member


0
7 posts 0 threads Joined: Jan 2019
01-06-2019, 02:19 PM -
#29
Update with build 7658: Using the default settings, it's possible to go ingame but the graphics flicker constantly and the game crashes randomly with "Memory Access Violation reading location 0x0" errors. Having had a look around there are some "Nothing" games that appear to have a similar issue with reading 0x0.
Asinine
Moderator
*****


3
1,962 posts 79 threads Joined: Aug 2017
01-14-2019, 01:44 PM -
#30
Memory Access Violations are the symptom, not the cause. they dont mean much to developers and require debugging to find the real problem.


Forum Jump:


Users browsing this thread: 2 Guest(s)