Hello There, Guest! Register

Ratchet and Clank Future: Tools of Destruction [BCES00052]
#1
  • Shows a black screen with 0.01 FPS
  • Once it starts, the console is constantly spammed with "·U {PPU[0x1000000] Thread (main_thread) [0x00839bb0]} cellGame TODO: cellDiscGameGetBootDiscInfo", and it goes on forever until I stop the emulator.

Modules:
  • libfs
  • libjpgdec
  • libl10n
  • libpngdec
  • libspurs_jq
  • libsre
Reply
#2
Goes further with PR #2390, but seems has broken path issues. Keeps looping
Code:
...
·U {PPU[0x1000016] Thread (fios mediathread) [0x009a4ec0]} sys_fs TODO: sys_fs_fcntl(): Unknown operation 0xc0000006 (fd=4294967295, arg=*0xd00c74f8, size=0x20)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(path=“PIC1.PNG”, sb=*0xd00c7648)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} vfs::get(): invalid input: PIC1.PNG
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(“PIC1.PNG”) failed: not mounted
·E {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} 'sys_fs_stat' failed with 0x8001003a : CELL_ENOTMOUNTED
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(path=“”, sb=*0xd00c7508)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} vfs::get(): invalid input:
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(“”) failed: not mounted
·E {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} 'sys_fs_stat' failed with 0x8001003a : CELL_ENOTMOUNTED
·! {PPU[0x1000016] Thread (fios mediathread) [0x0082745c]} sys_tty: sys_tty_write(ch=0, buf=*0x20000010, len=19, pwritelen=*0xd00c7040)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(path=“”, sb=*0xd00c7508)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} vfs::get(): invalid input:
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(“”) failed: not mounted
·E {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} 'sys_fs_stat' failed with 0x8001003a : CELL_ENOTMOUNTED
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} sys_fs: sys_fs_stat(path=“”, sb=*0xd00c7508)
·W {PPU[0x1000016] Thread (fios mediathread) [0x009a5ee4]} vfs::get(): invalid input:
...

LLE used
Code:
- libac3dec.sprx
    - libac3dec2.sprx
    - libadec.sprx
    - libapostsrc_mini.sprx
    - libat3dec.sprx
    - libatrac3plus.sprx
    - libatxdec.sprx
    - libdmux.sprx
    - libdmuxpamf.sprx
    - libfs.sprx
    - libl10n.sprx
    - libpamf.sprx
    - libresc.sprx
    - librtc.sprx
    - libsail.sprx
    - libsail_avi.sprx
    - libsail_rec.sprx
    - libsjvtd.sprx
    - libsmvd2.sprx
    - libsmvd4.sprx
    - libspurs_jq.sprx
    - libsre.sprx
Reply
#3
Seems to have made slightly more progress with recent builds, and the FPS counter now reaches 60fps. It doesn't boot yet, unfortunately.

Give it at least one months worth of revisions and I guarantee it will boot.
Reply
#4
Update: It boots! Big Grin (But crashes before showing the Insomniac logo :/ )

Auto LLE modules were used.

Please move this thread
Reply
#5
Well, this doesn't look very good. This game is "completely fucked" according to cell_juhn:
[Image: DmVOXOB.png]

Looks like the only way we can make this game go any further is to basically rip apart the game's files :/
Reply
#6
Alright, so if the Null renderer is used, I believe TOD actually goes ingame. However, there's two issues:

1. Null Renderer (obviously) prevents you from seeing anything.

2. This game needs libaudio to boot. Loading it breaks all sound, and nothing can be heard.


That being said, if I press Start and X a little while after booting, the save data prompt comes up, meaning I'm on the title screen. There appears to be no issues related to savedata, so I can proceed onwards, meaning it most likely goes ingame after this point.
Reply
#7
I still wouldn't consider it in game since you can't see anything, and thus can't confirm how far it gets.
Reply
#8
RPCS3 v0.0.4-6359-a27e2db45 Alpha
Intel® Core™ i7-6700HQ CPU @ 2.60GHz | 8 Threads | 7.88 GiB RAM | AVX+ | TSX

Now displays some image before dying with
E {rsx::thread} HLE: Getting the real address failed. (addr=0x82b48480)
F {rsx::thread} class std::runtime_error thrown: GetAddress(offset=0x82b48480, location=0x1): RSXIO memory not mapped
(in file Emu\RSX\RSXThread.cpp:55)

Still Intro.

.7z   BCES00052.7z (Size: 51.24 KB / Downloads: 13)


Attached Files Thumbnail(s)
       
Reply
#9
(01-28-2018, 09:52 PM)Ani Wrote: RPCS3 v0.0.4-6359-a27e2db45 Alpha
Intel® Core™ i7-6700HQ CPU @ 2.60GHz | 8 Threads | 7.88 GiB RAM | AVX+ | TSX

Now displays some image before dying with
E {rsx::thread} HLE: Getting the real address failed. (addr=0x82b48480)
F {rsx::thread} class std::runtime_error thrown: GetAddress(offset=0x82b48480, location=0x1): RSXIO memory not mapped
(in file Emu\RSX\RSXThread.cpp:55)

Still Intro.

ingame on hacked build, i know its useless to say but you know people want to know if this game is impossible to play for a long time
Reply
#10
RPCS3 v0.0.5-6844-0fc67aa2f Alpha

System Specs -
i5-8400
16GB DDR4 2114MHz
GTX 970

Exhibits a Black Screen with no audio on all default settings
disabling Renderer plays the audio as the above - but it can actually load my save and play abeilt with extremely choopy audio ( i can hear ratchet swing his wrench and shoot in game 9 despite the emulator claiming its running at '19fps' (I highly doubt that...)

even though it has a completely white screen - Only using DXD12 Shows the intro cinematics of Insomaniac then loops the memory error.

.7z   RCToD - Master RPCS3 0.0.5-6844 Alpha Build.7z (Size: 184 KB / Downloads: 6)
   
   
   

Using Jarves' Non-master Build (it is not representative of the RPCS3 Emulation Team's dedication and quality control as such its only there to show that one day it can be playable):
https://www.youtube.com/watch?v=TVx0z32g...e=youtu.be
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)