BlackDaemonPrince of Persia [BLUS30214]
Started by BlackDaemon




10 posts in this topic
BlackDaemon
Moderator
*****


2
844 posts 374 threads Joined: Aug 2017
02-02-2017, 05:51 AM -
#1
Tested on recent master build v0.0.1-9eba0ac5 (PR #2317). Shows autosaving screen, and doesn't react on controls input.

LLE used
Code:
- libadec.prx
- libat3dec.prx
- libatrac3plus.prx
- libatxdec.prx
- libl10n.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx
GrantKane
RPCS3 Tester


0
2,669 posts 1,777 threads Joined: Aug 2017
12-26-2017, 04:02 PM -
#2
RPCS3 v0.0.4-6273-3cf0fb60 Alpha | HEAD
Quote:·F 0:10:43.142413 {PPU[0x1000000] Thread (main_thread) [0x000f3f88]} MEM: Access violation reading location 0x765f6864
[Image: JU3eeL8.jpg]


Attached Files
.7z   RPCS3.7z (Size: 54.61 KB / Downloads: 9)
MasterTurkey
Member


0
125 posts 51 threads Joined: Feb 2018
04-09-2018, 04:06 AM -
#3
RPCS3 v0.0.5-6647-64992f758 Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.96 GiB RAM | AVX+ | TSX

Ingame. OpenGL. Need to create a folder in 'game' folder first.

This post was last modified: 04-09-2018, 04:07 AM by MasterTurkey.


Attached Files Thumbnail(s)
               

.7z   PrinceofPersia_RPCS3.7z (Size: 1.5 MB / Downloads: 11)
hbzlmx
Member


0
3 posts 1 threads Joined: Apr 2018
07-26-2019, 03:31 PM -
#4
Now it is playable
RPCS3 v0.0.6-8416 Alpha 
Vulkan
digitaldude
RPCS3 Tester


0
2,714 posts 533 threads Joined: Aug 2017
07-26-2019, 04:31 PM -
#5
Need log and 3 screenshots.
hbzlmx
Member


0
3 posts 1 threads Joined: Apr 2018
07-27-2019, 10:42 PM -
#6
Screenshots:

[Image: pic1.png]             [Image: pic2.png]            [Image: pic3.png]

Log file
mysterion23
Member


0
3 posts 0 threads Joined: Jun 2019
09-14-2019, 09:54 PM -
#7
Apart from some sound synchronization problems, the game seems playable 



Something important to notify: it seems that to be able to play dlc ( called Epilogue),
you have to put the SPU at LLVM Recompiler (instead of "ASMJIT" for the main game) and enable "accurate xfloat"

Ani
Administrator
*******


10
3,483 posts 94 threads Joined: Aug 2017
10-30-2019, 02:42 AM -
#8
Missing proper game report with full version identifier
This post was last modified: 10-30-2019, 02:43 AM by Ani.
jsc__123
Member


0
11 posts 0 threads Joined: Oct 2020
11-20-2020, 09:38 PM -
#9
struggling to get this running. I am using default settings - created a folder with game ID (BLUS30214) in the game directory, but I am getting memory errors and I never get in game. Log attached.

RPCS3 v0.0.13-11265-28cbba5a Alpha | HEAD | Firmware version: 4.86
Intel® Core™ i7-9700K CPU @ 3.60GHz | 8 Threads | 47.94 GiB RAM | TSC: 3.600GHz | AVX+ | FMA3
Operating system: Windows, Major: 10, Minor: 0, Build: 19042, Service Pack: none, Compatibility mode: 0
RSX: Found vulkan-compatible GPU: 'GeForce RTX 2060 SUPER' running on driver 457.30.0.0

E {PPU[0x1000000] Thread (main_thread) [0x00e14c48]} SYS: 'sys_mutex_lock' failed with 0x80010005 : CELL_ESRCH [1]
E {PPU[0x1000000] Thread (main_thread) [0x00e14d58]} SYS: 'sys_mutex_unlock' failed with 0x80010005 : CELL_ESRCH [1]
E {PPU[0x1000000] Thread (main_thread) [0x01921ee4]} SYS: 'sys_fs_stat' failed with 0x80010006 : CELL_ENOENT, “/dev_bdvd/PS3_GAME/USRDIR/POP0_ISO” [1]
U {PPU[0x1000000] Thread (main_thread) [0x0183ff0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)
E {PPU[0x1000000] Thread (main_thread) [0x0183ff0c]} SYS: '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1]
U {PPU[0x1000000] Thread (main_thread) [0x0183ff0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)
E {PPU[0x1000000] Thread (main_thread) [0x0183ff0c]} SYS: '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [2]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x016107f8, LR:0x00159ab4]} cellGame: cellGameDataCheckCreate2(version=0x0, dirName=“POP0”, errDialog=0x1, funcStat=*0x133a8a0, container=4294967295)
E {PPU[0x1000000] Thread (main_thread) [0x01921ee4]} SYS: 'sys_fs_stat' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd0/game/POP0/USRDIR/data/ispatch.txt” [1]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x016167b8, LR:0x001769e0]} SYS: 'cellPadClearBuf' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [1]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x01616810, LR:0x00167218]} SYS: 'cellPadInfoSensorMode' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [1]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x016167b8, LR:0x001769e0]} SYS: 'cellPadClearBuf' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [2]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x01616810, LR:0x00167218]} SYS: 'cellPadInfoSensorMode' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [2]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x016167b8, LR:0x001769e0]} SYS: 'cellPadClearBuf' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [3]
E {PPU[0x1000000] Thread (main_thread) [HLE:0x01616810, LR:0x00167218]} SYS: 'cellPadInfoSensorMode' failed with 0x80121107 : CELL_PAD_ERROR_NO_DEVICE [3]
E {PPU[0x1000003] Thread (Loading) [0x01922090]} SYS: 'sys_fs_open' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd0/game/POP0/USRDIR/data/dataps3.forge” [1]
F {PPU[0x1000003] Thread (Loading) [0x001059d4]} VM: Access violation reading location 0x78 (unmapped memory) [type=u32]


Attached Files
.gz   RPCS3.log.gz (Size: 90.32 KB / Downloads: 0)
mousesama
Member


0
2 posts 0 threads Joined: Dec 2020
12-29-2020, 07:16 PM -
#10
Last time I tried running the game (don't remember what RPCS3 version), the performance kept dropping from 60 FPS (using 120Hz vblank) to 30-40 randomly even just standing around, including stuttering and hitches in sound - unplayable.

However, today I tried running the game again on new build and was able to get solid 60FPS, only occasionally dropping to 50-55 FPS, mostly in bigger areas. Using 100% resolution scaling, game used 60-80% of my GPU, when other games usually use 30-40% of that and I can easily run 300% scaling at 60FPS so there's probably some bottleneck somewhere. Played through a chunk of the game so far without major issues - encountered a few memory access violation crashes as well as at one point looking in certain direction produced some graphical glitches - see screenshot - but otherwise perfectly playable so far.

Will update as I play through the game more to see if I can complete it. Log is from my last session, ending with a crash.

No settings changed from default, other than adjusting vblank frequency to 120Hz to get 60FPS in game.

RPCS3 v0.0.13-11487-57621d1c Alpha | HEAD | Firmware version: 4.86
AMD Ryzen 9 5900X 12-Core Processor | 24 Threads | 31.95 GiB RAM | TSC: 3.693GHz | AVX+ | FMA3

Operating system: Windows, Major: 10, Minor: 0, Build: 19042, Service Pack: none, Compatibility mode: 0
RSX: Found vulkan-compatible GPU: 'GeForce GTX 980 Ti' running on driver 457.30.0.0


Attached Files Thumbnail(s)
   

.7z   log.7z (Size: 584.79 KB / Downloads: 2)


Forum Jump:


Users browsing this thread: 1 Guest(s)