Hello There, Guest! Register

Deception IV Blood Ties [BLES01997]
#1
Several aspects of the game looks to be working, including save/load and such. But there are some graphics errors in the log and a lot of flickering shadows and broken textures and such.

Settings:
OpenGL 1280x720
PPU & SPU Recompiler works but the PPU recompiler is only a little faster.
XAudio

LLE: as usuall not everything is needed (probably) but it takes time and effort to narrow the list down...

Code:
.
    - libac3dec.prx
    - libac3dec2.prx
    - libadec.prx
    - libat3dec.prx
    - libatrac3plus.prx
    - libatxdec.prx
    - libavcdec.prx
    - libdmux.prx
    - libdmuxpamf.prx
    - libfont.prx
    - libfontFT.prx
    - libfreetype.prx
    - libfreetypeTT.prx
    - libl10n.prx
    - libmvcdec.prx
    - libpamf.prx
    - libresc.prx
    - librtc.prx
    - libsail.prx
    - libsjvtd.prx
    - libsmvd2.prx
    - libsmvd4.prx
    - libspurs_jq.prx
    - libsre.prx
    - libsvc1d.prx
    - libsync2.prx
    - libvdec.prx

Log


Screenshots

Reply
#2
((Test on RPCS3 LLVM-aef5113d))


Interpreter(fast) & Interpreter(ASMJIT)
Better in OpenGL
--------------------
Movie : Work
Graphic : Slow - Problem in Graphic
Music : Work
SaveGame : Work
LoadGame : Work



The Log File:-
BLES01997 - [Deception IV Blood Ties] - File

___________________________________
CPU:- Intel I7-6800K @ 3.40 GHz (OverClock 4.5 GHz)
GPU:- GTX 1080
Motherboards:- ASUS X-99A-II
RAM:- 32.0 GB (2666 MHz)
Reply
#3
Graphics in this game almost looks good, there are some lighting problems when enemy status is shown, and brightness setting not working.
I beat 1 chapter with 15-30 FPS on KD-11 186ebc50 vertex rewrite build, because new master are much slower and SPU crashes (it depends on FPS, less FPS, crashes faster) after a few seconds / minutes.
Settings:
Recompiler LLVM
Recompiler ASMJIT
Bind SPU threads to secondary cores: false
Lower SPU thread priority: false
SPU loop detection: true
Preferred SPU Threads: Auto
Vulcan
1280x720, fullHD not working.
options: everything but vsync turn off.

It may work even on master on more powerful CPU with 8 threads.
Reply
#4
Yeah, it works decently well. There are couple of slowdowns, but i think it is completely playable.
So general problems are some performance drops, lighting problem and graphics glitches. Saves work w/o problem

Ive made a video and attached log.


p.s. sound cracks are produced mostly by screen capture impact (without it they are rare)


RPCS3.log Download
Intel Core i7 - 4790k @4.4 Ghz
Asus - Z97 Pro
Asus - GTX970 - Strix
16GB DDR3 @1600
Win 10 Pro x64
Reply
#5
After a few hour test on new slow master I get even more stable 25-30 FPS using audio thread pause, when game stops I run it again, watch dialogues, and after repause it.
This game played with low FPS make always audio thread crash. Only playable on very fast processors.
Reply
#6
Moving to playable.

Use SPU thread options instead of the pause hack... Try 1-4 threads and loop detection on.
Reply
#7
So in its current state its playable with:
Vulkan and OpenGL (slower).
With DX12 its Loadable (crashes emu after intro - dialogues) with this message:
Quote:F {rsx::thread} class std::runtime_error thrown: HRESULT = D3D12 device was removed with error status 0x887A0001
(in file C:\rpcs3\rpcs3\Emu\RSX\D3D12\D3D12Texture.cpp:161)

Game menus and dialogs are at 30fps but when actual game starts its pretty bad (5-10 fps) until you walk some rooms and kill enemies then it gets better (20-30fps). At pause - trap menu its 30fps.
Intel Core i7 - 4790k @4.4 Ghz
Asus - Z97 Pro
Asus - GTX970 - Strix
16GB DDR3 @1600
Win 10 Pro x64
Reply
#8
(08-08-2017, 06:49 PM)vlakipn Wrote: Yeah, it works decently well. There are couple of slowdowns, but i think it is completely playable.
So general problems are some performance drops, lighting problem and graphics glitches. Saves work w/o problem

Ive made a video and attached log.


p.s. sound cracks are produced mostly by screen capture impact (without it they are rare)


RPCS3.log Download

care to tell us with which settings? I7 3.60 with 16 gb and geforce gtx 970 4 gb here, and its super slow once is in the game
Reply
#9
Quote:care to tell us with which settings? I/ 3.60 with 16 gb and geforce gtx 970 4 gb here, and its super slow once is in the game
[Image: O5v0e0Z.png]
[Image: 8zTVCqd.png]

Nothing specific as you can see. The problem is, game starts rly slow, but it gets faster as you progress (lets say walk over 2-3 rooms and/or kill 2-3 enemies), then it gets faster untill it reaches stable 30fps. Dunno whats the cause of this, but it seems to be the pattern.
Give it a try.
Intel Core i7 - 4790k @4.4 Ghz
Asus - Z97 Pro
Asus - GTX970 - Strix
16GB DDR3 @1600
Win 10 Pro x64
Reply
#10
(08-14-2017, 12:59 PM)vlakipn Wrote:
Quote:care to tell us with which settings? I/ 3.60 with 16 gb and geforce gtx 970 4 gb here, and its super slow once is in the game
[Image: O5v0e0Z.png]
[Image: 8zTVCqd.png]

Nothing specific as you can see. The problem is, game starts rly slow, but it gets faster as you progress (lets say walk over 2-3 rooms and/or kill 2-3 enemies), then it gets faster untill it reaches stable 30fps. Dunno whats the cause of this, but it seems to be the pattern.
Give it a try.

thanks Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)