Hello There, Guest! Register

Hatsune Miku: Project DIVA F [BLUS31319]
#61
(07-31-2016, 06:40 PM)Lemiru Wrote: Hi. In few songs some parts of it looks strange like this:

Screenshot is from Urbandonment. Any ideas how to fix this?

You can't fix it, you either wait for devs to fix regressions, or just use an older build that worked.
Reply
#62
Good news,
-The game saves and loads data properly now !
-Nvidia scaling issues (vulkan) along with some graphical issues are fixed.
-Performance improvements

Bad news,
-Emulator's audio can disappear randomly now (XAudio)
-OpenAL outputs no sound.

The game still crashes after a while and vulkan still has texture glitches in some costumes; dx12 shows no progress from what I've seen.

(tested build rpcs3-ReleaseLLVM-208f4c3e)
Reply
#63
Audio issue comes from this

https://github.com/RPCS3/rpcs3/pull/1995
Reply
#64
So the audio was already fixed and at least with vulkan you can play all the time you want without crashes.

Today I finished all the songs so the game is finally fully playable. The only issues that remain are related to video playback and texture glitching, no big deal.
Reply
#65
(08-14-2016, 07:20 AM)ryustylish Wrote: So the audio was already fixed and at least with vulkan you can play all the time you want without crashes.

Today I finished all the songs so the game is finally fully playable. The only issues that remain are related to video playback and texture glitching, no big deal.

Video playback is working with LLE modules. (libadec,libatxdec,libdmux,libdmuxpamf,libpamf)
Reply
#66
(08-14-2016, 11:09 AM)Nezarn Wrote:
(08-14-2016, 07:20 AM)ryustylish Wrote: So the audio was already fixed and at least with vulkan you can play all the time you want without crashes.

Today I finished all the songs so the game is finally fully playable. The only issues that remain are related to video playback and texture glitching, no big deal.

Video playback is working with LLE modules. (libadec,libatxdec,libdmux,libdmuxpamf,libpamf)

Yes, I know, but they freeze during the songs after a while.

The intro plays fine.
Reply
#67
Most of Vulkan graphic glitches (excluding HUD) doesn't appear in the newest build.
Reply
#68
I wonder, what kind of settings / configuration (loaded lib, PPU, SPU, fs setting, etc) you guys use ?

My PD F is barely loaded, it does shown its splash screen, the welcome voice but then, BOOM, an exception is thrown

Code:
Fatal error

Unhandled Win32 exception 0xC0000005.
Segfault reading location 00000000b97f0000 at 000000001007b387.
Instruction address: 000000001007b387.
Function address: 000000001007b350 (base+0x7b350).
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.

Here is my log dump and here is for my RPCS3 config.yml
(Both link are pointing to pastebin)

I don't know what i miss, so any kind of help and clues will appreciated.

Thank you
Reply
#69
(10-08-2016, 05:50 AM)ElementalCyclone Wrote: I wonder, what kind of settings / configuration (loaded lib, PPU, SPU, fs setting, etc) you guys use ?

My PD F is barely loaded, it does shown its splash screen, the welcome voice but then, BOOM, an exception is thrown

Code:
Fatal error

Unhandled Win32 exception 0xC0000005.
Segfault reading location 00000000b97f0000 at 000000001007b387.
Instruction address: 000000001007b387.
Function address: 000000001007b350 (base+0x7b350).
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.

Here is my log dump and here is for my RPCS3 config.yml
(Both link are pointing to pastebin)

I don't know what i miss, so any kind of help and clues will appreciated.

Thank you

Use the PPU interpreter (fast one) and not the recompiler.
Reply
#70
Quote:Use the PPU interpreter (fast one) and not the recompiler.

Well, surprisingly, it works, playable and i get 28+ fps, thanks ssshadow.

But even though i get 28+ fps, is it normal that the images and audio appear to be miss or skipped few frames and yet still appear slow at the same time ?


#A bit out of topic
So, ssshadow, why did you recommend me to use the Interpreter instead of Recompiler ? what is the difference between them ? is there any link or reference that i can read ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)