Rpcs3 hangs in Task Manager
Started by Pit2018

11 posts in this topic

2 posts 0 threads Joined: Jun 2018
06-26-2018, 05:07 PM -
Well Crap, digging deeper into the support I found a thread form a while back. Perhaps we all have the same issue where we went from a previous AMD graphics card to an NVidia card. If so, this advice from a different forum instantly fixed it for me
I had the same problem of rpcs3 not showing the UI. Updated drivers and installed the VulkanSDK but that didn't help. However, I found a way to get the post-6796 builds to work as intended. I opened regedit and in "HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\Vulkan\Drivers" the first entry was "C:\Windows\System32\amd-vulkan64.json". I previously had an AMD gpu but currently I have a nVidia one, so I deleted that entry and now everything works.

2 posts 1 threads Joined: Apr 2018
06-27-2018, 09:27 PM -
I am an AMD GPU user and had that issue (R9 380).
Removing that entry is not an option for me since it will fix the issue but will cause Vulkan to stop functioning on AMD GPUs.

That's my diagnosis and how i fixed it:

RPCS3 attempts to use existing traces from old AMD drivers.

1.Download and install Display Driver Uninstaller (to remove all traces and the entire AMD drivers).
2.Choose the AMD option.
3.clean and restart.
4.Install the drivers for your GPU and you are ready to go.

Forum Jump:

Users browsing this thread: 1 Guest(s)