Fatal error (STOP code: 0x3fff) in Borderlands 2
Started by darioq303

2 posts in this topic

2 posts 1 threads Joined: Dec 2022
12-21-2022, 02:42 PM -

Many of games work fine, but there's a problem.

I get an error when launching Borderlands™ 2 [BLES01684] or [NPEB01144]:

U sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0) x2
F {SPU[0x0000200] Thread (CompPatchCellSpursKernel0) [0x03104]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x3fff (op=0x3fff, Out_MBox=empty)
(in file C:\Users\ContainerAdministrator\AppData\Local\Temp\cirrus-ci-build\rpcs3\Emu\Cell\SPUThread.cpp:5753[:22], in function stop_and_signal)


.gz   RPCS3.log.gz (Size: 67.74 KB / Downloads: 1)

I use default settings.
I tried all four recompilers in the SPU Decoder section - same error.
Also the same error occurs at startup Ratchet & Clank™: Nexus [BCES01908]

How can I fix it?

My System:
CPU: i5 12400f
VIDEO: GTX 1070 Driver 516.94
RAM: 16 GB
OS: Windows 10 x64

2 posts 1 threads Joined: Dec 2022
12-22-2022, 06:12 PM -
I'll answer myself.
Maybe this will be useful to someone.
I tried asking for help on Discord RPCS3 and the bot replied me that a firmware of at least 4.80 is recommended for Borderlands 2.
I decided to check which one I had installed and of course I had the ancient 2.49 or something similar. I don't even know why ((
In the end, updating the firmware from the Sony website to version 4.89 completely solved the problem and the game runs and works perfectly!
Thank you all and forgive my inattention!

4,277 posts 105 threads Joined: Aug 2017
12-22-2022, 08:04 PM -
RPCS3 doesn't work properly with older firmware since it targets to emulate the latest version, the quickstart guide tells you to grab the latest version from the PS3 update page and this is for any game
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux

Forum Jump:

Users browsing this thread: 1 Guest(s)