Hello There, Guest! Register

The Ratchet & Clank Trilogy [BCES01503]
#1
It boots up and shows the health and safety information, Sony Logo, Insomniac Games Logo, etc. and then gets to the game selection screen.

However, it doesn't respond to button inputs for me, so I can't change what game is selected\try to start up a game.

Settings:
  • Modules:
  • libaudio
  • libspurs_jq
  • libsre
  • libaudio
  • libl10n
  • Other Settings:
  • VSync
  • D3D12
  • ASMJIT Recompiler
  • PPU Interpreter: Fast
Reply
#2
(02-15-2017, 02:53 AM)shoopdahoop22 Wrote: It boots up and shows the health and safety information, Sony Logo, Insomniac Games Logo, etc. and then gets to the game selection screen.

However, it doesn't respond to button inputs for me, so I can't change what game is selected\try to start up a game.

Settings:
  • Modules:
  • libaudio
  • libspurs_jq
  • libsre
  • libaudio
  • libl10n
  • Other Settings:
  • VSync
  • D3D12
  • ASMJIT Recompiler
  • PPU Interpreter: Fast

Has it a executable per game? (Like in God of War Collection)
Desktop: Intel Core i7-6700K, Nvidia GeForce GTX 970 (OpenGL, DirectX12 & Vulkan), Windows 10
Laptop: Intel Core i7-7700HQ, Nvidia GeForce GTX 1060 (OpenGL, DirectX12 & Vulkan), Windows 10
Reply
#3
(02-20-2017, 02:40 PM)MarioSonic2987 Wrote:
(02-15-2017, 02:53 AM)shoopdahoop22 Wrote: It boots up and shows the health and safety information, Sony Logo, Insomniac Games Logo, etc. and then gets to the game selection screen.

However, it doesn't respond to button inputs for me, so I can't change what game is selected\try to start up a game.

Settings:
  • Modules:
  • libaudio
  • libspurs_jq
  • libsre
  • libaudio
  • libl10n
  • Other Settings:
  • VSync
  • D3D12
  • ASMJIT Recompiler
  • PPU Interpreter: Fast

Has it a executable per game? (Like in God of War Collection)


Every game has its own executable, but all of them throw out an access violation error immediately whenever you try to start it.
Reply
#4
W {PPU[0x1000000] Thread (main_thread) [0x01612f74]} sys_lwmutex: _sys_lwmutex_create(lwmutex_id=*0xd00207f0, protocol=0x2, control=*0x15d8f38, arg4=0x80000001, name=0x5f6c67636d747800, arg6=0x0)
W {PPU[0x1000000] Thread (main_thread) [0x005c5924]} sys_time: sys_time_get_timezone(timezone=*0xd0020950, summertime=*0xd0020954)
W {PPU[0x1000000] Thread (main_thread) [0x005c7394]} sys_time: sys_time_get_timezone(timezone=*0xd0020950, summertime=*0xd0020954)
W {PPU[0x1000000] Thread (main_thread) [0x005c58d0]} sys_time: sys_time_get_timezone(timezone=*0xd0020950, summertime=*0xd0020954)
W {PPU[0x1000000] Thread (main_thread) [0x005c7394]} sys_time: sys_time_get_timezone(timezone=*0xd0020950, summertime=*0xd0020954)
W {PPU[0x1000000] Thread (main_thread) [0x01612f74]} sys_lwmutex: _sys_lwmutex_create(lwmutex_id=*0xd00208f0, protocol=0x2, control=*0x15af400, arg4=0x80000001, name=0x7073334844444c00, arg6=0x0)
W {PPU[0x1000000] Thread (main_thread) [0x005d3ee8]} sys_memory: sys_memory_allocate(size=0x100000, flags=0x400, alloc_addr=*0xd0020550)
F {PPU[0x1000000] Thread (main_thread) [0x005cff04]} MEM: Access violation reading location 0x0

while using RPCS3 V0.0.0-3-3-4aa8913 Alpha
Reply
#5
Should be moved to In-Game

Reply
#6
Need log file and version info, please read https://forums.rpcs3.net/thread-196671.html before making a compatibility report.
Reply
#7
(12-02-2017, 06:10 PM)Asinine Wrote: Need log file and version info, please read https://forums.rpcs3.net/thread-196671.html before making a compatibility report.

Sorry, I forgot

RPCS3 v0.0.4-6200-8f314c51 Alpha
All settings default.
Vulkan render

Log file:

.7z   RPCS3 - ratchet and clank trilogy.7z (Size: 288.13 KB / Downloads: 47)
Reply
#8
RPCS3 v0.0.4-6195-3fbc960c Alpha | HEAD
Intel® Core™ i7-3930K CPU @ 3.20GHz | 12 Threads | 11.92 GiB RAM | AVX+    gtx 970
goes in game  20~60 fps but with missing parts from the map




Attached Files
.7z   Ratchet & Clank 2.7z (Size: 811.92 KB / Downloads: 19)
.7z   Ratchet & Clank 3.7z (Size: 867.29 KB / Downloads: 23)
Reply
#9
RPCS3 v0.0.4-6195-3fbc960c Alpha
In this game, the FPS always drops when light appears, specifically blue light. Robots who use light, places with blue light, or many enemies. If you turn the camera where it does not show that the fps is 60
Reply
#10
RPCS3 Version:
rpcs3-v0.0.6-8435-e40b76b2_win64

Settings:
I changed it to Vulkan and locked the FPS to 60. apart from that everything as default

Report:
Just checked it and it seems to be Playable
First game Mostly between 50-60 FPS (sometimes it drop between 45-48 FPS)
Edit: i played more into the first game and i found a minor glitches like those:
https://i.imgur.com/pydJeRK.jpg
https://i.imgur.com/TzWmLkZ.jpg
(But it does not prevent playing it well because most of the game is fine!)
==================================================================

The second and third games are solid 60 FPS! (apart from some cutscenes that i saw one them drop to 22 in the second game)

First game:


============================================================================
Second game: (there was a problem with the upload so part of the video is stuck between 1.40 - 2.14 but the game was running smoothly)


============================================================================
Third game:



Attached Files
.gz   RPCS3 first game minor glitches.log.gz (Size: 383.06 KB / Downloads: 11)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)