RPCS3 Forums

Full Version: Gran Turismo® 6 [BCES01893]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6
BioSchock96 i tested with your config. Crash for me. I think non TSX cpu's never playable this game.
Here is the video of the situation. https://youtu.be/XeFNg2Rc21Q
Hey all.

Gran Turismo®6 [BCES01893] Ver. 1.05
 
Tested on these PC Specs:

AMD Ryzen 5 3600
16GB DDR4 3200, overclocked to 3466
Radeon RX 580
 
RPCS3 Build: 10627
 
CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
Additional Settings: Enable Thread Scheduler/ON,
Enable SPU Loop Detection:/ON,
SPU Cache/ON,
Else/OFF
SPU Block Size: Mega
 
GPU
Renderer: Vulkan
AF: auto
Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Additional Settings: VSync/ON,
Multithreaded RSX/ON,
Else/OFF

Debug
GPU: Disable ZCull Occlusion Queries/ON,
Force CPU Bit Emulation/ON,
Disable FIFO Reordering/ON,
Use GPU Texture Scaling: On
Else/OFF

FPS:  30 – 60

On these settings, the game shows good performance, playable, but you must wait until the SPUs are compiled, at this time it may freeze, or the performance will be lower and there will be sound freezes. Using these Debug settings, some lighting effects are disabled, but the constant blinking of the screen is removed (emulation of dynamic brightness changes is not work, it is possible to drop to 10 FPS) and performance increases.
Disable Vulkan Memory does not bring any changes except the fall of FPS. Virtual mirror does not work. Sometimes desynchronization occurs and the emulator freezes during the race, happens randomly, with a frequency of 5-10 times per hour to 2-3 in 6-7 hours, there is a dependence on FPS. When loading a lunar expedition (mission 1), the emulator freezes with an error in the log:

F {RSX [0x0bbf650]} SIG: Thread terminated due to fatal error: rsx::get_address(offset=0x402c9b10, location=0x1): RSXIO memory not mapped!
(in file d:\a\1\s\rpcs3\Emu\RSX\RSXThread.cpp:874)


During boot race, the emulator may crash without being reflected in the log. Also, when loading a race, the emulator may freeze with an error

F {SPU[0x0000100] Thread (PDICellSpursKernel0) [0x11c10]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x31b0 (Out_MBox=empty)
(in file d:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3312)

Moreover, the frequency increases with the number of opponents on the track and if you raise the Resolution Scale to 150% (1920x1080).
When updating the game to a version greater than 1.05, all shaders disappear (black screen), as I understand it.
There are also minor graphical issues

Logs and screenshots:

https://drive.google.com/file/d/1tybP9yf...sp=sharing
(07-08-2020, 04:02 PM)PY3AN Wrote: [ -> ]Hey all.

Gran Turismo®6 [BCES01893] Ver. 1.05
 
Tested on these PC Specs:

AMD Ryzen 5 3600
16GB DDR4 3200, overclocked to 3466
Radeon RX 580
 
RPCS3 Build: 10627
 
CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
Additional Settings: Enable Thread Scheduler/ON,
Enable SPU Loop Detection:/ON,
SPU Cache/ON,
Else/OFF
SPU Block Size: Mega
 
GPU
Renderer: Vulkan
AF: auto
Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Additional Settings: VSync/ON,
Multithreaded RSX/ON,
Else/OFF

Debug
GPU: Disable ZCull Occlusion Queries/ON,
Force CPU Bit Emulation/ON,
Disable FIFO Reordering/ON,
Use GPU Texture Scaling: On
Else/OFF

FPS:  30 – 60

On these settings, the game shows good performance, playable, but you must wait until the SPUs are compiled, at this time it may freeze, or the performance will be lower and there will be sound freezes. Using these Debug settings, some lighting effects are disabled, but the constant blinking of the screen is removed (emulation of dynamic brightness changes is not implemented, it is possible to drop to 10 FPS) and performance increases.
Disable Vulkan Memory does not bring any changes except the fall of FPS. Virtual mirror does not work. Sometimes desynchronization occurs and the emulator freezes during the race, happens randomly, with a frequency of 5-10 times per hour to 2-3 in 6-7 hours, there is a dependence on FPS. When loading a lunar expedition (mission 1), the emulator freezes with an error in the log:

F {RSX [0x0bbf650]} SIG: Thread terminated due to fatal error: rsx::get_address(offset=0x402c9b10, location=0x1): RSXIO memory not mapped!
(in file d:\a\1\s\rpcs3\Emu\RSX\RSXThread.cpp:874)


During boot race, the emulator may crash without being reflected in the log. Also, when loading a race, the emulator may freeze with an error

F {SPU[0x0000100] Thread (PDICellSpursKernel0) [0x11c10]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x31b0 (Out_MBox=empty)
(in file d:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3312)

Moreover, the frequency increases with the number of opponents on the track and if you raise the Resolution Scale to 150% (1920x1080).
When updating the game to a version greater than 1.05, all shaders disappear (black screen), as I understand it.
There are also minor graphical issues

Logs and screenshots:

https://drive.google.com/file/d/1tybP9yf...sp=sharing

If you leave SPU Block Size at safe, you get way better framerates and you don't have to wait for it to compile. I can do everything in game, buy cars, tune them and race but after an hour or so the game crashes randomly, doesn't matter what i'm doing ingame. i get 35-40fps.

our systems are almost identical:
Gran Turismo®6 [BCES01893] Ver. 1.02
AMD Ryzen 5 2600 @4.1ghz 
32GB DDR4 3266
Radeon RX 590
RPCS3 Build: i allways update to latest version

you have the better cpu so you should get better framerates than i do.
I feel like if the RPCS3 team would invest 1 week to optimize this game like they did with metal gear solid 4 it would run without crashing, and with enough cpu power it would run smooth enough.
Game crash when i buy car.

[Image: 4enolrI.png]
GT6 in version 1.22 always crashes after the intro video.
I tried several settings, but nothing gets me past that screen.
The non-patched version from my bluray runs and lets me at least drive the first race.
I have attached the log file: [attachment=19940]
May I support in finding and fixing the issue? I really would love to play this on my PC instead of my PS3.
(08-31-2020, 05:33 AM)Sandi1987 Wrote: [ -> ]Game crash when i buy car.

Why did you even bother to post this when you gave no log nor any useful information. What do you expect a dev to do with this?
Pages: 1 2 3 4 5 6