RPCS3 Forums

Full Version: Drakengard 3 [NPEB01407]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Automatic LLE modules.

Build: 9ea0778

Black screen only.



RPCS3 v0.0.2-8-ae9fb59 Alpha
Black Screen only, tried all 6 combinations of decoders.
·W 0:00:18.767962 {PPU[0x1000000] Thread (main_thread) [0x019191d8]} cellAudio: cellAudioInit()
·W 0:00:18.768140 {PPU[0x1000000] Thread (main_thread) [0x0191eca8]} sys_lwmutex: _sys_lwmutex_create(lwmutex_id=*0xd0040668, protocol=0x2, control=*0x1aa7300, arg4=0x80000001, name=0x454d4147444152, arg6=0x0)
·W 0:00:18.768160 {PPU[0x1000000] Thread (main_thread) [0x0191eca8]} sys_lwmutex: _sys_lwmutex_create(lwmutex_id=*0xd0040668, protocol=0x2, control=*0x1aa71f0, arg4=0x80000001, name=0x454d4147444152, arg6=0x0)
·W 0:00:18.768170 {PPU[0x1000000] Thread (main_thread) [0x0191eca8]} sys_lwmutex: _sys_lwmutex_create(lwmutex_id=*0xd0040668, protocol=0x2, control=*0x1aa7170, arg4=0x80000001, name=0x454d4147444152, arg6=0x0)
·W 0:00:18.768193 {PPU[0x1000000] Thread (main_thread) [0x008d9bdc]} sys_event: sys_event_queue_create(equeue_id=*0x206c9a54, attr=*0xd00407a0, event_queue_key=0x0, size=1)
·W 0:00:18.768206 {PPU[0x1000000] Thread (main_thread) [0x008d9c00]} sys_event: sys_event_port_create(eport_id=*0x206c9a58, port_type=1, name=0x0)
·W 0:00:18.768214 {PPU[0x1000000] Thread (main_thread) [0x008d9c20]} sys_event: sys_event_port_connect_local(eport_id=0xe00c300, equeue_id=0x8d00c200)
·W 0:00:18.768224 {PPU[0x1000000] Thread (main_thread) [0x008d9bdc]} sys_event: sys_event_queue_create(equeue_id=*0x206c9a74, attr=*0xd00407a0, event_queue_key=0x0, size=1)
·W 0:00:18.768231 {PPU[0x1000000] Thread (main_thread) [0x008d9c00]} sys_event: sys_event_port_create(eport_id=*0x206c9a78, port_type=1, name=0x0)
·W 0:00:18.768242 {PPU[0x1000000] Thread (main_thread) [0x008d9c20]} sys_event: sys_event_port_connect_local(eport_id=0xe00c500, equeue_id=0x8d00c400)
·S 0:00:18.768348 {SPU[0x2000002] Thread (Spurs1 5SPU CellSpursKernel2)} SPU: Function detected [0x02d80-0x03418] (size=0x698)
·S 0:00:18.769177 {SPU[0x2000002] Thread (Spurs1 5SPU CellSpursKernel2)} SPU: Function detected [0x00b00-0x00c68] (size=0x168)
·S 0:00:18.769638 {SPU[0x2000002] Thread (Spurs1 5SPU CellSpursKernel2)} SPU: Function detected [0x04638-0x0469c] (size=0x64)
·S 0:00:18.770025 {SPU[0x2000002] Thread (Spurs1 5SPU CellSpursKernel2)} SPU: Function detected [0x01430-0x01450] (size=0x20)
·S 0:00:18.770401 {SPU[0x2000002] Thread (Spurs1 5SPU CellSpursKernel2)} SPU: Function detected [0x04620-0x04638] (size=0x18)
·S 0:00:18.841836 {Audio Thread} XAudio 2.9 initialized
·! 0:00:55.841957 Stopping emulator...
·! 0:00:55.842037 All threads signaled...

Moving to Ingame.
Ingame: (probably Fully Playable dont had the time to playthrou it, there wasnt any glitches e.t.c. at the first couple minutes)

GTX 970, I7-4790K, Win 10, 16GB Ram, RPCS3 Build: 0.0.3-5867

Cutscenes: 30FPS
Ingame: 25-30FPS (if hes not compiling anything)

x Enable SPU loop detection
Firmware Settings: Autmatically load required libraries
Renderer: Vulkan (Tried OpenGL too, but it felt the compiling worked faster with vulkan so the gameplay was smoother)
Res: 720p (for some Reason it dont scaled right when i tryed 1080p had black bars left and right)
I tried it on master 6xxx and not works, crushes on load screen. On older version it game works but more further there was a half white background (it looks like big white borders) and every movies was black screen with subtitles.
Last working version is from 4 September, there is no white borders but only black stairs, when I go on it game show tip to use L3 and R3 at once, and on every version I tested it crashes.
Log: Mega

Gameplay until crash:
RPCS3 v0.0.3-3-6782b22 Alpha | HEAD   0.0.3-6706  
Intel® Core™ i7-3930K CPU @ 3.20GHz | 12 Threads | 9.92 GiB RAM | AVX    GTX 970
the game works 25~30 fps with vulkan 
but it crash for some rezone with this
F {PPU[0x1000000] Thread (main_thread) [0x01b57000]} MEM: Access violation reading location 0x6c

RPCS3 v0.0.5-6633-b0352d6ef Alpha | HEAD

USA version playable.
the game froze for me when I reached where these "Trolls" are. in chapter 3.
Probably random error, try again? A bunch of people have finished this game on RPCS3.