RPCS3 Forums

Full Version: Scott Pilgrim vs. The World: The Game [NPUB30162]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9


Fatal error
Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000000000000 at 0000000000458407.
Instruction address: 0000000000458407.
Function address: 0000000000457fe0 (base+0x447fe0).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
Above error means nothing by itself


I'm also getting some fatal errors if I patch to 1.03. If I return to 1.00 the game falls to about 15fps during gameplay in OpenGL. I'm assuming this isn't normal?

In any case here is the log for booting the game clean and into the first level where I'm getting 15fps:


Running the game on 1.01 with the Wallace DLC installed still runs the same way (in-fact I think load screens might be a bit faster) but Wallace is not a playable character. Here is the log for that:


Finally, patched to 1.03, the game launches but gets stuck at the autosave warning screen, the log starts going mental with the same error repeatedly. This happens with or without the Knives DLC installed.

Edit: My bad, switched to LLVM and ASMJIT and now the framerate is smooth as butter. Still having trouble getting the DLCs to work though.


(Imagine those last lines stuck in an infinite loop.) I don't know if the FPS issue I'm facing is a seperate problem or not, if it is could someone tell me what I did wrong? Hopefully those logs are helpful somehow.

Edit: My bad, I didn't set the recompilers to LLVM and ASMJIT. The game plays smoothly now and I can get Knives playable along with the extra DLC modes but Wallace remains locked away along with the non-functioning 1.03 patch.
Edit 2: Well damn, under my new settings 1.03 DOES boot but only to the menu screen. As soon as you try and get in-game it'll crash and start posting the same errors as before.


In addition to the log I posted recently, here's the message that spams repeatedly with Scott Pilgrim, even on the latest nightly. Why is it looking for RPCS3 folders in my C: drive root when I have no such folders or files there? Could this be part of the performance regression? I'm still bummed that I'm stuck on an old build of this emulator just to keep this game working. Thank you for all your help and hard work.

E {PPU[0x100000e] Thread (Transport Thread) [0x001a4070]} libnet: recvfrom(): error 0
E {PPU[0x100000e] Thread (Transport Thread) [0x001a4070]} libnet: Unknown/illegal socket error: 10045
(in file C:\rpcs3\rpcs3\Emu\Cell\Modules\sys_net.cpp:207)
It's not looking for anything inside C:\rpcs3 , that's build environment
Seems like the game wants to use networking


So that must be libnet/sysnet? I'm wondering why...Ive set the network to disabled. Is there a way to find out which libraries the game needs and maybe just disable libnet? Thanks for the reply. I'm not trying to spam this thread too much.


Why does it look like this? This started happening on the latest version, before the game worked perfectly

[Image: jEDPdUT.png]


Use OpenGL.

Vulcan has been showing a white screen for a while so the above is actually an improvement. Wink


(07-28-2017, 01:40 AM)legend80 Wrote: [ -> ]Use OpenGL.

Vulcan has been showing a white screen for a while so the above is actually an improvement. Wink
I AM using OpenGL


You're right. Scott is complete broken now on all backends on the nightly, GCM builds.....

Hopefully they recognize this and address the regression soon.
Pages: 1 2 3 4 5 6 7 8 9