EmpathaticDemon's Souls BLUS30443 Vulkan crash error
Started by Empathatic




2 posts in this topic
Empathatic
Member


0
4 posts 1 threads Joined: Sep 2020
10-01-2020, 02:40 AM -
#1
When I attempt to launch Demon's Souls with Vulkan set in the GPU options I immediately get a Fatal error that closes RPCS3. The crash message is: "Vulkan API call failed with unrecoverable error: Initialization failed (VK_ERROR_INITIALIZATION_FAILED) (in file D:\a\1\s\rpcs3\Emu\RSX\VK\VKHelpers.h:1001)

I can't get the game to run with Vulkan enabled. I've been able to run it just fine in the past until today. I can run it with OpenGL, but if I use OBS software to capture gameplay the video is constantly and intermittently flipping vertically.

Here is a link to the video showing OBS flipping vertically. I've posted to the OBS forums to see if there's a solution for that, but I suspect it has something to do with RPCS3 using OpenGL for the game as the issue with OBS never occurred before this.

https://youtu.be/ncUwfZqqIZk

I'm also attaching a screenshot showing the error. I cannot however attach the RPCS3 log file as I can't even run the game without RSPC3 completely crashing and closing.
Ani
Administrator
*******


11
3,578 posts 96 threads Joined: Aug 2017
10-01-2020, 10:26 AM -
#2
That error means Vulkan failed initialization - it's an issue on your system.
Try reinstalling your GPU drivers using DDU.
This post was last modified: 10-01-2020, 10:26 AM by Ani.
Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, Manjaro Linux
 Laptop:
Intel i7 6700HQ, Intel HD 530,      Manjaro Linux
Empathatic
Member


0
4 posts 1 threads Joined: Sep 2020
10-01-2020, 03:15 PM -
#3
(10-01-2020, 10:26 AM)Ani Wrote: That error means Vulkan failed initialization - it's an issue on your system.
Try reinstalling your GPU drivers using DDU.

I had already tried reinstalling GPU drivers, with three different methods. I uninstalled through windows applications. That didn't work. Then I tried manually uninstalling and reinstalling. That didn't work, I uninstalled the drivers and rolled back to previous driver versions, twice with different versions to see if that would work. It didn't. I even downloaded Vulkan drivers and attempted to install them specifically, and I couldn't get that work either. I gave DDU a shot this morning because I hadn't used a driver cleaner to attempt a reinstall. That did not work, I'm still getting the error.

Today I finally tried another game that I know relies on Vulkan, and it failed to initialize my GPU drivers, so it's clear it IS the system drivers for my GPU. How to solve that issue is beyond me though.

Thanks for your advice, and I'm disappointed that it didn't work.

Alright, so I got it to work.

I'm not sure exactly which step it was that fixed the issue, but here's what I did:

First I downloaded a driver version for my GPU that was 3-4 version older than the current driver, and I made a driver backup to make sure if something went wrong I had something I could roll back to.

Next I searched Change Device Installation settings in the windows search bar. This allowed me to turn off "automatically download manufacturers' apps" I believe this turns off Windows automatic installation of drivers (windows kept doing this on every restart despite the setting in DDU)

Then in Safe Mode I ran DDU, cleaning the drivers for a fresh install.

After reboot in to standard Windows, I verified through Device Manager: Display Adapters that it was the Windows Generic Display adapter. This can also be seen if your resolution doesn't change to your monitors highest resolution.

Then I made sure the Change Device Installation setting remained the same, and rebooted in to safe mode again.

In safe mode I searched my PC for every folder labeled Vulkan and NVIDIA, then deleted anything that was a shader cache or wasn't a part of game's NVIDIA logo. The earlier driver backup made this process a bit safer...

Finally after booting back in to standard Windows mode, I verified the Display Adapter was still the Windows Generic Display adapter. Then I installed the older driver I had downloaded earlier. I then tested some games that ran with Vulkan. RPCS3 did finally work.

If you have NVIDIA drivers, I highly recommend not updating to GeForce 456.55 Game Ready Driver until there's some semblance of stability.
This post was last modified: 10-01-2020, 04:49 PM by Empathatic.


Forum Jump:


Users browsing this thread: 1 Guest(s)