takagiginjoRPCS3 Not launching on 451.48 NVIDIA driver
Started by takagiginjo




5 posts in this topic
takagiginjo
Member


0
3 posts 1 threads Joined: Dec 2018
06-24-2020, 05:51 PM -
#1
Hello community. 

I have been facing a strange issue since I updated my NVIDIA driver today to the latest 451.48 that supports HAGS. RPCS3 doesn't launch, the log only creates two enteries the one with boot time and that a Vulkan supported GPU has been found. 

RPCS3 runs normally on older drivers. I DDU'ed the drivers 4 times, reinstalled the Vulkan Runtime Library to no avail. 

Any help?
Pantarei1983
Member


0
2 posts 0 threads Joined: Jun 2020
06-25-2020, 08:31 PM -
#2
(06-24-2020, 05:51 PM)takagiginjo Wrote: Hello community. 

I have been facing a strange issue since I updated my NVIDIA driver today to the latest 451.48 that supports HAGS. RPCS3 doesn't launch, the log only creates two enteries the one with boot time and that a Vulkan supported GPU has been found. 

RPCS3 runs normally on older drivers. I DDU'ed the drivers 4 times, reinstalled the Vulkan Runtime Library to no avail. 

Any help?

Same issue here with RPCS3! I've latest v2004 version of Windows 10 (all updated) with nvidia official WHQL 451.48 drivers with HAGS support (RTX 2080). RPCS3 seems open in background but no window appears.
takagiginjo
Member


0
3 posts 1 threads Joined: Dec 2018
06-27-2020, 08:49 AM -
#3
(06-25-2020, 08:31 PM)Pantarei1983 Wrote:
(06-24-2020, 05:51 PM)takagiginjo Wrote: Hello community. 

I have been facing a strange issue since I updated my NVIDIA driver today to the latest 451.48 that supports HAGS. RPCS3 doesn't launch, the log only creates two enteries the one with boot time and that a Vulkan supported GPU has been found. 

RPCS3 runs normally on older drivers. I DDU'ed the drivers 4 times, reinstalled the Vulkan Runtime Library to no avail. 

Any help?

Same issue here with RPCS3! I've latest v2004 version of Windows 10 (all updated) with nvidia official WHQL 451.48 drivers with HAGS support (RTX 2080). RPCS3 seems open in background but no window appears.
I have heard people saying that it's because of the changes in Vulkan runtime by the driver that is not supported by RPCS3. Maybe an update will come soon supporting the driver because there is a good increase in both GPU and CPU performance with this new driver.
Ani
Administrator
*******


8
3,105 posts 75 threads Joined: Aug 2017
06-27-2020, 07:58 PM -
#4
There's no such thing as "supporting the driver" when it comes to loading Vulkan. There is a specification, and RPCS3 loads Vulkan properly per specification. If anything, the driver installed incorrectly, didn't register Vulkan or is broken.
takagiginjo
Member


0
3 posts 1 threads Joined: Dec 2018
06-28-2020, 09:38 AM -
#5
(06-27-2020, 07:58 PM)Ani Wrote: There's no such thing as "supporting the driver" when it comes to loading Vulkan. There is a specification, and RPCS3 loads Vulkan properly per specification. If anything, the driver installed incorrectly, didn't register Vulkan or is broken.

It's been happening since the first 450.xx driver that supports Windows 10 2004 build. Every single game works fine, alongside Doom Eternal (Vulkan game) alongside Xenia in Vulkan mode (just a test), RPCS3 however hangs when launched, and stays on the taskbar consuming 50 mb of RAM until I close it.
Pantarei1983
Member


0
2 posts 0 threads Joined: Jun 2020
06-29-2020, 04:43 PM -
#6
(06-27-2020, 07:58 PM)Ani Wrote: There's no such thing as "supporting the driver" when it comes to loading Vulkan. There is a specification, and RPCS3 loads Vulkan properly per specification. If anything, the driver installed incorrectly, didn't register Vulkan or is broken.

Now I'm confirm that. Formatted and reinstalled clean copy of Windows 10 v2004 with most recent nvidia driver.  RPCS3 working very good now! Damn Windows 10 broken installation!


Forum Jump:


Users browsing this thread: 1 Guest(s)