chaosblade02Hi!
Started by chaosblade02




0 posts in this topic
chaosblade02
Member


0
5 posts 2 threads Joined: Jun 2020
06-24-2020, 04:39 PM -
#1
I've been using emulators for consoles for years, and recently decided to give RPCS3 a shot.  I'm shocked that this emulator runs as good as it does, and the few games I've tried all run full speed with no issues, or issues that can be solved with a custom configuration for that title.  

RPCS3 runs great on my PC:

CPU: Ryzen 5 1600x OC'd to 3.95ghz (all cores) - Been stable for 2 years.  
Ram: 16GBs DDR4 3200mhz
GPU: GTX 1080ti (no need to OC for RPCS3)
Windows 10 pro 64 bit

And to be perfectly honest, it also runs good on my old PC, and I'm quite surprised that it does.  

CPU: I5 2500k @ 4.4ghz (OC) - Been stable (mostly) since 2011, used to have it OC'd to 4.7ghz, but I dialed it back to 4.4ghz because it's an old chip.  
Ram: 16GBs DDR3 1866mhz
GPU: AMD R9 390 (OC +100 core, +200 mem) - this is almost a free OC, very minor voltage bump.  
Windows 10 pro 64 bit

Putting together a new PC here soon (as soon as the new I5s get restocked, as well as the case I want....) that's going to have these specs:

CPU: I5 10600k OC (gonna aim for at least 5ghz) with 360mm AIO cooling
Ram: 32GBs DDR4 3200mhz 
GPU: (reusing my 1080ti above because I'm priced out of upgrading this, and will put the R9 390 in my Ryzen rig, because it's still a decent 1080p card).  
Windows 10 pro 64 bit


Forum Jump:


Users browsing this thread: 1 Guest(s)