Hello There, Guest! Register

RPCS3 Hangs when using downloaded R&C save
#1
Using a save file for R&C Future Tools of Destruction from the gamefaqs website causes rpcs3 to freeze whenever I try loading it. Someone once told me to use the bruteforce save data tool (had it from the ps3 toolkit downloaded from psx place) to re-sign the save, but no matter what I did with the damn tool, the save still never worked. Kept returning an F {PPU[0x1000000] Thread (main_thread) [0x002d16e4]} VM: Access violation reading location 0x7eef6790 (unmapped memory). Whenever I tried using the bruteforce save data tool on any of my current ps3 saves, while it detected the .sfo files, the saves never seem to make a .pfd file which it seems to need to do any ps3 console related profile removal and such

Including a compressed log file


Attached Files
.gz   RPCS3.log.gz (Size: 225.76 KB / Downloads: 1)
Reply
#2
That happens when the save is encrypted
RPCS3 doesn't use PFD as well
Reply
#3
so, just to get it cleared up, is it possible for me to decrypt these saves to work with rpcs3 at all, or get them working in any respect, or is this whole thing just impossible for one without a proper jailbroken ps3 (fat or slim)
Reply
#4
It's possible to decrypt saves with Bruteforce Savedata Tool so they work on RPCS3, yes, but it seems you did the decryption incorrectly so they're still not working
That's a third party tool, don't know what could have gone wrong
Reply
#5
so....I figured out what went wrong. apparently, I was meant to leave the ps3 save file decrypted on the final result because rpcs3 cant read encrypted saves, following uses the bruteforce save data tool

After using a param.sfo file from my GoW Ghost of Sparta save to set the global profile 1 to what rpcs3 uses, I decrypt the downloaded save 1st, then unlock it to work with any ps3 account, encrypt it, rebuild it (full), then I decrypt it one more time, verify the .pfd file as valid, and close the program wholesale leaving the save decrypted. after doing so, the save loaded, I got the intro,and loaded in with all the weapons, and the latest purchasable armor

This video set me straight, and if allowed by the staff, I'd like the steps on how to properly use this tool to use ps3 saves from wherever legally downloadable (gamefaqs mainly, unless there are more hosts out there) be added to the quick-start tab on the main website

One thing I find weird and a source of game freezing, is whenever I linger on the weapons menu and look at the descriptions of the weapons long enough, the game freezes, whether I stay on one, or switch to others in 3 to 5 minute intervals. This was even after I deleted the imported save and made a proper stable-ish rpcs3 save

Also the picture below has this happen to the text, and im sure on the ps3 this never happened, any configuration tips to fix this text glitch im seeing?


Attached Files Thumbnail(s)
   
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)