Hello There, Guest! Register

Can't compile RPCS3 because of issues with cotire
#1
Question 
Hello!

I have downloaded the RPCS3 source code (cloned the repository and downloaded the submodules), installed dependencies, started building following the instructions on building.md, but cmake ended with this error message:

Code:
-- The C compiler identification is GNU 8.3.0
Code:
-- The CXX compiler identification is GNU 8.3.0
Code:
-- Check for working C compiler: /usr/bin/cc
Code:
-- Check for working C compiler: /usr/bin/cc -- works
Code:
-- Detecting C compiler ABI info
Code:
-- Detecting C compiler ABI info - done
Code:
-- Detecting C compile features
Code:
-- Detecting C compile features - done
Code:
-- Check for working CXX compiler: /usr/bin/c++
Code:
-- Check for working CXX compiler: /usr/bin/c++ -- works
Code:
-- Detecting CXX compiler ABI info
Code:
-- Detecting CXX compiler ABI info - done
Code:
-- Detecting CXX compile features
Code:
-- Detecting CXX compile features - done
Code:
CMake Error at CMakeLists.txt:3 (include):
Code:
  include could not find load file:
Code:
    cotire
Code:
-- Found Git: /usr/bin/git (found version "2.20.1")
Code:
CMake Warning at git-version.cmake:33 (message):
Code:
  git not found, unable to include version.
Code:
Call Stack (most recent call first):
Code:
  CMakeLists.txt:6 (include)
Code:
CMake Error at CMakeLists.txt:9 (include):
Code:
  include could not find load file:
Code:
    ConfigureCompiler
Code:
-- Initializing RPCS3_SRC_DIR=/home/madoka/InstallRPCS3/rpcs3/rpcs3
Code:
CMake Error at CMakeLists.txt:32 (include):
Code:
  include could not find load file:
Code:
    /home/madoka/InstallRPCS3/rpcs3/rpcs3/3rdparty/qt5.cmake
Code:
-- Looking for pthread.h
Code:
-- Looking for pthread.h - found
Code:
-- Looking for pthread_create
Code:
-- Looking for pthread_create - not found
Code:
-- Looking for pthread_create in pthreads
Code:
-- Looking for pthread_create in pthreads - not found
Code:
-- Looking for pthread_create in pthread
Code:
-- Looking for pthread_create in pthread - found
Code:
-- Found Threads: TRUE 
Code:
CMake Error at Emu/CMakeLists.txt:426 (cotire):
Code:
  Unknown CMake command "cotire".
Code:
-- Configuring incomplete, errors occurred!
Code:
See also "/home/madoka/InstallRPCS3/rpcs3/rpcs3_build/CMakeFiles/CMakeOutput.log".
Code:
See also "/home/madoka/InstallRPCS3/rpcs3/rpcs3_build/CMakeFiles/CMakeError.log".

Could you help me please?
Reply
#2
Missing the CMakeError / Output files
Reply
#3
(11-24-2019, 01:58 AM)Ani Wrote: Missing the CMakeError / Output files

Here they are.


Attached Files
.gz   CMakeLogs.tar.gz (Size: 4.72 KB / Downloads: 1)
Reply
#4
Your logs show CMake 3.13.4

RPCS3 building instructions specify CMake 3.14.1+
Reply
#5
(11-26-2019, 04:04 PM)Ani Wrote: Your logs show CMake 3.13.4

RPCS3 building instructions specify CMake 3.14.1+

I uninstalled CMake 3.13.4 and downloaded, compiled and installed CMake 3.16.0, but still get the same error.


Attached Files
.gz   logfiles.tar.gz (Size: 5.19 KB / Downloads: 1)
Reply
#6
From the output it looks like your rpcs3_build folder is actually inside the cloned repository and so you're not running cmake on the main cmake file

Should be home/madoka/InstallRPCS3/rpcs3_build/ for build folder and home/madoka/InstallRPCS3/rpcs3/ for git repository root
Reply
#7
Thank you very much!

Successfully finished the compilation recently.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)