customizerAfterburner Climax crashes with "Unhandled Win32 exception" error
Started by customizer




10 posts in this topic
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
Exclamation  07-22-2019, 05:46 AM -
#1
Hello. The game Afterburner Climax ( NPUB30151 ) crashes on rpcs3-v0.0.6-8391 after a few seconds of starting, and just before the screen that says "Press start".

RPCS3 hangs and a message appears on the screen saying:

"RPCS3: Fatal Error
Unhandled Win32 exception 0xC000001D.
Exception address: 00000000006a97a9
etc."

This game was working fine for me, running at 20 to 35 fps ingame on older releases. The issue seems to have appeared in latest releases, at least last month ones. 

I have only tested a few games with this release. Other games behave different: Top Gun crashes at the beginning the same way as Afterburner Climax; 
but Daytona USA doesn´t crash, so it seems the issue is present only in some games.

The more recent release I tested this game and in which it was working well, was rpcs3 0.0.6-8204, and I don´t know in which release the issue appeared first.

What could be the reason for crashing ?

My specs are:

PC Pentium Dual Core E5700 4 GB RAM, with Nvidia GT640 GPU -

System: Windows 10 Enterprise v.1709 64 bits

RPCS3 release used: rpcs3-v0.0.6-8391-ea2f4d57_win64 (2019-07-17)

I attach the RPCS3 LOG and other related files to the thread.


.7z   RPCS3 FILES.7z (Size: 125.55 KB / Downloads: 31)
This post was last modified: 07-22-2019, 06:21 AM by customizer.
Ani
Administrator
*******


12
3,740 posts 96 threads Joined: Aug 2017
07-22-2019, 04:54 PM -
#2
Will have to check locally, log doesn't say much
In the meantime, try with the latest build as it has some fixes added since the one you used

Can not reproduce: https://cdn.discordapp.com/attachments/2...nknown.png

This could perhaps be caused by an issue affecting old NVIDIA cards: https://github.com/RPCS3/rpcs3/issues/6103

Try disabling Anti-Aliasing and retrying.
This post was last modified: 07-22-2019, 05:18 PM by Ani.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
07-22-2019, 11:02 PM -
#3
(07-22-2019, 04:54 PM)Ani Wrote: Will have to check locally, log doesn't say much
In the meantime, try with the latest build as it has some fixes added since the one you used

Can not reproduce: https://cdn.discordapp.com/attachments/2...nknown.png

This could perhaps be caused by an issue affecting old NVIDIA cards: https://github.com/RPCS3/rpcs3/issues/6103

Try disabling Anti-Aliasing and retrying.

I tried the latest build rpcs3-v0.0.6-8410-d17be2c2_win64, and the game has the same issue.

I also disabled Anti-Aliasing, but this has no effect, the issue is still there.

Using SPU Interpreter, the game doesn´t crash but runs a few seconds and then sits there, showing the same screen, this is, it doesn´t advance any far, and doesn´t reach the "Press start" screen.

Using SPU ASMJIT Recompiler, the game crashes in the "Press start" screen, before I can press "start" button of the gamepad.

Using SPU LLVM Recompiler, the game takes about 10 seconds to show the first screen, and then, as in the case of SPU interpreter, runs a few seconds more and sits, without reaching the "Press start" screen.

Looking at the debug screen, these are the last lines that appear before the game crashes ( using SPU ASMJIT Recompiler ):

E {PPU[0x1000000] Thread (main_thread) [0x0174ff0c]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1]
E {PPU[0x1000015] Thread (fios mediathread) [0x01831ee4]} 'sys_fs_stat' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd0/game/NPUB30151/USRDIR/dev_hdd0/game/NPUB30151/USRDIR/rom/adx/voice.afs” [1]
S {RSX Decompiler Thread RSX: New program compiled successfully

I don´t know if this issue happens only with my PC specs or may happen to other users, maybe some new code was added to rpcs3 that requires more RAM, or better hardware in order to run ?
This post was last modified: 07-22-2019, 11:10 PM by customizer.
Ani
Administrator
*******


12
3,740 posts 96 threads Joined: Aug 2017
07-22-2019, 11:13 PM -
#4
Your specs are way below recommended yeah, but it should go in-game regardless.

No idea what's going on there without debugging with an actual debugger like Visual Studio's and seeing where the program dies.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
07-23-2019, 09:46 PM -
#5
(07-22-2019, 11:13 PM)Ani Wrote: Your specs are way below recommended yeah, but it should go in-game regardless.

No idea what's going on there without debugging with an actual debugger like Visual Studio's and seeing where the program dies.

I tried some rpcs3 builds in order to identify where the issue started, and found that the game last works fine on build 0.0.6-8280, and the first time the game crashes is on the following, 
build 0.0.6-8298 from (2019-06-25) - ( Pull request #6112 ), so I am pretty sure the problem starts in build 0.0.6-8298.

Maybe this can be of any help to know what causes the issue. At least, from what I tested, it affects the game Afterburner Climax (NPBUB30151) and Top Gun (NPUB30116) ( maybe other games too ). These are games that usually run quite fine with my PC specs, as they are not very CPU demanding.
This post was last modified: 07-23-2019, 09:53 PM by customizer.
Ani
Administrator
*******


12
3,740 posts 96 threads Joined: Aug 2017
07-24-2019, 03:26 AM -
#6
Introduced by https://github.com/RPCS3/rpcs3/pull/6112 , weird
Could be fixed by upcoming regression work by kd-11, but I'll let him know anyways
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
07-24-2019, 06:33 PM -
#7
(07-24-2019, 03:26 AM)Ani Wrote: Introduced by https://github.com/RPCS3/rpcs3/pull/6112 , weird
Could be fixed by upcoming regression work by kd-11, but I'll let him know anyways

Yes, as the regression started with pull #6112, it lingers on every build that came after that, so it will stay there until kd-11 can fix it.
Thanks for your help!
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
08-03-2019, 06:38 PM -
#8
(07-24-2019, 03:26 AM)Ani Wrote: Introduced by https://github.com/RPCS3/rpcs3/pull/6112 , weird
Could be fixed by upcoming regression work by kd-11, but I'll let him know anyways

Hello, do you have any update about this issue ? 

I posted a thread about the same issue in GitHub too, but I did not yet receive any commentary there.

Is kd-11 aware of the issue ? It´s surprising no other people have complained about this.

I continue trying the latest builds as soon as they are posted in the download section, but the same games above mentioned, keep on crashing.   Confused

I understand you have to deal with lots of issues, and I am not the only one having problems; I just wanted to help you fix this one by reporting where it all started.

Please let me know if the devs are aware of it and can fix it, thanks in advance !
Ani
Administrator
*******


12
3,740 posts 96 threads Joined: Aug 2017
08-03-2019, 08:00 PM -
#9
I linked the thread to him, there's still no news, he is currently working on something else
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
customizer
Member


0
17 posts 5 threads Joined: Jun 2018
08-20-2019, 06:27 PM -
#10
(08-03-2019, 08:00 PM)Ani Wrote: I linked the thread to him, there's still no news, he is currently working on something else

Hello, just a quick update to tell you that I left a comment today in GitHub in PR #6290 "Afterburner Climax Fatal error: Unhandled Win32 exception 0xC000001D - regression ?", 
about other games that are showing the same error reported here, just before going ingame.

As it doesn´t make sense starting a new thread about the same issue with these other games, please read what I wrote there, and I will be grateful if you let kd-11 know about it, just in case he can´t read it.

Many thanks in advance !
This post was last modified: 08-21-2019, 04:40 AM by customizer.


Forum Jump:


Users browsing this thread: 1 Guest(s)