Hello There, Guest! Register

Kingdom Hearts HD 2.5 Can't get in-game
#1
Bug 
Hi.

Whenever I try to get in-game in this title, either the emulator crashes or I get a black screen.
I can get to the game selection screen all right, but when I chose KH2, the emulator crashes and I get the following error code:

https://i.imgur.com/NlA1DVQ.png

Sometimes this doesn't happen and I can go through the Kingdom Hearts 2 title screen. But when I chose New Game, the opening cutscene plays (which appears with a horrible black bar at the bottom btw) and after that, I finally meet with a black screen.

This happens with both Vulkan and OpenGL renderers, but I prefer to stick with Vulkan bc that's RPCS3's default.
I have pretty much everything set with Default settings if that's useful, I just want to get his game running!!

I have attached a compressed file with both logs on it.

My Specs:

OS: Windows 10 64-Bit 
CPU: Intel Core i3-7100 @3.90GHz
GPU: NVIDIA Geforce GTX 1060 3GBRAM: 4GB @2133MHz
Drivers Version: 398.36 (Latest atm)

(Sorry for the abusive use of the word "I", my dominant language is not English).


Attached Files
.rar   Logs.rar (Size: 112.82 KB / Downloads: 2)
Reply
#2
(07-28-2018, 12:48 AM)Danielegend Wrote: Hi.

Whenever I try to get in-game in this title, either the emulator crashes or I get a black screen.
I can get to the game selection screen all right, but when I chose KH2, the emulator crashes and I get the following error code:

https://i.imgur.com/NlA1DVQ.png

Sometimes this doesn't happen and I can go through the Kingdom Hearts 2 title screen. But when I chose New Game, the opening cutscene plays (which appears with a horrible black bar at the bottom btw) and after that, I finally meet with a black screen.

This happens with both Vulkan and OpenGL renderers, but I prefer to stick with Vulkan bc that's RPCS3's default.
I have pretty much everything set with Default settings if that's useful, I just want to get his game running!!

I have attached a compressed file with both logs on it.

My Specs:

OS: Windows 10 64-Bit 
CPU: Intel Core i3-7100 @3.90GHz
GPU: NVIDIA Geforce GTX 1060 3GBRAM: 4GB @2133MHz
Drivers Version: 398.36 (Latest atm)

(Sorry for the abusive use of the word "I", my dominant language is not English).

Hmm, I have the same issue, though this doesn't happen when trying to get in game but rather when switching from the main hub menu (where you select the games) to the actual KH2.5 game, using the experimental LLVM recompiler seems to reduce the chances of crashing, getting in game isn't an issue for me though pre-rendered cutscenes  just seem to crash the game, OGL helped me past some of these, though now i'm hard stuck on the last day of roxas because there is a pre-rendered cutscene from one of the dreams which just hardlocks the game. I've tried all settings and can't get past it. I've you're desperate to play the game from a fresh start I recommend trying an older build or rpcs3 until the errors are creased out. Smile
Reply
#3
1. Launch the game directly instead of choosing to launch it via the game selection screen: ...\KH 2.5 dir\PS3_GAME\USRDIR\kingdom2.self

This should reduce getting in game crashes to 0.

2. Disable write color buffer (or if its disabled, enable it, i cant remember which). This will eliminate the black bar things, and may fix your black screen.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)