Hello There, Guest! Register

Demon's Souls Audio Stuttering
#1
Exclamation 
When running Demon's Souls I get severe audio stuttering in some areas. It's very choppy and distorted. I run at 30 FPS always, never any slowdowns with the exclusion of the audio, visually it's perfect. I'm currently running on the Interpreter did the same thing as LLVM Recompiler, Interpreter did the same thing as ASMJIT Recompiler and LLVM won't work with the game, Auto SPU Threads, Automatic Firmware (Topmost), Thread Scheduler, SPU Loop Detection was toggle on and off and it didn't change anything, SPU Cache, Safe Block Size, TSX Enabled, Vulkan seems to keep it from stuttering in most areas but it still happens, Tried framelimiter on Off and 30, Default Resolution is on the Recommend setting, Resolution Scale doesn't affect it and is set to 300%, Resolution Scale Threshold doesn't affect it and is set to 64x64, Write Color Buffers, and Use GPU Texture Scaling. Audio settings are Default.

Windows 10 Home,
Intel i7-7700K,
8GB NVIDIA GeForce GTX 1070,
8GB DDR4 RAM,
Video Driver Version 391.35

Log: https://mega.nz/#!h1xAEa7B!IdUYrSBnFfodI...miVQOYbL44

EDIT: Seems to be fixed, possibly due to my GPU overclocking and NVIDIA profile settings? Sounds unlikely but it is fixed.
Reply
#2
(07-10-2018, 08:13 PM)billy61300 Wrote: When running Demon's Souls I get severe audio stuttering in some areas. It's very choppy and distorted. I run at 30 FPS always, never any slowdowns with the exclusion of the audio, visually it's perfect. I'm currently running on the Interpreter did the same thing as LLVM Recompiler, Interpreter did the same thing as ASMJIT Recompiler and LLVM won't work with the game, Auto SPU Threads, Automatic Firmware (Topmost), Thread Scheduler, SPU Loop Detection was toggle on and off and it didn't change anything, SPU Cache, Safe Block Size, TSX Enabled, Vulkan seems to keep it from stuttering in most areas but it still happens, Tried framelimiter on Off and 30, Default Resolution is on the Recommend setting, Resolution Scale doesn't affect it and is set to 300%, Resolution Scale Threshold doesn't affect it and is set to 64x64, Write Color Buffers, and Use GPU Texture Scaling. Audio settings are Default.

Windows 10 Home,
Intel i7-7700K,
8GB NVIDIA GeForce GTX 1070,
8GB DDR4 RAM,
Video Driver Version 391.35

Log: https://mega.nz/#!h1xAEa7B!IdUYrSBnFfodI...miVQOYbL44

EDIT: Seems to be fixed, possibly due to my GPU overclocking and NVIDIA profile settings? Sounds unlikely but it is fixed.

I wish I knew what worked for you, since I'm having this issue and tried everything I could think of.
My Rig:
Ryzen 1800x / Crosshair VI Hero
32 GB TRidentZ 3333 @ cl14
GTX-1080 (left at stock when using RPCS3
Reply
#3
The audio stuttering disappears if you disable write colour buffers. I dunno how it works but it must up stuff up the emulations ability to play the sound effects in a well timed manner.

Not a solution as the colours go psychedelic.
Reply
#4
I'm going through the same problem. If anyone knows how to fix please let me know. I recorded a video demonstrating the problem and the settings that I use. https://www.youtube.com/watch?v=WJc1DmUEm3g
Reply
#5
Disabling write color buffer didn`t help me
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)