LamamaI'm having trouble with Vulkan and RPCS3.
Started by Lamama




4 posts in this topic
Lamama
Member


0
4 posts 2 threads Joined: May 2018
05-31-2018, 09:37 AM -
#1
First of all, sorry for my bad English.

I'm not famillar with RPCS3, and today is the first time I've used it. The instruction said: GPU->Renderer: Vulkan, but apparently in my renderer box there is no "Vulkan" option. As I searched for solution on Google, I found lots of people giving the following way to fix: "HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\Vulkan\Drivers", if you don't have "Drivers" key just create it and in it create a new REG_DWORD and name it "C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_5601d21ccd639df9\nv-vk64.json", and put the value as 0."

I finished creating the required file, but then I found out that my FileRepository folder didn't have the nv-vk64.json file. So even though others successful, mine got no change. 

That's the only way I've found so far and sadly, didn't work. Do you know any other way that I can use, or, how to get the nv-vk64.json file? Thank you very much!
This post was last modified: 06-01-2018, 03:25 PM by Lamama.
lastdance
Member


0
37 posts 2 threads Joined: Aug 2017
05-31-2018, 08:56 PM -
#2
I cant say that im totally sure if this is your issue, but for me, i actually just fixed this 2 days ago by upgrading my drivers to the latest version. Vulkan doesnt really seem to support drivers that are too old (or if you are using an old version of rpcs3, too new).
This post was last modified: 05-31-2018, 08:57 PM by lastdance.
Lamama
Member


0
4 posts 2 threads Joined: May 2018
06-01-2018, 11:20 AM -
#3
(05-31-2018, 08:56 PM)lastdance Wrote: I cant say that im totally sure if this is your issue, but for me, i actually just fixed this 2 days ago by upgrading my drivers to the latest version. Vulkan doesnt really seem to support drivers that are too old (or if you are using an old version of rpcs3, too new).

I tried updating my drivers but unfortunately, it didn't work as well. The nk-vk64.json file is still nowhere to be found TT_TT. Is there any other way?
Ani
Administrator
*******


11
3,725 posts 96 threads Joined: Aug 2017
06-01-2018, 02:04 PM -
#4
Try installing the VulkanSDK https://www.lunarg.com/vulkan-sdk/
It may fix your problem
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
Lamama
Member


0
4 posts 2 threads Joined: May 2018
06-01-2018, 03:00 PM -
#5
(06-01-2018, 02:04 PM)Ani Wrote: Try installing the VulkanSDK https://www.lunarg.com/vulkan-sdk/
It may fix your problem

that's the version I've been using TT_TT


Forum Jump:


Users browsing this thread: 1 Guest(s)