Hello There, Guest! Register

Prince of Persia Classic [NPUB30031] bg image issues
#1
So I have finally been able to emulate Prince of Persia Classic [NPUB30031] in RPCS3 and things seem to be working fine (the game is supposed to be playable after all). However, some of the in-game fixed images seem to have trouble loading and I was wondering if anyone else has experienced this. I have attached some screenshots that demonstrate the problem.


Attached Files Thumbnail(s)
                               
Reply
#2
Yeah I have the same issue with the title screen for many months now, and for me atleast the whole game world is rendered as black only displaying the timer and the white rectangle overlaying hud elements.

I have asked a few other people and tried the exact same builds as them with the same settings and it only happens to me no idea what causes it but since it worked for other people I left it alone.
Tried debug options and every combination of GPU settings and interpreters/recompilers but nothing helped.


Attached Files Thumbnail(s)
   
Reply
#3
(05-19-2018, 08:34 PM)Asinine Wrote: Yeah I have the same issue with the title screen for many months now, and for me atleast the whole game world is rendered as black only displaying the timer and the white rectangle overlaying hud elements.

I have asked a few other people and tried the exact same builds as them with the same settings and it only happens to me no idea what causes it but since it worked for other people I left it alone.
Tried debug options and every combination of GPU settings and interpreters/recompilers but nothing helped.

I think it's because you are using a different version of the game (NPEB00032). NPUB30031 seems to be fully playable (save for the aforementioned issues).
Reply
#4
(05-19-2018, 08:34 PM)Asinine Wrote: Yeah I have the same issue with the title screen for many months now, and for me atleast the whole game world is rendered as black only displaying the timer and the white rectangle overlaying hud elements.

I have asked a few other people and tried the exact same builds as them with the same settings and it only happens to me no idea what causes it but since it worked for other people I left it alone.
Tried debug options and every combination of GPU settings and interpreters/recompilers but nothing helped.

I have the same issues as you with NPUB30031 and rpcs3 6924. Title screen is all white. Once in the game the screen is all black. Can "play" the game as a blind man. Can hear myself walking and jumping and i can die. I can see the text but not the background and characters the whole screen outside of the text remains black (tried Vulkan and OpenGL).

I have a Ryzen 7 1800x and a 1070.
Reply
#5
(06-09-2018, 12:30 AM)MonstroMart Wrote:
(05-19-2018, 08:34 PM)Asinine Wrote: Yeah I have the same issue with the title screen for many months now, and for me atleast the whole game world is rendered as black only displaying the timer and the white rectangle overlaying hud elements.

I have asked a few other people and tried the exact same builds as them with the same settings and it only happens to me no idea what causes it but since it worked for other people I left it alone.
Tried debug options and every combination of GPU settings and interpreters/recompilers but nothing helped.

I have the same issues as you with NPUB30031 and rpcs3 6924. Title screen is all white. Once in the game the screen is all black. Can "play" the game as a blind man. Can hear myself walking and jumping and i can die. I can see the text but not the background and characters the whole screen outside of the text remains black (tried Vulkan and OpenGL).

I have a Ryzen 7 1800x and a 1070.

Try 6697. NPUB30031 works perfectly for me in rpcs3 6697 (well, except for the aforementioned problem).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)