Some_GingerDemon's souls failure on start using vulkan
Started by Some_Ginger




2 posts in this topic
Some_Ginger
Member


0
1 posts 1 threads Joined: Feb 2018
02-26-2018, 03:13 AM -
#1
I've been trying to play this game on vulkan, as running the game on OpenGl makes the game stutter. However whenever trying to boot this game up on vulkan the screen will go white and the game will stay there and not boot up. The log of the emulator says:
 F {rsx::thread} class std::runtime_error thrown: Assertion Failed! Vulkan API call failed with unrecoverable error: Invalid shader code (VK_ERROR_INVALID_SHADER_NV)

(in file c:\projects\rpcs3\rpcs3\emu\rsx\vk\VKProgramBuffer.h:158)

PC specs:
CPU: Intel i7-4720HQ 
GPU: Nvidia Geforce 965m
OS: Windows 8.1 64-bit
16 GB Ram
Nvidia Driver: 390.77

Any help is appreciated
This post was last modified: 02-27-2018, 07:07 PM by Some_Ginger.


Attached Files
.7z   RPCS3.7z (Size: 63.81 KB / Downloads: 0)
.7z   TTY.7z (Size: 90 bytes / Downloads: 0)
ProbablyJimmy
Member


0
1 posts 0 threads Joined: Mar 2018
03-17-2018, 12:24 PM -
#2
The Problem is with your NVIDIA Driver. You need to install version 388.71 or older, or else it won't work. The new Driver breaks the Vulkan feature.
Ani
Administrator
*******


11
3,722 posts 96 threads Joined: Aug 2017
03-17-2018, 06:49 PM -
#3
(03-17-2018, 12:24 PM)ProbablyJimmy Wrote: The Problem is with your NVIDIA Driver. You need to install version 388.71 or older, or else it won't work. The new Driver breaks the Vulkan feature.

No it doesn't, only if you have a really old RPCS3 version.


With latest build, right click the game on game list and clear shaders cache, and then retry to see if that issue persists.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7


Forum Jump:


Users browsing this thread: 1 Guest(s)