RolocaVulkan causes textures to flicker on laptop
Started by Roloca

2 posts in this topic

1 posts 1 threads Joined: Nov 2017
12-02-2017, 01:09 AM -
Hey guys!

You are doing an amazing work constantly updating RPCS3, however I have ran into a bug with the newer builds. I'm playing a famous JRPG series's 5th installment and it runs fine, however I constantly see textures flicker, change into negatives, turn full white/black and other problems. The cutscenes are fine, however even in the menu when they are standing in the subway the textures constantly flicker and it hurts my eyes.

Things I tried to do:
-Tested it on the newest build of RPCS3, bug still persists.
-Tested it with almost all CPU/GPU options that doesn't change the rendering method, mainly the ones that offer to possibly fix broken/flickering graphics, but the bug still persists
-Tested changing the render method to OpenGL, game loads fine, textures doesn't flicker, but it's a lot slower.
-Tested it with older builds,  2017-08-06-ecc55003 runs the game amazingly in Vulkan, but I don't think that newer versions wouldn't be able to do fine.
-Tested it on my Desktop PC. Everything works well on Vulkan, it's only doing this on laptop.

Thanks for any help in advance, till then I'll just use the older RPCS3 build

EDIT: The textures flicker during Hatsune Miku Project DIva F2ND too.
This post was last modified: 12-03-2017, 11:03 PM by Roloca.

60 posts 6 threads Joined: Nov 2017
01-10-2018, 02:27 PM -
Can confirm, every games I play on laptop has excessive texture flickering too while using desktop there's next to no flickering at all. On laptop this flickering issue didn't exist on older (mid 2017 I think) build either.

Games I've tested on both PC/Laptop:
-Gundam Extreme Versus Full Boost
-Afterburner Climax
-Ridge Racer 7
-RayStorm HD

60 posts 6 threads Joined: Nov 2017
02-09-2018, 01:16 PM -
Any solution for this? Will updating video card driver fix this issue? Since I haven't updated my Nvidia driver since 378.78.

update: updating display driver solved this issue.
This post was last modified: 02-10-2018, 12:51 AM by gespenst.

Forum Jump:

Users browsing this thread: 1 Guest(s)