Hello There, Guest! Register

Demon's Souls [NPEB01202]
#1
Digital versions of Demon's Souls are currently NOT COMPATIBLE.

Settings don't matter, game tries mounting itself as a disc game.
Such behavior has not been found in any other games so far.

1ffc1e8
Reply
#2
This still stands true.

06fc423
Reply
#3
Digital versions of Demon's Souls are still NOT COMPATIBLE, but game is now Loadable instead of Nothing as of rpcs3-v0.0.5-6509-ac82ecf3


.7z   NPEB01202.7z (Size: 62.59 KB / Downloads: 29)
Reply
#4
Question 
I looked at the md5sum of the elf of the psn game and the elf of the disc game and they are identical (0f1763bdaf6aa54c2607488fc8717857).
There is also this iso2pkg log file in the pkg so maybe they used the original disc files 1:1.
I really have no clue how this works but would it be possible to create a virtual disc path where the files are accessible that can already be decrypted with the rap?
In theory everything this game needs should be there, otherwise other PSN games wouldn't be able to load their encrypted files Huh .
Reply
#5
Sorry for the double post, but I think one of the reasons for the loading error is that files that don't typically have an NPD header are encrypted as sdats internally nonetheless.
If I run "mk_npdata -d encryptedfile decryptedfile 0" I get the files like they were originally on the bluray disc.
With this one could possibly recreate a working disc image.
Reply
#6
I'm sorry for the third post in a row, but I had too much time on my hands and got demon's souls (technically) running flawlessly even with the new 60 fps patch.
As I said before, they encrypted files that aren't normally with PSN releases, so I batch undid it only for the normally unencrypted files with make_npdata and I renamed the param.sfo to be HG and changed the id to NPEB01202.
However, it still didn't boot, so I dug even deeper and changed the param.sfo back and decided to recreate everything like it is on disc.
For this I created the generic ps3_disc.sfb file, removed the licdir as it didn't exist on the disc release and created the general directory structure of a disc and now it boots and runs flawlessly.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)