Hello There, Guest! Register

JoJo's Bizarre Adventure: All-Star Battle [NPEB01922]
#1
Wink 
RPCS3 used: rpcs3-v0.0.3-2017-09-13-b141b43c_win64

The game is fully playable in a constant 30fps (if you have a good rig), but the versus mode doesn't work, the game freezes when you select the battle scenario.
 
The settings are :
PPU & SPU Decoder: Recompiler.
Firmware Settings: Automatically load required libraries.
Using OpenGL or Vulkan works perfectly.

 Selecting char:
   

RPCS3 Log file:

.gz   RPCS3.log.gz (Size: 1.04 MB / Downloads: 186)
Reply
#2
this game runs on a gtx 1050 ti, i5 7400 and 8 gb ram?
Reply
#3
BUG REPORT: if you have the DLC installed, this game no longer works correctly in the latest builds, i.e. 0.0.5-6939.

After the initial logo screens, it will hang as the "checking DLC" box is on screen and never continue on. So, no longer playable.

On older builds, i.e. 0.0.5-6697, the game with DLC installed works very well.

Please see the 2 logs attached. You can see the 6939 one goes crazy with hash errors (see code below) when it showing that "checking DLC" message and it just hangs.
Code:
·E 0:44:18.590187 {PPU[0x1000008] Thread (CRI FS File Access 1) [0x01511174]} LDR: Error Decrypting data
·E 0:44:18.590323 {PPU[0x1000008] Thread (CRI FS File Access 1) [0x01511174]} LDR: EDAT: Block at offset 0x120 has invalid hash


Regardless of the DLC bug, there is one noticeable graphical bug: the character life bars display at the top of the screen are missing and no setting will make them appear (I tried EVERYTHING). The game is still very playable, just can't see all the info on screen as intended by the game. If you watch video of the game on actual PS3 on youtube you can see what I mean.

UPDATE: here is a picture from the game on actual PS3 showing the life bars at top of screen. RCPS3 *does not* show the life bars, but it *does* show the energy/special bars at the bottom of screen though.
[Image: jojo_asb_Esidisi%202-noscale.jpg]


Attached Files
.gz   NPEB01922-RPCS3_0.0.5-6939.log.gz (Size: 1.67 MB / Downloads: 26)
.gz   NPEB01922-RPCS3_0.0.5-6697.log.gz (Size: 373.71 KB / Downloads: 26)
Reply
#4
In regard to what Tapper said about the life bars at the top not showing: I've had this problem for ages, then before I recently updated my emulator It suddenly showed up! I was so overjoyed I updated my emulator to the recent 0.0.5-7006 and lost the setting that made it appear. If I ever find out how to get it back, I will post again. If anybody else figures it out before me, please let me (us) know!
Reply
#5
There is no specific settings for the lifebar, it's a random bug no one knows what causes it. It affects both AMD and NVIDIA users, and has been around since early 2017 when the game went ingame for the first time.
Reply
#6
Hello, can anyone say how to install DLC's for this game on emulator or, if it possible on real console?
Reply
#7
Pliss, if anyone Knows a way to fix the DLC problem or the health bars report here (the dlc's are more important for me)
Reply
#8
Smile 
Okay so I got the game working at a constant 30fps (even with stands out), with the DLC working with all characters unlocked and with HP bars showing. I can also play with my friend over Parsec in versus mode with no problems. Keep in mind that I have quite a powerful PC aswell. Here my setup:


RPCS3 v0.0.4-4108 Farseer build (google rpcs3 farseer build, probably many other emulator versions work just fine, google around and maybe try old versions)
Game version is US (BLUS31405)
Character data DLC, campaign mode DLC and DLC fix applied in that order (you'll have to find those yourself and they need to be compatible with your game region US/EU)
RPCS3 settings will be attached as images to this post. Settings not shown are set to default.

I'm going to assume that you have the game and emulator ready from this point on.

after you've installed the DLC (using install .pkg from RPSC3) you should do the following, even though I don't remember if it did anything, try it anyway. Also backup your game files!

After installation of DLC characters unlock pkg, Campaign Data pkg and Fix DLC pkg, then, there are two folders created under the directory \dev_hdd0\game,NPUB31391 and NPUB31391_DLC. you have to move all keyxxxx.edat files in folder NPUB31391 to the directory dev_hdd0\game\NPUB31391_DLC\USRDIR.The folder NPUB31391 can be deleted now.
- Credit to ssd zeldac's youtube comment

However the problem for alot of people is that the DLC stops the game from loading, making it stuck on "checking DLC data", one way to work around this is to restart your game several times, and sometimes it will just work. However on my emulator version it seems that the cause is some multithreading issue that makes the emulator freeze, and I found a way to make it work every time (might not work for you). Do this BEFORE you have started the game.

1. go into task manager
2. go into the "details" tab
3. find rpcs3.exe
4. right click the process, click "set affinity"
5. uncheck all processors except CPU 0 and click ok
6. start the game, the emulator should now no longer freeze.
7. when the game has reached the main menu, go back into task manager and check all processors again

the game should now have started properly even with DLC installed, you should be able to go into versus mode and see all the characters. If you don't see everyone, then you screwed something up when you either installed the DLC or moved the files or something, try again from scratch. Remember to use a savegame that has all characters available unless you want to unlock them yourself.

If you want to play with a friend use Parsec.

If this worked or didn't work for you then please reply. Smile


Attached Files Thumbnail(s)
                       
Reply
#9
spu_perf isn't master, this is an invalid test. Also apart from very select cases you really should't be using that ancient build anymore. If performance is the only reason your using it. Wait for elad's changes to merge it improves performance of non-tsx cpu's quite a lot. And, there's been lots and lots of performance improvements before that anyway e.g spu llvm.
Reply
#10
(12-24-2018, 02:14 AM)techiew Wrote: If this worked or didn't work for you then please reply. Smile

It work for me with the last build ^^

It seems to be the only way to make it work BTW, I tried everything else on the internet.

Thanks you for you dedication
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)