KravickaSonic Generations [BLUS30612]
Started by Kravicka




7 posts in this topic
Kravicka
Member


0
162 posts 26 threads Joined: Aug 2017
09-02-2017, 11:20 PM -
#1
RPCS3 v0.0.3-3-9440e65 - master build

   


.gz   RPCS3.log.gz (Size: 128.03 KB / Downloads: 54)
This post was last modified: 09-05-2017, 02:15 PM by digitaldude.
[Image: CwrhKKk.png]
[Image: 4m5wb2-2.png]
MarioSonic2987
RPCS3 Tester


4
295 posts 104 threads Joined: Aug 2017
09-05-2017, 09:26 AM -
#2
Thread name should be Sonic Generations.
Desktop: Intel Core i9-9900KF, Nvidia GeForce RTX 2080 (OpenGL, DirectX12 & Vulkan), Windows 11
Laptop: Intel Core i7-7700HQ, Nvidia GeForce GTX 1060 (OpenGL, DirectX12 & Vulkan), Windows 11
zelurker
Member


0
4 posts 2 threads Joined: Sep 2018
02-29-2020, 09:30 AM -
#3
It's the game where the "freeze bug" related to rsx hits the fastest on current builds for me (0.0.8-9761) :
I have a save in the "white world", just after finishing the intro level at excellent speed (just use llvm for ppu & spu). But here, just make a few steps around and the game will be frozen in a matter of seconds !
cleverest
Member


0
98 posts 1 threads Joined: Jun 2018
03-24-2022, 04:15 AM -
#4
RPCS3 Version: 0.0.21-13370-a4d715e2 Alpha

Defaults (Vulkan)

Keeps freezing on the start menu. Restarting, got a bit farther, but still froze there :-(

Log shows:
F {SPU[0x2000100] Thread (RsdxPrimaryCellSpursKernel2) [0x0a768]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x0 (op=0x0, Out_MBox=empty)
(in file D:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:4774[:22], in function stop_and_signal)
Tezuka
Member


0
19 posts 1 threads Joined: Jan 2020
07-02-2022, 10:21 PM -
#5
That's the same error I get Cleverest, with the Mac Version and latest Default Vulkan, I would love this game fixed to be able to play.
yurinator557
RPCS3 Tester


3
282 posts 39 threads Joined: Jul 2019
07-02-2022, 10:52 PM -
#6
This game requires the SPU decoder set to ASMJIT
Tezuka
Member


0
19 posts 1 threads Joined: Jan 2020
08-05-2022, 08:22 AM -
#7
(07-02-2022, 10:52 PM)yurinator557 Wrote: This game requires the SPU decoder set to ASMJIT

So I tried that, but then it crashes in loading a game? Any Ideas to get past it?
quick.sliver1
Member


0
97 posts 0 threads Joined: Mar 2020
09-13-2022, 09:08 PM -
#8
Ingame
Beaten the game from start to finish with Non-default setting. (The game is a very sensitive case with CPU bottlenecking, I presume).  FPS is Variable. (Green Hill Zone performance is stable FPS without any freezing/crashing, whilst next Zone/Challenge Act performances are variable with random freezing/crashing).  Graphic/Cutscenes are well-rendered (However, Anti-Aliasing is not properly working).  Sound/Effects are clearly working.

# Gameplay FPS = (29~32) – Green Hill Zone/ 2D Gameplay Camera / 3D Nondash Gameplay Camera
# Gameplay FPS = (22~32) – Dashing Gameplay
# Gameplay FPS = (02~06) – Egg Dragon Boss [desync event error & cleared by its own]
# Cutscenes stable (59~60)
# RPCS3 v0.0.24-14153-2807be70 Alpha
# Non-default setting [Res. Scale= 300% Fullscreen 4K]
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia | NVMe storage (3500MB/2500MB Read/Write)


@ Random Freezing
SIG: Thread terminated due to fatal error: Unknown STOP code: 0x0 (op=0x0, Out_MBox=empty)    

Set Driver Wake-Up Delay = 350us (Advanced)               
# Enable Hook Static Function (Debug)                                   => Sustainable long-gameplay without quick error/freeze OR Might help when selecting “RPCS3 Alternative Scheduler”.  
               
@ Random Crash
RSX: FS exports depth component but depth test is disabled (INVALID_OPERATION)
S SPU: New block compiled successfully x156

# Disable Enable SPU loop detection (CPU)
# Select RPCS3 Alternative Scheduler (CPU)
# Enable Disable On-Disk Shader Cache (Advanced)

 
RPCS3 Issue: Broken Graphic (at the middle fight with Egg Dragon Boss)
E RSX: FIFO error: possible desync event (last cmd = 0xe0e0e0e0)
E RSX: [attrib buffer] Pool limit was reached. Will attempt to swap out the current heap. x3

# Just keep playing, the graphic issue will clear by itself


Attached Files Thumbnail(s)
                           

.7z   RPCS3_TTY_FIFO+desyncEven.7z (Size: 1.02 MB / Downloads: 13)


Forum Jump:


Users browsing this thread: 1 Guest(s)