Hello There, Guest! Register

Ni No Kuni: Wrath of the White Witch [NPUB30932]
#1
RPCS3 v0.0.3-3-da3f3fd Alpha
Ingame
[Image: 6922d32f8f.jpg]


Attached Files
.7z   Ni_No_Kuni.log.7z (Size: 382.69 KB / Downloads: 260)
Reply
#2
Rename the title to "Ni no Kuni: Wrath of the White Witch" to match the other topic.
Reply
#3
I have issues with very bright cutscenes and menu with the build rpcs3-0.0.3-6765-ed21bb3.
Here is how it looks like for me: https://imgur.com/a/AVrWR
And for some reason the game just froze when I was running in the start location.
I've attached the log file.
My spec:
i5-7600K, 16GB RAM, Gigabyte 1060 Windforce OC 6GB

P.S.
Menu and cutscenes are OK in the build rpcs3-0.0.3-5952-da3f3fd1, however game froze right in the start location before showing me a movement tutorial.


Attached Files
.gz   RPCS3.log.gz (Size: 470.51 KB / Downloads: 9)
Reply
#4
^skip cutscenes before they end otherwise the game will freeze.
Reply
#5
Nah, the game doesn't freeze, I believe the freezes were caused by the shader cache since I used to run two different versions of the emulator in the same folder.
What about the overly bright cutscenes anyway?
It is working A-OK in the older version.
Reply
#6
RPCS3 v0.0.4-6129-1344f15e Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+
Dualshock 4 gamepad

My config:

   

   
[attachment=2445]


DX 12 render

crashed with error after save loading begins:

F {rsx::thread} struct gsl::fail_fast thrown: GSL: Precondition failure at c:\projects\rpcs3\3rdparty\gsl\include\span.h: 382

Here log:
.7z   dx12-log.7z (Size: 369.73 KB / Downloads: 5)

OpenGL render and Vulkan have artifacts and overlightning, artefacts are whenAnisotropic filter enabled:

   

OpenGL render


About 10-15 fps, when i runs there shadows begins moving arround from lightposts i think and other atrifacts:

   

I was able to run to garage and skip 2 movie and after another one, when animation ends game just stops respond with black screen,
also there flickering noise and animation slow but voice go ahead of it when in on engine cutscenes and FPS in they are pretty low 5-8 fps.

heres log:


.7z   opengl-log.7z (Size: 1.37 MB / Downloads: 0)

Vulkan render

20-25 fps

crushes did not allow me to approach garage with error:

F {rsx::thread} class std::runtime_error thrown: Unknown primitive type 128

(in file Emu\RSX\gcm_enums.cpp:45)

here screenshot of this epic moment Smile


   

Here log:


.7z   vulcan-log.7z (Size: 349.2 KB / Downloads: 3)

Hope it helps to fix a thing Smile

RPCS3 v0.0.4-6134-917ee472 Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+

Setting as above, i just use Autoload All Modules.

DX 12 render still fails with

F {rsx::thread} struct gsl::fail_fast thrown: GSL: Precondition failure at c:\projects\rpcs3\3rdparty\gsl\include\span.h: 382

OpenGL

Still overlightning in some moments in cutscenes, but sometimes all ok, able to go to next save point byt skipping cutscenes when they starts fade out, still very low FPS in most cutscenes.

Vulkan

Same here. but with good FPS 20-30. And also i notice that i miss 1 cutscene, when he drive a car, it skipped but i did not ask for it.


Here all logs in - https://yadi.sk/d/kdm_-Owb3Q6pkT

RPCS3 v0.0.4-6134-917ee472 Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+

Emulator crushed when i pause game and pressed start to unpause it


   

I upload log here - https://yadi.sk/d/kdm_-Owb3Q6pkT

vulcan-log-crush-after-game-pause.7z

RPCS3 v0.0.4-6138-662fe8cc Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+

vulkan render

crashed after first fight in ingame engine movie

E {rsx::thread} HLE: Getting the real address failed. (addr=0x3f326290)
E {rsx::thread} RSX: Invalid FIFO queue get/put registers found, get=0x3F326290, put=0x19671C
E {rsx::thread} HLE: Getting the real address failed. (addr=0x3f326290)
E {rsx::thread} RSX: Invalid FIFO queue get/put registers found, get=0x3F326290, put=0x19671C
E {rsx::thread} HLE: Getting the real address failed. (addr=0x3f326290)
E {rsx::thread} RSX: Invalid FIFO queue get/put registers found, get=0x3F326290, put=0x19671C
E {rsx::thread} HLE: Getting the real address failed. (addr=0x3f326290)
E {rsx::thread} RSX: Invalid FIFO queue get/put registers found, get=0x3F326290, put=0x19671C
E {rsx::thread} RSX: Application has failed to recover, discarding FIFO queue


LOG - https://yadi.sk/d/kdm_-Owb3Q6pkT - 281117-v0.0.4-6138-662fe8cc-vulcan-log

RPCS3 v0.0.4-6138-662fe8cc Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+

vulkan render

crashed after first fight in ingame engine movie in middle of it

F {rsx::thread} class std::runtime_error thrown: Unknown magnify filter 0x0
(in file Emu\RSX\gcm_enums.cpp:631)

LOG - https://yadi.sk/d/kdm_-Owb3Q6pkT - 281117-v0.0.4-6138-662fe8cc-vulcan-log-2.7z

RPCS3 v0.0.4-6138-662fe8cc Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+

vulkan render

longest run ever, i was able finish tutorial boss fight and exit forest, but it crushes on world map with similar error as above

I play with settings so here new screenshots for it:

   
   


LOG - https://yadi.sk/d/kdm_-Owb3Q6pkT - 281117-v0.0.4-6138-662fe8cc-vulcan-log-3.7z


Attached Files
.7z   dx12-log.7z (Size: 301.53 KB / Downloads: 0)
Reply
#7
RPCS3 v0.0.4-6144-5810b292 Alpha | HEAD
Intel® Core™ i5-7400 CPU @ 3.00GHz | 4 Threads | 7.97 GiB RAM | AVX+



Emiulator itself crushed in city when running around

LOG - https://yadi.sk/d/kdm_-Owb3Q6pkT - 291117-v0.0.4-7066-5810b29-vulcan-log-1.7z
Reply
#8
The game now freeze the screen but sound still going. And in 4k there are glitches on logos, buttons, etc.
And after closing all windows the process doesn't closed, I need to terminate it with task manager.


Attached Files
.gz   RPCS3.log.gz (Size: 428.11 KB / Downloads: 1)
Reply
#9
@skyr don't use dx12, it's abandoned. Also try not to spam the comments too much. The brightness "issue" has been fixed the game uses some rather strange code so when kd-11 made the emulator more accurate it broke. Either way it looks normal again now.

The game icons, logos, portraits etc have issues when using resolution scaling but this isn't really a problem with the emulator. The game uses an image format that was not intended to be scaled, remember that resolution scaling is actually a hack. The persona 5 mod that fixes portraits just re-compressed the images into a different format.

OpenGL is more stable than Vulkan with Ni No Kuni so i recommend you guys use that.
Reply
#10
Yo!

I am happy with Ni No Kuni and only had a few crashes but was still able to continue from save but I reached a point where the game cannot go any further. I played the game up until you get to the island with the fairies and after collecting the 8 pieces of art and talking to one of the brothers, the game gets stuck in an endless loading screen... this is as far as I got with the game. Please let us know when this has been resolved. Love the progress so far and game runs smoothly (Core i7 4790, GTX 1060)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)