Hello There, Guest! Register

Ni No Kuni: Wrath of the White Witch [NPUB30932]
#51
Ignore this. Wrong Version Didnt notice
Reply
#52
Using the latest build RPCS3 v0.0.5-7569-1ca02c7d
cpu: i7 5820k @ 4Ghz
gpu: 980 ti
vulkan renderer

I've been able to play mostly without problem
about 24 hours of gameplay and only 4 crashes, and 2 instances where the game wouldn't load (black screen after starting emulation)
The crashes seem to be at random times without a obvious trigger

Getting solid 30 fps with dips to as low as 15 in ding dong dell.
At 400% scaling the artifacts on ui elements go away completely.

Here are logs from times where the game crashed
http://www.mediafire.com/file/wpqijmt6l3..._1.gz/file
http://www.mediafire.com/file/av83235vc4..._2.gz/file
http://www.mediafire.com/file/5t54woqa7y..._3.gz/file

I will update when i finish the game and if the crash rate goes up at all

picture below is 200% vs 400% scaling

note to mod: sorry i posted in wrong thread the version is NPUB30932. please delete the other post !


Attached Files Thumbnail(s)
       
Reply
#53
i am back
RPCS3 v0.0.5-7569-1ca02c7d Alpha | HEAD

Intel® Core™ i7-5820K CPU @ 3.30GHz | 12 Threads | 15.91 GiB RAM | AVX+

I used OpenGL for the second half of the game
Setting resolution scale to 100% i had framerate drops to 20-25 very often
The final battle crawled to 10-15 fps
I did however not experience ANY crashes in the 23 hours i was playing on openGL
The glowing people in certain environments still persists with opengl
some small texture glitches on some clothing and fabric type objects but i forgot to take any screenshots

It seems it's a choice between 400% upscale and saving every 5 minutes or 100% and getting frequent frame drops

Requesting game to be set to playable !

log: http://www.mediafire.com/file/yvcwm7cak7...sh.gz/file


Attached Files Thumbnail(s)
   
Reply
#54
Your report is missing two screenshots, and the issue you're seeing in the menu is because you're forcing Anisotropic Filtering. Use "Automatic" and you wont have that issue and all the 2d ui elements will look normal. Other than that you should be using SPU LLVM, because it'll be faster. And Elad's PR which will merge in the coming weeks will improve performance, but performance is quite good already especially with Vulkan. I'm not so sure about resolution scaling causing crashes that sounds quite odd. Also, you shouldn't use GPU Texture Scaling, it defaults to off for a reason.
Reply
#55
(12-28-2018, 01:23 PM)Asinine Wrote: Your report is missing two screenshots, and the issue you're seeing in the menu is because you're forcing Anisotropic Filtering. Use "Automatic" and you wont have that issue and all the 2d ui elements will look normal. Other than that you should be using SPU LLVM, because it'll be faster. And Elad's PR which will merge in the coming weeks will improve performance, but performance is quite good already especially with Vulkan. I'm not so sure about resolution scaling causing crashes that sounds quite odd. Also, you shouldn't use GPU Texture Scaling, it defaults to off for a reason.

Using LLVM no models appear - see first screenshot below
http://www.mediafire.com/file/1ip50h9o10...gl.gz/file

The crashes only happen on Vulkan i don't know if it had anything to do with the render scale. Every time it crashed it was with the same error:
·W 4:30:20.081111 {rsx::thread} RSX: Invalid transform register index (load=548988288, index=0)
·W 4:30:20.081115 {rsx::thread} RSX: Invalid transform register index (load=548988288, index=1)
·W 4:30:20.081116 {rsx::thread} RSX: Invalid transform register index (load=548988288, index=2)
·W 4:30:20.081117 {rsx::thread} RSX: Invalid transform register index (load=548988288, index=3)
·F 4:30:20.081419 {rsx::thread} RSX: class std::runtime_error thrown: Unknown wrap mode 0x0
(in file c:\projects\rpcs3\rpcs3\emu\rsx\gcm_enums.cpp:588)
·! 4:30:20.081446 {rsx::thread} Thread time: 14644.421875s (48207.477897Gc); Faults: 5430 [rsx:0, spu:0];
·! 4:30:20.082144 {RSX Decompiler Thread} Thread time: 4.218750s (157.094904Gc); Faults: 0 [rsx:0, spu:0];
·! 4:30:20.082620 {VBlank Thread} Thread time: 0.000000s (157.391062Gc); Faults: 0 [rsx:0, spu:0];
·! 4:30:31.632233 Stopping emulator...

The crashes could happen after 10 minutes of gameplay or 5 hours and didn't seem to be triggered by anything gameplay wise
the path c:\projects\ doesn't exist

I tried out your recommended settings except using ASMJIT and using openGL and the performance was the same as beforehand which is perfectly playable
I assume a 8700k may not have the fps drops at all


Attached Files Thumbnail(s)
               

.gz   RPCS3.log.gz (Size: 780.92 KB / Downloads: 1)
Reply
#56
(12-28-2018, 03:47 PM)Puffy Vulva Wrote: Using LLVM no models appear - see first screenshot below

Yeah, because you're using an ancient version of RPCS3 before Neko merged his changes which fix that. The Xfloat approximation fixes many games needing Accurate Xfloat with SPU LLVM to fix graphics, thus resulting in a big speed boost for many titles.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)