Hello There, Guest! Register

The Last of Us [BCUS98174]
#31
RPCS3 Version: 0.0.9-10105-cd649905 Alpha

Sometimes it would give me the main menu and then freezes, if it doen't freeze at or after Naughty Dog's logo. When it reaches the menu, it doesn't dislpay the scene, only the menu and the sounds.
Using Vulkan

Ryzen 5 2600, stock speeds
[email protected]
Radeon R7 370 4gb, adrenalin 20.2.2


Attached Files
.gz   RPCS3.log.gz (Size: 622.33 KB / Downloads: 2)
Reply
#32
(04-04-2020, 07:54 PM)nandru Wrote: RPCS3 Version: 0.0.9-10105-cd649905 Alpha

Sometimes it would give me the main menu and then freezes, if it doen't freeze at or after Naughty Dog's logo. When it reaches the menu, it doesn't dislpay the scene, only the menu and the sounds.
Using Vulkan

Ryzen 5 2600, stock speeds
[email protected]
Radeon R7 370 4gb, adrenalin 20.2.2
same here
Reply
#33
Ingame
Gameplay FPS is unstable.  Game is acceptably playable with non-default setting + patches.
  • More Playable with Res Scale=100% 720p
  • Correct lighting/shadow reflection (By Read Depth/Color Buffers)
  • Correct menu rendering (No Blacksrceen/Lighting bubble) 
Res. upscaling randomly causes FPS drops in gameplay only.  Upscaling has higher FPS at Indoors area, Low FPS in Outdoor areas.

# Gameplay FPS = (15~30)
# Cutscenes stable (29~30)
# RPCS3 v0.0.9-10177-ae1ff1e9 Alpha
# Whatcookie + Zerox patch used
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia | NVMe storage (3500MB/2500MB Read/Write).


@ lighting/shadow reflection problems (No patch)

Enable Write Color Buffers (GPU) 
Enable Force CPU Blit emulation (Debug) 
Enable Read Depth Buffers (Advanced) 
Enable Read Color Buffers (Advanced) 

@ Lighting/shadow reflection problems || Better FPS But Not Stable (Using Whatcookie + Zerox patch)

Disable Write Color Buffers (GPU) 
Enable Force CPU Blit emulation (Debug)   ==> Remove lighting bubbles @ Menu/Outdoor area.
Enable Read Depth Buffers (Advanced) 
Enable Read Color Buffers (Advanced) 

Enable Relaxed ZCULL Sync (Advanced)     ==> Useful few FPS boost with Res. Upscaling= 150~300% Fullscreen.


@ IF Frequent Freeze/Crash
  # Select Load automatic and manual selection (Advanced)
                # Enable libssl.sprx (Advanced)
                # Enable libavcdec.sprx (Advanced)
                # Enable libvdec.sprx (Advanced)


Attached Files Thumbnail(s)
               

.7z   RPCS3_4k.7z (Size: 972.58 KB / Downloads: 33)
.7z   RPCS3_720p.7z (Size: 866.57 KB / Downloads: 57)
Reply
#34
(04-12-2020, 06:20 PM)quick.sliver1 Wrote: # Whatcookie + Zerox patch used

I can't find any info on Whatcookie patches
Reply
#35
(04-14-2020, 10:00 PM)nandru Wrote:
(04-12-2020, 06:20 PM)quick.sliver1 Wrote: # Whatcookie + Zerox patch used

I can't find any info on Whatcookie patches
https://wiki.rpcs3.net/index.php?title=H...Last_of_Us
Reply
#36
hi guys, 

after a few years i've played again TLOU on rpcs3 and I want to share my experience

my specs are a 2600X + RX 580 + 16GB ram

so, i was experiencing the crashes at the intro screens. after watching a tutorial by Zerox himself, I managed to get the game going with no freezes!

for me, it was the "driver wakeup delay" in the "advanced" tab. Default i 0, Zerox suggested 30 microseconds. Now the game never crashes for me.

he says that the higher the value, the more stable, but also the higher the value, the less FPS you get. for me, it does not go over 13 FPS

other fellows with intel i7-8700K @ 5GHz can run it stable at 25/30FPS no problem.
Reply
#37
Do not make reports with unofficial builds, those posts won't be approved. Read the Guidelines.
Reply
#38
Ingame
Beaten the game from start to finished.  Gameplay FPS is unstable.  Game is acceptably playable with non-default setting (CheatEngine patch).  Long gameplay (+3hr) got no crash at all (except for 2-crashes at Hotel elevator & Underground Tunnel).
  • More Playable with Res Scale=100% 720p
  • All chapters are almost playable even with low FPS (Most area performs close to 30FPS)
  • Menu/Gameplay are correctly well-rendered even with Res. Upscaling (Landscape/Rain/Water/Snow/Fog/Shadow/Flame gun…etc)
# Gameplay FPS = (18~30)
# Cutscenes stable (29~30)
# Cutscenes stable (59~60) – By CheatEngine!!
# RPCS3 v0.0.10-10427-865180e6 Alpha
# Non-default Setting [Res. Scale= 300% Fullscreen 4K]
# Illusion + Zerox CheatEngine patch OR Patch.yml
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia | NVMe storage (3500MB/2500MB Read/Write).



@ Dynamic shadow reflection || Blurry Lag camera control
# Enable Read Color Buffers (Advanced)                                ==> Better shadow reflection & visible environment
Set Driver Wake-Up Delay = 350us (Advanced)
 
@ Graphic Depth Color/Too dark || More FPS Boost (Using Illusion/Zerox CheatEngine patch)
Set Mesh Trimming= 0                                                            ==> (0= Remove Trimming character face @ Res. Upscaling)
Set Bloom Control = 3                                                             ==> (3= Cargo Chapter)
Set Frame Lock = 0                                                                 ==> (0= 60FPS Cutscenes)
Set Depth Buffer Viewport = 1
Set Depth Buffer = 2
 
Other remain setting = 0




----------------------------------------------------------------------------------------------------------------------------------
@ Hotel elevator/Underground Tunnel Crash Bypass workaround CELL_PAD_ERROR_NO_DEVICE
# Use rpcs3-v0.0.9-10297 (any firmware)                        ==> Later RPCS3 ver, Log (in elevator scene) might NOT detect more than fisrt 15-Line error.
# Use Aphelion Gaming patch (18~20-Line)                    ==> Disable after crash bypass.
:: Blackscreen immediately appears after falling from elevator scene, wait till (R3) logo flashlight is appeared.  Autosave will be made. Safe to reboot RPCS3.
:: Transfer savegame to latest rpcs3 version.
:: Can be used with Illusion/Zerox CheatEngine patch.

@ Listen Mode/Projectile (Optional)
at 720p (Comparative picture attached) FPS Drops by 7~12 
Set MLAA (Post on Spu) = 1                                      ==> (1= Visible Aim & “Listen Mode” aura)
:: Ensure to apply above CheatEngine setting & delete old patches related to Last of Us/Uncharted 3, particularly MLAA patch!!
 
at 1080p~4k (Comparative Picture attched) FPS Drops by 7~15 
Enable Write Color Buffers (GPU)                           ==> Remove blackscreen & colorful dot.
# Set Res. Scale Threshold = 128 x 128  (GPU)        ==> Better Aiming curve @ Res. Upscaling.
Enable Force CPU Blit emulation (Debug)              ==> “Listen Mode” aura @ Res. Upscaling.
Set MLAA (Post on Spu) = 1                                       ==> (1= Visible Aim & “Listen Mode” aura)
:: Ensure to apply above CheatEngine setting & delete old patches related to Last of Us/Uncharted 3, particularly MLAA patch!!
---------------------------------------------------------------------------------------------------------------------------------


 
@ Smooth gameplay VM: Access violation writing/reading location (unmapped Memory)
  # Select Load automatic and manual selection (Advanced)
                # Enable libssl.sprx (Advanced)
                # Enable libavcdec.sprx (Advanced)
                # Enable libvdec.sprx (Advanced)


Attached Files Thumbnail(s)
                       

.7z   RPCS3_+3hr.7z (Size: 6.73 MB / Downloads: 138)
.7z   TLoU(CE)_Patch(TrapErr).7z (Size: 1.62 KB / Downloads: 197)
Reply
#39
Sad 
I playing the game with master 10435,and this patch. No cheatengine,no vodoo magic. 
Only 3x times freezing the emulator,and the restart always helped. But Now i,am in the Hotel undergrund and the elevator accident.
Always stopped the emulator when Joel falls into the water,and the flsahlight turns on.  I hear the flashlight,but not see because freezing. No error messsage,no trap error.

I think the flaslight light is the problem. When i begin the game,i push the R3 my flaslight have light,but now in Hotel after 3hour gameplay i push the R3,and no light!!!??  Huh
I have dualshock4,and the shake charge is working when started the game.  
try clear all cache but not helped.
 Any idea??
My pc: Ryzen 2600 4Ghz,gtx 1070,DDR4 16Gb 3000 mhz
Reply
#40
(06-01-2020, 08:48 AM)Attelee Wrote: I playing the game with master 10435,and this patch. No cheatengine,no vodoo magic. 
Only 3x times freezing the emulator,and the restart always helped. But Now i,am in the Hotel undergrund and the elevator accident.
Always stopped the emulator when Joel falls into the water,and the flsahlight turns on.  I hear the flashlight,but not see because freezing. No error messsage,no trap error.

I think the flaslight light is the problem. When i begin the game,i push the R3 my flaslight have light,but now in Hotel after 3hour gameplay i push the R3,and no light!!!??  Huh
I have dualshock4,and the shake charge is working when started the game.  
try clear all cache but not helped.
 Any idea??
My pc: Ryzen 2600 4Ghz,gtx 1070,DDR4 16Gb 3000 mhz

if you read my step carefully, you will definitely bypass this issue with elevator scene crash.



1) Use rpcs3-v0.0.9-10297 (of course, transfer ur save into this version temporarily)
2) Use/enable trap patch. 
3) Blackscreen immediately appears after falling from elevator scene, wait till (R3) logo appear alone in blackscreen (which mean autosave is done). close RPCS3.
4)Transfer savegame to your latest rpcs3 version.
5) run your latest rpcs3 version

6) Savegame will load at "after elevator fall" while your are at the water.

Latest RPCS3 ver, Log (in elevator scene) might NOT detect more than fisrt 15-Line error.  To bypass the crash, emulator must detect 19-line trap error with elevator scene & 20-line trap error for underground tunnel.  && this is done by rpcs3-v0.0.9-10297
Reply


Forum Jump:


Users browsing this thread: 4 Guest(s)