Hello There, Guest! Register

Gran Turismo 5 [BCUS98114]
#1
RPCS3 v0.0.3-3-c7c0139 Alpha

Quote:·F 0:00:32.749502 {PPU[0x1000000] Thread (main_thread) [0x00bf0968]} MEM: Access violation writing location 0x80000000


Attached Files
.7z   RPCS3.7z (Size: 62.05 KB / Downloads: 58)
Reply
#2
Loadable now? Black screen, 0.00FPS RPCS3 v0.0.3-3-9bcc298 Alpha

Video: OpenGL/Vulkan
PPU: Interpreter (fast)
SPU: Recompiler (ASMJIT)
Code:
U {PPU[0x100001a] Thread (9ZWAM) [0x01789808]} sys_io TODO: cellMouseGetDataList
U {PPU[0x100001a] Thread (9ZWAM) [0x01789808]} sys_io TODO: cellMouseGetDataList
U {PPU[0x100001a] Thread (9ZWAM) [0x01789808]} sys_io TODO: cellMouseGetDataList
U {PPU[0x100001a] Thread (9ZWAM) [0x01789808]} sys_io TODO: cellMouseGetDataList
U {PPU[0x100001a] Thread (9ZWAM) [0x01789808]} sys_io TODO: cellMouseGetDataList


Attached Files
.7z   GT5_20171010.7z (Size: 110.89 KB / Downloads: 42)
Reply
#3
RPCS3 v0.0.3-3-882e949 Alpha
Confirmed Loadable after flash-fire merged his Page Fault implementation as with other GT titles. 
[Image: ab3c9628df.jpg]
Boots with both PPU LLVM and Interpreter however LLVM = White screen and Interpreter = Black.


Attached Files
.gz   RPCS3.log.gz (Size: 740.48 KB / Downloads: 16)
Reply
#4
RPCS3 v0.0.4-6200-8f314c51 Alpha
Intro


Attached Files Thumbnail(s)
   

.gz   RPCS3.log.gz (Size: 596.79 KB / Downloads: 6)
Reply
#5
RPCS3 0.0.4-6301

CPU: Intel Core i5-4460
RAM: 8GB DDR3
GPU: Nvidia GTX 1060 6GB
OS: Windows 10 Pro
Firmware: 4.82 (downloaded from Sony's website)
Console Language: English (US)

Game info from RPCS3:

[Image: dRC0VDZ.png]
The game loads up fine for me, but would eventually hang on this glitchy loading screen

[Image: VSBS4Su.png]

I played with the settings, and tried it enough times to get through that screen. I was greeted with this:

[Image: ZFBYFx7.png]

Then, it loaded the intro movie and hung.

[Image: ByQthmp.png]

I played around with it some more, but skipped the intro as soon as it popped up. This screen came up and hung:

[Image: 157rXQ7.png]

Now, I wanted to see how far I could possibly get through the intro movie. I changed the PPU decoder to the "Interpreter (fast)" option, and the SPU decoder to "Interpreter (fast)" and got this far in the intro movie (about 5-10 seconds in):

[Image: YLldPae.png]

I tried several times to get into the menu, but this screen would either load forever or hang.

[Image: V2MfcTf.png]

The log popped up with this error, and kept scrolling:

[Image: OC1C4qw.png]


Other random crashes would show a runtime error like this:

[Image: EKPMtcW.png]

Attached is my RPCS3.log.gz file. If anyone has gotten further, please share your settings and results with me because myself and many others would like to see this game working on their PC.

Hope this helps!
icomputer7


Attached Files
.gz   RPCS3.log.gz (Size: 842 bytes / Downloads: 10)
Reply
#6
Hello everyone, I tried GT5 BCUS98114 with all updates installed (till v2.17) and all DLCs installed .pkg but only displays the first copyright screen.

RPCS3 0.0.4-8bc7bb63b
Logs


Attached Files
.gz   RPCS3.log.gz (Size: 10 bytes / Downloads: 6)
.gz   oldRPCS3.log.gz (Size: 1.19 MB / Downloads: 12)
Reply
#7
BCUS98114, disc version (no updates). Can now get to pre-race in arcade mode, but it freezes at the menu. Car selection graphics work.
Menu music either cuts after a few seconds or doesn't work at all.
RPCS3 0.0.5-7492
[Image: RZJXusz.jpg]
[Image: IOMo582.jpg]
[Image: 4mhUFM7.jpg]

Log is too large to be attached. Link:
https://drive.google.com/file/d/1W9xaRqe...sp=sharing

Sorry for the consecutive posts, but as of 0.0.5-7496, Gran Turismo 5 is now in-game. Great work to the RPCS3 team!
[Image: uPDHY2a.jpg]
[Image: qFnUJBe.jpg]
Reply
#8
Does GT Mode work at this very moment? Also why are there graphical issues is something being incorrectly being loaded in the log files because so far the game runs at a decent framerate it is just that the game has graphical issues in both in game and in the Hud menus.
Reply
#9
BCUS98114, v2.01.

RPCS3 version: rpcs3-v0.0.5-7727-c5026f71_win64

Can open time trial and run around Tsukuba for a few minutes before it crashes, have to delete save game every time otherwise the game crashes on startup. Very prone to crashing in the main menu "cutscene" and car selection. The intro video works most of the time, when it doesn't it just freezes and is still skippable.

[Image: p0nWKhi.png]
[Image: laT1bdb.jpg]
Game looks pretty good, main problem seems to be in the lighting.
[Image: 9FBWCKZ.png]
[Image: ze72W1i.png]
[Image: KiOQJM6.png]
[Image: fvM3Vzx.jpg]
[Image: jEawZ7r.jpg]
[Image: glQ7X90.png]
[Image: 9wjAtZW.jpg]


Edit: Log not getting attached so here it is: https://drive.google.com/file/d/1OWfHWqW...sp=sharing

Edit 2: RPCS3 was displaying the wrong version number, recent build fixed it so I'll correct it here. (1.00 -> 2.01)
Reply
#10
0.0.6-7909-a254a203
GT5 v2.00 working very well on an i7-9700K. GT Mode is pretty stable and very playable. I was able to complete all license tests without any major issues.
[Image: Jb8cL2s.png][Image: pywwqEo.png][Image: 4JF2QIe.png]
[Image: DiNq3fw.png]

I'm able to achieve 60 FPS on most tracks during Practice and Time Trials using the roof cam. With a full grid of cars visible, the framerate dips to around 30 FPS.
Some reflections and/or specular highlights have odd tints to them, often glowing bright green or purple.
Special Stage Route 7 and the AMG Driving Academy Intermediate missions freeze during loading.
Longplay log attached (~700MB uncompressed) with crash during loading of AMG Driving Academy Intermediate Mission 1.
https://drive.google.com/open?id=1Fd64W3...5320-02sD8
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)