Hello There, Guest! Register

Metal Gear Solid 4: Guns of the Patriots [BLUS30109]
[Image: YqoNUdPukeeREME-800x450-noPad.jpg]

Game is still loadable with master (but of course Dodgy)
Displaying a 60fps black screen as before

Build used:
Anyone got some settings to share on this? I saw news posts that it gets to the menus now but have not been able to find out how they did that.
same here
I have a black screen with fps
is there any option available?
is it helpful to copy the log here so people who know what they do, can take a look?
Just wanted to add some info and a log here. 

On RPCS3 v0.0.5-6541, using the option 'Recompiler (ASMJIT)' results in an immediate crash for rpcs3. 
However, the game boots to black screen, 60fps using 'Interpreter (Fast)' . 

Tried many different CPU / GPU settings but they did not effect the emulation, far as I could tell. 

Attached is a log.

Attached Files
.7z   RPCS3.7z (Size: 67.11 KB / Downloads: 18)
This wont work until sys_overlay PR from numan is merged. It's been in the works for a long time even then it doesn't go ingame but it does reach menus.
SPU: LLVM without accurate float

Makes it to the main menu now and shows the cemetery for an instant but then black screens.

[Image: k4zlPPM.png]

Attached Files
.gz   RPCS3.log.gz (Size: 575.79 KB / Downloads: 2)

[Image: 9y5F7aq.png]
Couldn't attach log so added link to a download of it.
RPCS3 log
Is anyone else encountering a bug in the final boss fight? Have been using builds from the MGS4 Rajkosto fork fine up until this moment.

The first time you fight Ocelot, when his health bar reaches half you're supposed to transition to the next phase of the fight through a cutscene. Instead the transition never occurs and once his health bar reaches 40% it never decreases and you're stuck fighting him until you eventually die.

My settings

PPU Decoder : LLVM
SPU Decoder: LLVM
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: Auto
SPU Block Size: Safe
TSX Instructions: Enabled
Enable SPU loop Detection: True
SPU Cache: Enabled

Renderer: Vulkan
Anistropic Filter: Automatic
Anti-Aliasing: Disabled
Default Resolution: 1280X720
Resolution Scale: 300% (3840X2160)
Resolution Scale Threshold: 16X16
Multithreaded RSX: True

Audio Out: OpenAL
Downmix to Stereo : True
Enable Buffering: True (100ms)
Enable Time Stretching: True (70%)

Vblank Frequency: 240 Hz

*Debug Menu*
To enable debug menu, go to RPCS3 Folder, GUIconfigs, open CurrentSettings, change *showDebugTab* to true

Disable Zcull Occlusion Queries : True
Use GPU Texture Scaling: True

Tried multiple builds. Tried setting Interpreters all to precise and disabling debug options. Game is updated to v02.00. Firmware version 4.82
Hi.The game works fine ,but I have a big problem.Game freeze ,crash on the tv scenes/intro cutscenes after click new game and select difficult.Any fix these problem? Sorry for my english [Image: smile.png] [BLUS30109] Latest version rajkosto

Forum Jump:

Users browsing this thread: 1 Guest(s)