Hello There, Guest! Register

Diablo 3: Reaper of Souls - Ultimate Evil Edition [BLUS31437]
#11
As of 6649 the game is playable with very few crashes here and there.
However FPS fluctuates wildly on my rig, between 20 in the most crowded areas to 60fps in small ones; my rig being: I5-4440 3.2ghz, 16gb RAM, 960GT, game on SSD.

One thing to note as well, enabling SPU Loop Detection causes the game to crash almost immediately, to fix that you have to set the RPCS3 process to realtime priority in your task manager.
Reply
#12
(04-19-2018, 09:56 AM)Unforgiven Wrote: As of 6649 the game is playable with very few crashes here and there.
However FPS fluctuates wildly on my rig, between 20 in the most crowded areas to 60fps in small ones; my rig being: I5-4440 3.2ghz, 16gb RAM, 960GT, game on SSD.

One thing to note as well, enabling SPU Loop Detection causes the game to crash almost immediately, to fix that you have to set the RPCS3 process to realtime priority in your task manager.

need screenshots build name and log file uploaded.
Reply
#13
(04-19-2018, 09:56 AM)Unforgiven Wrote: As of 6649 the game is playable with very few crashes here and there.
However FPS fluctuates wildly on my rig, between 20 in the most crowded areas to 60fps in small ones; my rig being: I5-4440 3.2ghz, 16gb RAM, 960GT, game on SSD.

One thing to note as well, enabling SPU Loop Detection causes the game to crash almost immediately, to fix that you have to set the RPCS3 process to realtime priority in your task manager.

Interesting.  I have been trying to see what would make the game playable via settings to fix the memory error crash without any success. Setting the process to realtime seems to have fixed it at first glance.  I need to test a bit more but since setting the process priority I have not had a crash.  Usually it crashes after 2-5 minutes depending on luck but I was able to play for 30 minutes without a problem with that change.  Could the memory crash issue be related to some race condition?


i7-8700k 4.9ghz, 16gb RAM, 1070ti
Reply
#14
The crashes are totally random, I was able to play almost 2 hours but it crashed then.
I don't think that changing the process priority does anything.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#15
(04-29-2018, 03:21 PM)baguettez Wrote: The crashes are totally random, I was able to play almost 2 hours but it crashed then.
I don't think that changing the process priority does anything.

Not exactly, no. So far there are three things causing crashes in my case:
1- Not setting the process to realtime
2- Enabling "Lower SPU Thread Priority"
3- Setting "Preferred SPU Thread" to anything but "auto"

The third item is usually the one causing the crashes. If I leave it on auto I never experience any crashes, however I lose a LOT in terms of performance (the game becomes unplayable)

Here hoping future updates of the emu will fix this.
Reply
#16
(05-01-2018, 05:14 PM)Unforgiven Wrote:
(04-29-2018, 03:21 PM)baguettez Wrote: The crashes are totally random, I was able to play almost 2 hours but it crashed then.
I don't think that changing the process priority does anything.

Not exactly, no. So far there are three things causing crashes in my case:
1- Not setting the process to realtime
2- Enabling "Lower SPU Thread Priority"
3- Setting "Preferred SPU Thread" to anything but "auto"

The third item is usually the one causing the crashes. If I leave it on auto I never experience any crashes, however I lose a LOT in terms of performance (the game becomes unplayable)

Here hoping future updates of the emu will fix this.

None of that changes anything on my end, besides I've never set SPU threads to anything other than Auto, and the performance is the same.

Only way to play without crashes is to use Interpreter, but of course, that kills performance.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#17
I experience sound crackling whenever I am fighting mob of enemies, any Idea how to resolve this?

Params
SPU Threads 2/auto
RPCS3 Master
SPUASMJIT Recompiler
PPU LLVM Recompiler
Vulkan
XAudio
Reply
#18
(05-05-2018, 06:14 PM)organicchemistry_01 Wrote: I experience sound crackling whenever I am fighting mob of enemies, any Idea how to resolve this?

Params
SPU Threads 2/auto
RPCS3 Master
SPUASMJIT Recompiler
PPU LLVM Recompiler
Vulkan
XAudio

Pretty sure that's related to the framerate so unless the emulator itself improves there's no way around it.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#19
Games can have bad audio even when capped at the maximum framerate, usually it's from bad SPU performance. Can be resolved by turning off additional SPU options like SPU Loop Detection, Lower SPU Thread Priority and setting SPU threads to different values or auto. This doesn't always help though, a better cpu generally does.
Reply
#20
(05-06-2018, 04:58 AM)baguettez Wrote:
(05-05-2018, 06:14 PM)organicchemistry_01 Wrote: I experience sound crackling whenever I am fighting mob of enemies, any Idea how to resolve this?

Params
SPU Threads 2/auto
RPCS3 Master
SPUASMJIT Recompiler
PPU LLVM Recompiler
Vulkan
XAudio

Pretty sure that's related to the framerate so unless the emulator itself improves there's no way around it.


there is a way although it is a bit peculiar, I am playing it and I go for Act 2 on level 22, a jewel of play. Do the following with the open emulator open the task manager and go to details of rpcs3 and change the priority from normal to real time, you should also delete the caches so that it does not crash, I just as in this video I was able to play with the acceptable sound and variables fps, sorry for my poor english, greetings.
https://www.youtube.com/watch?v=oNudRl9UZe8
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)