Hello There, Guest! Register

Sly Cooper: Thieves in Time [BCUS98247]
#1
black screen after selecting New Game (same as EU version)

Code:
E {rsx::thread} RSX: Depth texture bound to pipeline with unexpected format 0x8B x6666



fast PPU and SPU interpreters
OpenGL

rpcs3-v0.0.2-2017-07-12-3b7b6ff4

Reply
#2
Same error.. any news?
Reply
#3
Emulation stops right after choosing New Game.

Using Vulkan Renderer and both PPU & SPU Recompiler.

RPCS3 Version: v0.0.3-3-c85806c ( August 20th 2017 )

Message:
Code:
·F 0:00:55.689822 {rsx::thread} class std::runtime_error thrown: Possible data corruption on frame context storage detected

Settings:

Code:
Core:
 PPU Decoder: Recompiler (LLVM)
 PPU Threads: 2
 PPU Debug: false
 Save LLVM logs: false
 Use LLVM CPU: ""
 SPU Decoder: Recompiler (ASMJIT)
 Bind SPU threads to secondary cores: false
 Lower SPU thread priority: true
 SPU Debug: false
 Maximum immediate DMA write size: 16384
 Preferred SPU Threads: 0
 SPU delay penalty: 3
 SPU loop detection: true
 Lib Loader: Automatically load required libraries
 Hook static functions: false
 Load libraries:
   []
Video:
 Renderer: Vulkan
 Resolution: 1280x720
 Aspect ratio: 16:9
 Frame limit: Off
 Write Color Buffers: false
 Write Depth Buffer: false
 Read Color Buffers: false
 Read Depth Buffer: false
 Log shader programs: false
 VSync: false
 Debug output: false
 Debug overlay: false
 Use Legacy OpenGL Buffers: false
 Use GPU texture scaling: true
 Stretch To Display Area: false
 Force High Precision Z buffer: false
 Invalidate Cache Every Frame: false
 Strict Rendering Mode: false
 Disable ZCull Occlusion Queries: false
 Disable Vertex Cache: false
 Enable Frame Skip: false
 Consecutive Frames To Draw: 1
 Consecutive Frames To Skip: 1
 D3D12:
   Adapter: AMD Radeon HD 7800 Series
 Vulkan:
   Adapter: AMD Radeon HD 7800 Series
 Batch Instanced Geometry: false
 Vertex Upload Threads: 1
 Multithreaded Vertex Upload Threshold: 512
 Consecutive Frames Drawn: 1
 Consecutive Frames Skept: 1



.7z   logs_sly4.7z (Size: 105.33 KB / Downloads: 7)
Reply
#4
Same here. When I create a new game, I can see just for a second the loading screen, but then it all goes black.
Reply
#5
Rpcs3 ver. 0.0.3-2017-09-28-eb8af974
PPU: Recompiler
SPU: Recompiler
libaudio
OpenGL

The game only displays menu text. Everything else is black. Same thing ingame.
[Image: 2859ce9cb5e9bbd252be92c14f32493c.jpg]
The dynamic loading screen is now working, but it claims that i have -317% trophies.

Same settings used to work "fine" with v0.0.3-2017-09-14-07af701a

X5460 4.3Ghz, GTX480
Reply
#6
RPCS3 v0.0.4-2017-11-26-1344f15e
PPU: Recompiler
SPU: Recompiler
libaudio
OpenGL

The rendering issue is now fixed, and seems to work as it used to. The game still crashes randomly.
[Image: 467e81b2e04a5ab1afa42a2ad47e36fb.png]
X5460 4Ghz, GTX480 800Mhz


Attached Files
.gz   RPCS3.log.gz (Size: 1.27 MB / Downloads: 6)
Reply
#7
@Goustoulos archive is broken, cant extract log, also i'm guessing this is ingame? best to take screenshots where it's clear that you can control the character
Reply
#8
The screenshot was taken right after the game freezed. Next time i'll know to screenshot when the game is running.
Played about 3 or 4 minutes before it crashed. I will re-test it when i get back home and reupload the archive.

Edit:I am sorry for being so late.
Re-tested with rpcs3-v0.0.4-2017-12-01-8f314c51.
PPU: Recompiler
SPU: Recompiler
Auto libraries
OpenGL

The game now has sound ingame(i m pretty sure it wouldnt go ingame without libaudio before). Still crashes randomly, and the sound is laggy(i guess because of the low fps i get with my old cpu). When the game freezes, the sound keeps playing without any lag.

X5460 4Ghz, GTX480


Attached Files
.gz   RPCS3.log.gz (Size: 659.21 KB / Downloads: 4)
Reply
#9
I report that the audio has now been fixed (even tho it stutters badly on my computer).
Goes ingame with "Load liblv2.sprx only".
OpenGL renders almost fine, but everything is displayed with a yellowish color tint from some angles, while Vulkan renders almost everything black. Remember to disable Strict Rendering Mode.
Reply
#10
Audio works. (Still stutters badly a least on my computer)
Goes in-game with Load liblv2.sprx only and Automatically load required libraries
OpenGL renders fine, but cel-shading doesn't work. Vulkan works perfectly for me no. Flickers on 2d story intro.
Opens to menu with LLVM Recompiler But freezes on loading screen if tried playing with.
Runs about 20-35fps did drop to 10fps in intensive areas.

I5-4590 3.3 GHz, GTX970
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)