God of War III [BCUS98111]
Started by wffl

26 posts in this topic

1 posts 0 threads Joined: Jun 2020
06-18-2020, 04:49 PM -
I'm testing now, Ryzen 3800x and RTX 2080 Ti. My experience seems consistent with quik.sliver1's - cut-scenes and menus run at 50+ fps, I hit 3000 fps while rendering the Sony logo (lol), but gameplay sits at 15-20 FPS. Sort-of playable, but painful. I imagine an Intel CPU could get a better framerate. My only change was to change Delay Driver Wakeup to 200, resolution at 300%, and to framelimit to 60 because some of the cut-scenes were running at 70+ fps and causing tearing on my 60 Hz monitor.

33 posts 0 threads Joined: Jul 2020
09-06-2020, 09:20 PM -
After seeing BSoD Gaming's video about recent improvements in God of War 3 , 

I decided to try it for myself, since my setup is quite similar to his and might be slightly better

Huge improvements and is closed to original native P3 experience, but the remaster on PS4 is still the best version of this game, with 1080P and locked 60fps. I'm sure this game will keep improving on rpcs3, and given time, we will see 4K locked 60fps one day. looking forward to it Tongue

Follow up video testing CPU utilization, this game starts at 41:48
This post was last modified: 09-14-2020, 01:10 AM by ldczzyy.

28 posts 3 threads Joined: Dec 2018
09-07-2020, 03:06 AM -
whenever i uncheck the "Accurate xfloat" the renderer became plain, such as in menu (New game, Load game,...), there are nothing to be seen, except yellow rain, and some lighting in the grey background, without Kratos. therefore I cant get into ingame.

is this "Accurate xfloat" needed to be on? or i should setting my nvidia control panel?

10 posts 0 threads Joined: Dec 2017
02-08-2021, 05:09 PM -
I am getting strange resolution scaling issues. Like a vaseline smearing across the screen. I am using all patches, including the ones to disable MLAA that should allow resolution scaling, and am getting the same error when scaling to 200%, 300%, with scale threshold set to 1x1, 16x16, and 160x160. Are some of these patches incompatible with each other?

100 posts 0 threads Joined: Mar 2020
10-18-2021, 08:44 AM -
Almost Playable
Updating of post #16, lighting graphic effect is adaptively well-rendered using some new patches & config.  Multiple intel CPUs shows proportional performance in FPS 
  • 4C8T [i7-4800MQ] – Ingame, Laggy/Stuttering Gameplay, 60FPS Cutscenes/Menu (SSD @ SATA 3.0)
  • 6C12T [i7-8750H] – Fine after multiple run with random crashes (NVMe @ PCIe 3)
  • 8C16T [i7-11800H] – Flawless (NVMe @ PCIe 3) – AVX-512
  • 8C16T [i9-10980HK] – Flawless (NVMe @ PCIe 3)
  • 8C16T [i9-9900K] – Flawless (NVMe @ PCIe 3)
# Gameplay Variable FPS = (29~47~60) – Unlocked FPS
# Cutscenes stable (59~60)
# RPCS3 v0.0.18-12902-683c061e Alpha
# Non-Default setting [Res. Scale= 300% Fullscreen 4K]
# RPCS3 Patch Manager used (thanks to RPCS3 teams & the contributors illusion001 & Zerox latest patches)
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia | NVMe storage (3500MB/2500MB Read/Write).

@ Graphic Config
# Enable list of patches depicted in attached picture (Patch Manager)

@ CPU Config @ 9900K
# Set Driver Wake-Up Delay = 350us (Advanced)
# Enable TSX Instruction (CPU)  

@ CPU Preferable FPS++ Performance & Support
# Enable Accurate RSX reservation access (Advanced)     – AMD/non-TSX Intel
# Enable Full Width AVX-512 (CPU)                                          – 11th  Intel CPU
# Set ZCULL Accuracy = Approximate (GPU)
# Set SPU Block Size = Mega (CPU)
This post was last modified: 10-18-2021, 08:51 AM by quick.sliver1.

Attached Files Thumbnail(s)

.7z   RPCS3+TTY [4C,6C,8C].7z (Size: 1.17 MB / Downloads: 93)

98 posts 1 threads Joined: Jun 2018
03-16-2022, 12:48 AM -
RPCS3 Version: 0.0.21-13349-f3a325fe Alpha

Has this game badly regressed with the latest build? It builds cache and then closes out. I've tried every setting listed here and elsewhere....

Last lines in log are:

U sys_prx TODO: _sys_prx_stop_module(): cmd is 8 (stop function = *0x9f0100)
U sys_prx TODO: _sys_prx_stop_module(): cmd is 8 (stop function = *0x9904d8)
U sys_prx TODO: _sys_prx_stop_module(): cmd is 8 (stop function = *0x930814)
S sys_process: Process finished
Tio Flash Gamer

1 posts 0 threads Joined: Mar 2022
05-14-2022, 03:46 AM -
I played with the average above 100 fps
my gameplay and settings

Forum Jump:

Users browsing this thread: 2 Guest(s)