Hello There, Guest! Register

The Sly Trilogy [BCES00968]
#1
RPCS3 v0.0.2-11-67cebb4 Alpha

Main menu, then black screen after choosing any of the games.
Reply
#2
(06-07-2017, 04:31 PM)wffl Wrote: RPCS3 v0.0.2-11-67cebb4 Alpha

Main menu, then black screen after choosing any of the games.

Has it a executable (.self/.elf) file per game? (Like in The Ratchet & Clank Trilogy)
Desktop: Intel Core i7-6700K, Nvidia GeForce GTX 970 (OpenGL, DirectX12 & Vulkan), Windows 10
Laptop: Intel Core i7-7700HQ, Nvidia GeForce GTX 1060 (OpenGL, DirectX12 & Vulkan), Windows 10
Reply
#3
(06-07-2017, 06:48 PM)MarioSonic2987 Wrote: Has it a executable (.self/.elf) file per game? (Like in The Ratchet & Clank Trilogy)

Yes, 1 self for each. Sly 1 loadable, 2-3 intro when booting from self.
Reply
#4
RPCS3 v0.0.3-3-cde29ab Alpha

Boot selector now works for all games (most likely fixed by Neko's PR at the end of August.) However it does seem to cause some issues when not booting from the .self for Sly2.
[Image: 7b0827e318.png]

Sly 1 loadable:
[Image: 2c3541942e.png]

Sly 2 renders ingame cutscene with no audio I wasn't able to progress past this scene despite pressing every button, game still running.
[Image: c91c7beca5.png]
I did get this once as well: F {PPU[0x1000000] Thread (main_thread) [0x002364b4]} MEM: Access violation reading location 0x430ed604


Sly 3 is loadable (blackscreen with FPS showing) different GPU settings didn't help
[Image: 57b53d9e8f.png]
Once more trophy functions are working it may progress further.


Attached Files
.gz   Sly_Cooper_Trilogy.log.gz (Size: 217.3 KB / Downloads: 10)
Reply
#5
Test 1
Build used: rpcs3-v0.0.3-2017-11-11-8fc98626_win64

Some progress in Sly 3 with Vulkan, as some part of the intro was able to be played before the whole rpcs3 emulator would crash.
https://youtu.be/ZECGEL-DRnY

Last lines of the log file before crashing:
Code:
E {PPU[0x1000007] Thread (TrophyThread) [0x0024d460]} sceNpTrophy: sceNpTrophyRegisterContext(context=0x1, handle=0x1, statusCb=*0x413a28, arg=*0x0, options=0x1)
E {PPU[0x1000007] Thread (TrophyThread) [0x0024d4c0]} sceNpTrophy: sceNpTrophyGetGameInfo(context=0x1, handle=0x1, details=*0x202bd740, data=*0xd00a8870)
E {PPU[0x1000007] Thread (TrophyThread) [0x0024d694]} sceNpTrophy: sceNpTrophyGetTrophyUnlockState(context=0x1, handle=0x1, flags=*0xd00a87b4, count=*0xd00a87b0)
F {rsx::thread} class std::runtime_error thrown: [attrib buffer] Working buffer not big enough, buffer_length=268435456 allocated=263474176 requested=2448644 guard=4194304 largest_pool=2883584
(in file c:\projects\rpcs3\rpcs3\emu\rsx\d3d12\../Common/ring_buffer_helper.h:78)


Test 2

build used: rpcs3-v0.0.4-2017-11-12-0064976c_win64

By using OpenGL the error in the previous post disappears, which enable to pass the pause menu and reach to the first conversation, in which like with Sly 2 the game gets stuck.

Some images


Attached Files
.gz   RPCS3_test_1.log.gz (Size: 407.29 KB / Downloads: 3)
.gz   RPCS3_test2_.log.gz (Size: 268.17 KB / Downloads: 2)
Reply
#6
Could someone test it again?
If I do not have it down and I'll tell
Reply
#7
Report for version 0.0.4-6345-f908daf32 Alpha
Hardware: Ryzen 7 1700X (factory clock), 32GB of RAM (oc @ 2933 MHz), MSI GTX 1080 G3 gaming (factory clock)

Recompiler enabled for both PPU and SPU.

The runs fine to the game selection menu with both OpenGL and Vulkan.
Attached "boot-to-menu.log" for log sequence from game boot to game selection menu.

Vulkan
Attempting to boot the 3 Sly games results in (numbered list number corresponds to the game)

  1. Window is created and destroyed after few instants, emulator doesn't crash but the game process closes. sly1-vulkan.log
  2. Window is created, initial cutscene starts (heavy glitches, see sly2-vulkan.1.png), sometime it freezes before making it to the main menu (sly2-vulkan.1.log). Main menu has minor glitches, z buffering looks pretty much random, performance is poor. Starting the game works, performance still poor, trying to proceed in the level results in major glitches (sly2-vulkan.{2-4}.png) & finally black screen with health bar still showing. Nothing very interesting in the log (sly2-vulkan.2.log). Also tried with Strict Rendering, similar results, with ~40% performance loss.
  3. Window is created, initial cutscene starts, never makes it past the initial "Thievius Raccoonus" animation, after which the window is destroyed just like with Sly 1. sly3-vulkan.log
OpenGL
  1. Same. Log also looks identical, call by call
  2. Window is created, initial cutscene starts. Performance is terrible (few FPS), and the screen is a mess of random polygons filled with colored noise patterns for 90% of the time (sly2-opengl.{1-3}.png). Starting the game works, performance stays bad, making my way through the glitched graphics (pretty much by heart and luck) I could progress to the same part of the level where the screen became black in my Vulkan test: same result. Again, the log looks exactly the same.
  3. Same old

.7z   BCES00968 0.0.4-6345-f908daf32 Alpha.7z (Size: 3.57 MB / Downloads: 10)
Reply
#8
RPCS3 v0.0.5-6998-3935cef69 Alpha | HEAD
All threee games included in the trilogy now go Ingame!
I even finished the first game so that one is playable. without any major issues.
Sly 2 has an issue where the screen goes black, sly 3 only goes ingame with the standalone PSN versions not in the collection.


Attached Files Thumbnail(s)
       

.gz   RPCS3.log.gz (Size: 802.43 KB / Downloads: 5)
Reply
#9
Hello im new to Emulating to this and i wanted to play my Sly 3 Collection on my Laptop but i can't get it to run and i know that it doesnt work to 100% right now but i can't get trough to any game everytime i start it i get a black screen and only the music plays so if someone could give me the right Configurations to atleast play a bit would be great.

I have a Laptop with i7-7700HQ Nvidea Gefroce 1070 and 16GB Ram

sooo if someone could help me give me some tips or something that helps me and yes i played already around with the settings but i don't get trough this black screen :c
Reply
#10
Sly 3 only works on the standalone PSN edition at the moment sadly.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)